在线检测未来函数

通达信漂亮并且很准的顶底判势指标公式

来源:Internet,编辑:股旁网,2016-11-01

STICKLINE(C>0,0,10,6,0),COLOR000068;
STICKLINE(C>0,90,100,6,0),COLOR000068;
蓝魔:(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*300,COLORRED,LINETHICK0;
STICKLINE(蓝魔>0,0,蓝魔,4,0),COLORBLUE;
STICKLINE(蓝魔>0,0,蓝魔,3.5,0),COLORFF3300;
STICKLINE(蓝魔>0,0,蓝魔,3,0),COLORFF5500;
STICKLINE(蓝魔>0,0,蓝魔,2.5,0),COLORFF7700;
STICKLINE(蓝魔>0,0,蓝魔,2,0),COLORFF9900;
STICKLINE(蓝魔>0,0,蓝魔,1.5,0),COLORFFBB00;
势:MA((((-100))*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21))+100,5),COLORGREEN;
AA:=(O+H+L+C)/4;
A1:=HHV(AA,15);
A2:=LLV(AA,15);
A3:=A1-A2;
A4:=EMA((AA-A2)/A3,2)*100;
快马加鞭:A4,LINETHICK2,COLORRED;
虹:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-
LLV(LOW,27))*100,5,1)-2*SMA
(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-
LLV(LOW,27))*100,5,1),3,1),COLORYELLOW,LINETHICK2;
顶部区域:=((CLOSE > (MA(CLOSE,54.16) + (2 * STD(CLOSE,170)))) * 130);
STICKLINE((顶部区域 >= 20),111,117,4,0),COLORCYAN;
清仓:=IF(((EMA(((100 * (CLOSE - LLV(LOW,34))) / (HHV(HIGH,34) - LLV(LOW,34))),3) / 1) > 92),(EMA(((100 * (CLOSE - LLV(LOW,34))) / (HHV(HIGH,34) - LLV(LOW,34))),3) / 1),0);
STICKLINE((清仓 >= 70),112,114,4,0),COLORRED;
MN:=MA(((((((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100) + (((2 * (CLOSE - MA(CLOSE,12))) / MA(CLOSE,12)) * 100)) + (((3 * (CLOSE - MA(CLOSE,24))) / MA(CLOSE,24)) * 100)) / 6),3);
抄底:=MA(((((((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100) + (((2 * (CLOSE - MA(CLOSE,12))) / MA(CLOSE,12)) * 100)) + (((3 * (CLOSE - MA(CLOSE,24))) / MA(CLOSE,24)) * 100)) / 6),3);
STICKLINE((抄底 < (0 - 6)),(0 - 15),(0 - 23),4,0),COLORBROWN;
STICKLINE((MN < (0 - 9)),(0 - 17),(0 - 21),4,0),COLORLIBLUE;
STICKLINE((MN < (0 - 12)),(0 - 17),(0 - 21),4,0),COLORRED;
VAR1K:=(((LOW + HIGH) + (2 * CLOSE)) / 4);
VAR2K:=REF(VAR1K,1);
VAR3K:=((SMA((VAR1K - VAR2K),5,1) / SMA(ABS((VAR1K - VAR2K)),5,1)) * 100);
MMS:=(MA(VAR3K,1) + 50);
STICKLINE((MMS >= 100),110,108,2,0);
STICKLINE((MMS >= 100),109,107,4,0),COLORFFFFFF;
VAR03:=((((CLOSE - LLV(CLOSE,10)) / (HHV(CLOSE,10) - LLV(CLOSE,10))) * 100) = 100);
STICKLINE((VAR03 > 0),103,106,4,0),COLORGREEN;
VARAA:=AMOUNT/(100*VOL);
CYC13:=MA(VARAA,13);
CYC34:=MA(VARAA,34);
CYCMAX:=DMA(C,VOL/CAPITAL);
CYS13:=(C-CYC13)/CYC13*100;
CYS34:=(C-CYC34)/CYC34*100;
CYSMAX:=(C-CYCMAX)/CYCMAX*100;
亏损程度:
STICKLINE(CYS13<=-10,50,55,3,1 ),COLORAA66FF;
STICKLINE(CYS13<=-16,50,60,3,0),COLORAAAACC;
STICKLINE(CYS13<=-20,50,65,3,1),COLOR00AAFF;
STICKLINE(CYS13<=-25,50,70,3,0),COLORWHITE;
STICKLINE(CYS13<=-30,50,75,3,1),COLORRED;

通达信漂亮并且很准的顶底判势指标公式

 

相关文章