在线检测未来函数

通达信霸气波段指标公式

来源:Internet,编辑:股旁网,2016-11-17

N:=14;MM:=4;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/MTR,LINETHICK1,COLORWHITE;
MDI:=DMM*100/MTR,LINETHICK1,COLORYELLOW;
ADX:= EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM),COLORMAGENTA, ;
ADXX:= EXPMEMA( (MDI-PDI)/(MDI+PDI)*100,MM),COLORMAGENTA, ;
ADXXX:=REVERSE(ADXX),COLORMAGENTA, ;
ADXR:=EXPMEMA(ADX,MM),COLORGREEN,DOTLINE;
ADXRR:=EXPMEMA(ADXX,MM),COLORGREEN,DOTLINE;
ADXRRR:=REVERSE(ADXRR),COLORGREEN, ;
DRAWBAND(REVERSE(ADXX),RGB(250,150,0),REVERSE(ADXRR),RGB(0,150,250));
新SAR101:=NEWSAR(1,100),COLORLIMAGENTA;
波霸:新SAR101<REF(新SAR101,1) AND REF(新SAR101,1)<REF(新SAR101,2) AND REF(新SAR101,2)<REF(新SAR101,3) AND C>新SAR101,NODRAW;{选股时去掉前面的等号}
DRAWICON(波霸,REVERSE(ADXRR),23);

大智慧霸气波段指标公式

 

相关文章