在线检测未来函数

通达信顺水推舟指标公式

来源:Internet,编辑:股旁网,2016-12-07

{KKDD中线}
LOWV1:=EMA(LLV(LOW,34),3);
HIGHV1:=EMA(HHV(HIGH,34),3);
RSV1:=EMA((CLOSE-LOWV1)/(HIGHV1-LOWV1)*100,3);
50,COLORRED,LINETHICK2;
105,COLORFF7F00,DOTLINE;
{强势有效}
DIFF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
短线买点:=CROSS(((DIFF1-EMA(DIFF1,9))*10-REF((DIFF1-EMA(DIFF1,9))*10,1)),1) AND (DIFF1-EMA(DIFF1,9))*10>1;
STICKLINE(短线买点>0,0,45,1.3,0),COLOR008888;
STICKLINE(短线买点>0,0,45,0.9,0),COLOR00AAAA;
STICKLINE(短线买点>0,0,45,0.6,0),COLOR00DDDD;
STICKLINE(短线买点>0,0,45,0.2,0),COLOR00FFFF;
DRAWTEXT(短线买点>0,43,'☆预警'),COLOR00FFFF,LINETHICK1;
0,COLORWHITE,LINETHICK1;
{KDJ短线}
RSV:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
短线2:SMA(RSV,3,1),COLORWHITE,LINETHICK2;
D:=SMA(短线2,3,1),COLOR00FFFF,LINETHICK2;
{J线没未来}
短线1:3*短线2-2*D,COLOR00FFFF,LINETHICK2;
IF(短线1<REF(短线1,1),短线1,DRAWNULL),COLORGREEN,LINETHICK2;
IF(短线1>REF(短线1,1),短线1,DRAWNULL),COLORRED,LINETHICK2;
{KDJ红绿相交}
DRAWICON(CROSS(短线1,D) AND CROSS(短线1,短线2),0,25);
DRAWICON(CROSS(D,短线1) AND CROSS(短线2,短线1),110,27);
{KKDD红绿箭头}
{横盘启动}
LOWV:=LLV(LOW,15); {15天内的最低价}
HIGHV:=HHV(HIGH,15); {15天内的最高价}
HIGHVV:=HHV(HIGH,40); {40天内的最高价}
V0:=V; {当天的成交量}
V1:=REF(V,1); {一天前的成交量}
V2:=REF(V,2); {两天前的成交量}
V3:=REF(V,3); {三天前的成交量}
HV22:=HHV(V,35); {35天内的最大成交量}
D0U:=C>O; {今天是阳线}
D1U:=REF(C,1)>=REF(C,2); {昨天是阳线}
横盘:=((HIGHV-LOWV)/HIGHV)<0.15; {半个月内价格波动小于15%}
放量1:=V0>=(1.8*((V1+V2+V3)/3)); {今天量是前三天均量的1.8倍}
放量2:=V0<=(3.8*V1); { 今天的量在昨天量的四倍范围内}
今天阳线:=D0U; {今天是阳线}
昨天阳线:=D1U; {昨天是阳线}
今天中阳:=(C-REF(C,1))/REF(C,1)>=0.018; {今天涨幅大于1.8%}
开盘非最高价:=C<=HIGHVV; {收盘非40天内最高价}
收盘非最高价:=O<=HIGHVV; {开盘非40天内最高价}
非最大成交量:=V0<HV22; {非一个月内最高成交量}
启动突破:=横盘 AND 放量1 AND 放量2 AND 今天阳线 AND 昨天阳线 AND 今天中阳 AND 开盘非最高价 AND 收盘非最高价 AND
非最大成交量;
IF(启动突破>0,48,0),COLORWHITE,LINETHICK2;
DRAWTEXT(启动突破>0,45,'启动'),COLORFFFFFF;
DRAWTEXT(ISLASTBAR,55,'↓弱'),COLORGREEN;
DRAWTEXT(ISLASTBAR,5,'准备'),COLORCYAN;
20,COLOR4080FF,DOTLINE;
DRAWTEXT(ISLASTBAR,25,'关注'),COLOR4080FF;
40,COLOR00FFFF,DOTLINE;
60,COLORLIRED,DOTLINE;
DRAWTEXT(ISLASTBAR,65,'↑强'),COLORRED;
85,COLORA943FF,DOTLINE;
DRAWTEXT(ISLASTBAR,90,'强势'),COLORRED;

通达信顺水推舟指标公式

 

相关文章