在线检测未来函数

通达信价格区间统计主图指标公式

来源:Internet,编辑:股旁网,2017-01-06

时长:=120;
换手次数:=2;
选择方式:=1;
统计时长:IF(选择方式=1,CONST(SUMBARS(V/FINANCE(7)*100,换手次数)),时长),NODRAW;
KK:=统计时长;
高:=CONST(HHV(H,KK));
低:=CONST(LLV(L,KK));
STICKLINE(CURRBARSCOUNT=KK,高,低,0,0);{竖线统计起点位置}
XX:=(高-低);
均价:AMOUNT/V/100,NODRAW;
L0:=低+XX*0/9;
L1:=低+XX*1/9;
L2:=低+XX*2/9;
L3:=低+XX*3/9;
L4:=低+XX*4/9;
L5:=低+XX*5/9;
L6:=低+XX*6/9;
L7:=低+XX*7/9;
L8:=低+XX*8/9;
L9:=低+XX*9/9;
MLZ:=SUM((CURRBARSCOUNT<KK+1)*V,KK),NODRAW;
ML1:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L0-0.001,L1+0.001))*V,KK)/MLZ;
STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML1*200)),L0,L1*0.99,5,0),COLORFF5555;
ML2:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L1,L2+0.001))*V,KK)/MLZ;
STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML2*200)),L1,L2*0.99,5,0),COLORFFAA55;
ML3:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L2,L3+0.001))*V,KK)/MLZ;
STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML3*200)),L2,L3*0.99,5,0),COLORAAFF55;
ML4:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L3,L4+0.001))*V,KK)/MLZ;
STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML4*200)),L3,L4*0.99,5,0),COLOR5FFF00;
ML5:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L4,L5+0.001))*V,KK)/MLZ;
STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML5*200)),L4,L5*0.99,5,0),COLORFFFFF0;
ML6:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L5,L6+0.001))*V,KK)/MLZ;
STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML6*200)),L5,L6*0.99,5,0),COLORFF0FFF;
ML7:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L6,L7+0.001))*V,KK)/MLZ;
STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML7*200)),L6,L7*0.99,5,0),COLOR509FDD;
ML8:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L7,L8+0.001))*V,KK)/MLZ;
STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML8*200)),L7,L8*0.99,5,0),COLORAA5DDD;
ML9:=SUM((CURRBARSCOUNT<KK+1 AND RANGE(均价,L8,L9+0.001))*V,KK)/MLZ;
STICKLINE(CURRBARSCOUNT<CONST(INTPART(ML9*200)),L8,L9*0.99,5,0),COLOR0055DD;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,30);
MA4:MA(CLOSE,60);

通达信价格区间统计主图指标公式

 

相关文章