在线检测未来函数

通达信CCI改编指标公式

来源:Internet,编辑:股旁网,2017-02-06

均价:=(2*C+(C+H+L+O)/4+O)/4;
R:=(2*L+3*均价)/5;R1:=(2*H+3*均价)/5;KX:=(R+R1)/2;
CCI:(R-MA(R,84))/(0.015*AVEDEV(R,84))/200,COLORYELLOW;
做多:(3*SMA(CCI,2,1)+2*SMA(SMA(CCI,2,1),2,1))/5,COLOR6600FF;
STICKLINE(CCI<做多,做多,CCI,2,0),COLORRED;
STICKLINE(CCI<做多,做多,CCI,2,0),COLORBROWN;
OBV:=SUM(IF(KX>REF(KX,1),VOL,IF(KX<REF(KX,1),-VOL,0)),0);
OBV13:=(MA(OBV,1)-MA(OBV,13))/MA(OBV,13)*100;
OBV52:=(MA(OBV,1)-MA(OBV,52))/MA(OBV,52)*100;
OB:=(3*OBV13+2*OBV52)/5,COLORWHITE;
趋势:=EMA(OB,13/2),COLORGREEN;
地:=LLV(MA(OB,1),26),COLOR00AA99;
天:=HHV(MA(OB,1),26*2/3),COLORRED;
STICKLINE(CCI>=0 ,0,CCI,3,0),COLORYELLOW;
STICKLINE(CCI>=0.5 ,0.5,CCI,3,0),COLORRED;
N:=60;
BC:=(IF(C>(H+L+C)/3,(H*0.618+L*0.382)*0.382,(H*0.382+L*0.618)*0.382)+(O*0.382+C*0.618)*0.618);
EMN:=EMA((MA(BC,N)+SMA(BC,N,N/3))/2,N),COLOR6600FF;
空头:=EMA((EMN-(C-EMN)*C),1),COLORGREEN;
AA05:=MA(空头,3),COLOR0099CC;
STICKLINE(AA05<EMN AND CCI>=0 ,0,CCI/2,3,0),COLORMAGENTA;
关注:CROSS(做多,0),NODRAW;
DRAWICON(关注,-0.1,1);

通达信CCI改编指标公式

 

相关文章