在线检测未来函数

通达信魔鬼中长线指标公式

来源:Internet,编辑:股旁网,2017-02-15

LL:=26;
S:=12;
M:=9;
DIFF :=( EMA(CLOSE,S) - EMA(CLOSE,LL))*100;
DEA :=EMA(DIFF,M);
MACD :=2*(DIFF-DEA);
绿柱消失阳根起:IF(DIFF<0,DIFF,0),STICK,LINETHICK7,COLOR00FF00;
0,STICK,LINETHICK1,COLOR000000;
红柱上涨:IF(DIFF>=0,DIFF,0),STICK,LINETHICK7,COLORRED;
IF(DEA>=0,DEA,0),STICK,LINETHICK7,COLORMAGENTA;
IF(DEA<0,DEA,0),STICK,LINETHICK7,COLORYELLOW;
绿柱跌:IF(DIFF<0,DIFF,0),STICK,LINETHICK7,COLORGREEN;
卖出:=IF(DIFF>=0 AND DEA>=DIFF AND REF(DIFF,1)>REF(DEA,1),-20,0),COLORWHITE;
IF(DIFF>=0 AND DEA>=DIFF AND REF(DIFF,1)>REF(DEA,1),-20,0),STICK,LINETHICK5,COLORGREEN;0,STICK,LINETHICK2,COLORWHITE;
买入:=IF(DIFF<=0 AND DEA<=DIFF AND REF(DIFF,1)<REF(DEA,1),0,20),COLORRED;
IF(DIFF<=0 AND DEA<=DIFF AND REF(DIFF,1)<REF(DEA,1),20,0),STICK,LINETHICK5,COLOR00FF00,COLORRED;0,STICK,LINETHICK2,COLOR00FF00,COLORRED;
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
逃跑线: 80,COLORYELLOW;
VAR2:=LLV(LOW,34);
VAR3:=HHV(HIGH,34);
生命线: EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13),LINETHICK2,COLORCYAN;
魔鬼线: EMA(生命线,3),LINETHICK1,COLORYELLOW,;
低吸: 20;
强弱分界: 50,LINETHICK1,COLORRED;
VAR4:=IF(CROSS(生命线,魔鬼线),40,14);
VAR5:=IF(CROSS(魔鬼线,生命线),25,78);
DRAWTEXT(ISLASTBAR,-40,'绿柱跌'),COLORWHITE;
DRAWTEXT(ISLASTBAR,40,'红柱涨'),COLORWHITE;

通达信魔鬼中长线指标公式

 

相关文章