在线检测未来函数

通达信金波银浪指标公式

来源:Internet,编辑:股旁网,2017-02-24

LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
LLW:EMA(RSV,3),COLORWHITE,LINETHICK2;
LQR:MA(LLW,3),COLORYELLOW,LINETHICK2;
RSVZ:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
PKZ:=SMA(RSVZ,5,1);
PDZ:=SMA(PKZ,6,1);
PJZ:=3*PKZ-2*PDZ;
LX:=PERIOD;
ZQ:=IF(LX=5,4,IF(LX=4,4,IF(LX=2,8,4)));
DXW:=IF((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),1,0);
MR1:=SUM(DXW,ZQ);
ZS2:=IF(MR1>0,1,0);
RSV1:=(CLOSE - LLV(LOW,18))/(HHV(HIGH,18) - LLV(LOW,18))*100;
K1:=EMA(RSV1,3);
D1:=EMA(K1,3);
J1:=(3*K1-2*D1);
KDJ1:=REF(COUNT(J1<REF(J1,1),5)>=3,1) AND REF(J1,1)<20;
KDJ2:=J1>REF(J1,1);
FZ:=SUM(IF(FILTER(KDJ1 AND KDJ2,3),30,0),ZQ);
ZS3:=IF(FZ>0,1,0);
MD:=ZS2 AND ZS3;
TYP:=(HIGH+LOW+CLOSE)/3;
AZZ:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
ZBPD:=IF(LLW>=LQR OR AZZ>=-100,1,0);
MR:=MD AND ZBPD;
XSZQ:=IF(PERIOD=5,3,4);
DYC:=IF(SUM(MR,XSZQ)>1,0,1);
买入:IF(MR AND DYC,50,0),STICK,COLORRED,LINETHICK2;
DRAWTEXT(MR AND DYC,20,' 买入'),COLORRED;
DRAWICON(DXW,10,1);
底部:IF(CLOSE<MA(L+(H-L)/2,25)*0.95,1,0),NODRAW,COLORMAGENTA;
STICKLINE(底部,0,5,5,1),COLORMAGENTA;
HSL:=(VOL/CAPITAL)*100;
HSL2:=MA(HSL,2),COLORWHITE;
HSL10:=MA(HSL,10);
CS1:=COUNT(HSL2>REF(HSL2,1),3);
CS2:=COUNT(HSL10>REF(HSL10,1),3);
HSLPD:=IF(CS1=3 AND CS2=3,0,1);
ZF:=(ABS(CLOSE-OPEN)/REF(CLOSE,1))*100;
ZHB:=(ZF/HSL)*100;
ZHB10:=MA(ZHB,10);
NOSL:=IF((VOL>REF(MA(VOL,3),1)*0.6),1,0);
ZX:=LOW+(HIGH-LOW)/2;
ZXMAX:=HHV(ZX,10);
ZXPD:=IF(ZX<ZXMAX,0,1);
DQPD:=IF(CLOSE<MA(C,10) OR CLOSE<MA(C,20),0,1);
GD1:=IF(PJZ>=100,1,0);
GD2:=COUNT(PJZ>=100,3);
GDCS:=IF(GD2>0,1,0);
KDJPD:=IF(GD1 OR GDCS,1,0);
ZHBBJ:=HHV(ZHB10,5);
TD2:=IF(ZX=ZXMAX AND ZHB<ZHBBJ,1,0);
TD3:=IF(KDJPD AND DQPD AND HSLPD AND NOSL AND TD2,1,0);
悬崖勒马:IF(TD3,100,0),STICK,COLORGREEN,LINETHICK2;
DYC2:=IF(SUM(TD3,8)>1,0,1);
DRAWTEXT(TD3 AND DYC2,70,' 悬崖勒马'),COLORGREEN;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),90,2);
顶部:IF(HIGH>MA(L+(H-L)/2,25)*1.15,1,0),NODRAW,COLORCYAN;
STICKLINE(顶部,100,95,5,1),COLORCYAN;
HQ1:=BARSLAST(CROSS(MA(C,5),MA(C,60)));
HQ2:=BARSLAST(CROSS(MA(C,60),MA(C,5)));
STICKLINE(HQ1<HQ2,0,1,1,0),COLORRED;
STICKLINE(HQ1<HQ2,100,99,1,0),COLORRED;
STICKLINE(HQ1>HQ2,0,1,1,0),COLORGREEN;
STICKLINE(HQ1>HQ2,100,99,1,0),COLORGREEN;

通达信金波银浪指标公式

 

相关文章