在线检测未来函数

通达信满仓买入指标公式

来源:Internet,编辑:股旁网,2017-03-31

VAR1:=REF(CLOSE,1);
VAR2:=LLV(LOW,5);
VAR3:=HHV(HIGH,10);
VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,4);
VAR5:=EMA(0.667*REF(VAR4,1)+0.333*VAR4,2);
VARA:=SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100;
VARB:=SMA(MAX(CLOSE-VAR1,0),13,1)/SMA(ABS(CLOSE-VAR1),13,1)*100;
VAR0A:=BARSLAST(VARB<43)<=3 AND CROSS(VARA,VARB);
VAR0B:=(CLOSE-MA(CLOSE,43))/MA(CLOSE,20)*100<-12.5;
VAR1A:=BARSLAST(VARB<33)<=3 AND CROSS(VARA,VARB);
VAR1B:=(CLOSE-MA(CLOSE,33))/MA(CLOSE,20)*100<-12.5;
VAR2A:=BARSLAST(VARB<23)<=3 AND CROSS(VARA,VARB);
VAR2B:=(CLOSE-MA(CLOSE,23))/MA(CLOSE,20)*100<-12.5;
三合一:VAR0A AND VAR0B AND VAR1A AND VAR1B AND VAR2A AND VAR2B AND CROSS(VAR4,VAR5) AND VAR4<=25;
距今天:BARSLAST(三合一),NODRAW;
机会难得:VAR0A AND VAR0B AND CROSS(VAR4,VAR5) AND VAR4<=25;
难得一见:VAR1A AND VAR1B AND CROSS(VAR4,VAR5) AND VAR4<=25;
满仓买入:VAR2A AND VAR2B AND CROSS(VAR4,VAR5) AND VAR4<=25;
DRAWTEXT(机会难得>0,0.3,'机会'),COLORWHITE;
DRAWTEXT(难得一见>0,0.6,'一见'),COLORYELLOW;
DRAWTEXT(三合一>0,0.9,'合一'),COLORFFFF99;
DRAWTEXT(满仓买入>0,0.9,'满仓'),COLORFFFF99;

通达信满仓买入指标公式

 

相关文章