在线检测未来函数

通达信一把尺子主图指标公式

来源:Internet,编辑:股旁网,2017-04-26

{使用说明:1.双线上升趋势可以买入,双线下降趋势不宜买入;2.上升趋势突破不宜买入,下降趋势突破可以买入;3.上升趋势尾翘可以买入,上升趋势尾掉不宜买入;4.上升通道反弹可以买入,下降通道不宜买入;5.在同等条件下,优选活跃度80%(大盘低迷时70%)以上的,活跃度30%以下不宜买入。}

涨幅:=3;
TP转换PW:=1;
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:=IF(SAT>1,1,SAT)*100,NODRAW;
获利筹码:=WINNER(C)*100,NODRAW;
N:=5;
LC:=REF(CLOSE,1);
RSI值:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活跃:=(RSI值-WR10);
活跃度比:=IF(活跃>=0,(活跃+100)/2,100-ABS((活跃-100)/2)),NODRAW;
A1:=BACKSET(ISLASTBAR,PEAKBARS(1,N,1)+1);
A2:=A1>REF(A1,1);
B1:=BACKSET(ISLASTBAR,PEAKBARS(1,N,2)+1);
B2:=B1>REF(B1,1);
C1:=BACKSET(ISLASTBAR,PEAKBARS(1,N,3)+1);
C2:=C1>REF(C1,1);
A11:=BACKSET(ISLASTBAR,TROUGHBARS(2,N,1)+1);
A21:=A11>REF(A11,1);
B11:=BACKSET(ISLASTBAR,TROUGHBARS(2,N,2)+1);
B21:=B11>REF(B11,1);
C11:=BACKSET(ISLASTBAR,TROUGHBARS(2,N,3)+1);
C21:=C11>REF(C11,1);
高辅线:DRAWLINE(B2,H,A2,H,1),COLORBLUE;
低辅线:DRAWLINE(B21,L,A21,L,1),COLOR0000FF;
DRAWRECTREL(80,10,240,60,RGB(0,75,200));
DRAWRECTREL(80,10,160,60,RGB(0,100,0));
DRAWRECTREL(80,10,80+CONST(活跃度比*160/100),60,RGB(200,0,50));
DRAWTEXT_FIX(1,0.00,0.01,0,STRCAT(STRCAT('活跃度: ',CON2STR(活跃度比,2)),'% ')),COLORYELLOW;
DRAWRECTREL(80,70,240,120,RGB(0,75,200));
DRAWRECTREL(80,70,160,120,RGB(0,100,0));
DRAWRECTREL(80,70,80+CONST(获利筹码*160/100),120,RGB(200,0,50));
DRAWTEXT_FIX(1,0.00,0.07,0,STRCAT(STRCAT('获利率: ',CON2STR(获利筹码,2)),'% ')),COLORYELLOW;
DRAWRECTREL(80,130,240,180,RGB(0,75,200));
DRAWRECTREL(80,130,160,180,RGB(0,100,0));
DRAWRECTREL(80,130,80+CONST(量能饱和*160/100),180,RGB(200,0,50));
DRAWTEXT_FIX(1,0.00,0.13,0,STRCAT(STRCAT('饱和度: ',CON2STR(量能饱和,2)),'% ')),COLORYELLOW;

通达信一把尺子主图指标公式

 

相关文章