在线检测未来函数

通达信所有个股一线通吃指标公式

来源:Internet,编辑:股旁网,2017-05-03

{使用方法:线条变色,变粗,尤其是大红粗线即加入,变成黄色细线,即退出。}

M3:=MA(C,3),COLORFFBB11;
M5:=MA(C,5),COLORFF99FF;
M10:=MA(C,10),COLOR00FF00;
M20:=MA(C,20),COLORFFCCFF;
M30:=MA(C,30),COLOR00FFFF;
M60:=MA(C,60),COLOR3399FF;
M120:=MA(C,120),COLOR00FFFF;
M250:=MA(C,250),COLOR3399FF;
大:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(M3,M5),M10),M20),M30),M60),M120),M250);
小:=MIN(MIN(MIN(MIN(MIN(MIN(MIN(M3,M5),M10),M20),M30),M60),M120),M250);
Z250:=(大/小-1)*100,COLORFF99FF,LINETHICK1;
大250是:=IF(大=M3,3,IF(大=M5,5,IF(大=M10,10,IF(大=M20,20,IF(大=M30,30,
IF(大=M60,60,IF(大=M120,120,250))))))),COLOR00FFFF,NODRAW;
大120:=MAX(MAX(MAX(MAX(MAX(MAX(M3,M5),M10),M20),M30),M60),M120);
小120:=MIN(MIN(MIN(MIN(MIN(MIN(M3,M5),M10),M20),M30),M60),M120);
Z120:=(大120/小120-1)*100,COLORFF99FF,NODRAW;
大120是:=IF(大120=M3,3,IF(大120=M5,5,IF(大120=M10,10,IF(大120=M20,20,
IF(大120=M30,30,IF(大120=M60,60,120)))))),COLOR00FFFF,NODRAW;
大60:=MAX(MAX(MAX(MAX(MAX(M3,M5),M10),M20),M30),M60);
小60:=MIN(MIN(MIN(MIN(MIN(M3,M5),M10),M20),M30),M60);
Z60:=(大60/小60-1)*100,COLORFF99FF,LINETHICK0;
大60是:=IF(大60=M3,3,IF(大60=M5,5,IF(大60=M10,10,IF(大60=M20,20,
IF(大60=M30,30,60))))),COLOREDEDED,LINETHICK0;
大30:=MAX(MAX(MAX(MAX(M3,M5),M10),M20),M30);
小30:=MIN(MIN(MIN(MIN(M3,M5),M10),M20),M30);
Z30:=(大30/小30-1)*100,COLOR00FFFF,NODRAW;
大30是:=IF(大30=M3,3,IF(大30=M5,5,IF(大30=M10,10,IF(大30=M20,20,
30)))),COLOREDEDED,NODRAW;
大20:=MAX(MAX(MAX(M3,M5),M10),M20);
小20:=MIN(MIN(MIN(M3,M5),M10),M20);
Z20:=(大20/小20-1)*100,COLOR00FFFF,NODRAW;
大20是:=IF(大20=M3,3,IF(大20=M5,5,IF(大20=M10,10,20))),COLOREDEDED,NODRAW;
大10:=MAX(MAX(M3,M5),M10);
小10:=MIN(MIN(M3,M5),M10);
Z10:=(大10/小10-1)*100,COLOR00FFFF,NODRAW;
大10是:=IF(大10=M3,3,IF(大10=M5,5,10)),COLOR00FF00,NODRAW;
Z:IF(C>M250,Z250,IF(C<M250 AND C>M120,Z120,
IF(C<M250 AND C<M120 AND C>M60,Z60,
IF(C<M250 AND C<M120 AND C<M60 AND C>Z30,Z30,
IF(C<M250 AND C<M120 AND C<M60 AND C<M30 AND C>Z20,Z20,Z10))))),
COLOR00FFFF;
Z是:=IF(Z=Z250,250,IF(Z=Z120,120,IF(Z=Z60,60,IF(Z=Z30,30,
IF(Z=Z20,20,IF(Z=Z10,10,0)))))),COLOR00FF00,NODRAW;
A:IF(大20是=3,Z,DRAWNULL),COLORFFBBFF,LINETHICK5;
B:IF(大60是=3 AND 大30是=3 AND 大20是=3,Z,DRAWNULL),COLOR11AAFF,LINETHICK5;
D:IF(大120是=3 AND 大60是=3 AND 大30是=3 AND 大20是=3,Z,DRAWNULL),COLORFFE5C5,LINETHICK5;
E:IF(大250是=3 AND 大120是=3 AND 大60是=3 AND 大30是=3 AND 大20是=3,Z,DRAWNULL),COLORRED,LINETHICK5;
Z选:IF(E=Z,250,IF(D=Z,120,IF(B=Z,60,IF(A=Z,20,0)))),COLORRED,NODRAW;

通达信所有个股一线通吃指标公式

 

相关文章