在线检测未来函数

通达信饱和度指标公式

来源:Internet,编辑:股旁网,2017-05-05

N:=20;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100);
STICKLINE(((CLOSE>0)AND BARSCOUNT(C)),0,100,3,1),COLOR777777;
STICKLINE(((SAT<=5)AND BARSCOUNT(C)),0,(0+SAT),2.9,1),COLORBLUE;
STICKLINE((((SAT>5)AND (SAT<=20))AND BARSCOUNT(C)),0,(0+SAT),3,0),COLORCCFF88;
STICKLINE((((SAT>20)AND(SAT<=40))AND BARSCOUNT(C)),0,(0+SAT),3,0),COLORFF00FF;
STICKLINE(((SAT>40)AND BARSCOUNT(C)),0,(0+SAT),2,0),COLORRED;
STICKLINE(((CLOSE>0)AND BARSCOUNT(C)),0,(0+SAT),2,0),COLORRED;
STICKLINE(((CLOSE<REF(CLOSE,1))AND BARSCOUNT(C)),0,(0+SAT),1,0),COLORLIGREEN;
均线:MA(SAT,N),COLORGREEN;
量能饱和度:SAT,LINETHICK2,COLORYELLOW;

通达信饱和度指标公式

 

相关文章