在线检测未来函数

同花顺三线多头必涨指标公式

来源:Internet,编辑:股旁网,2017-05-19

资金流出:=-ZJLC[-1]/1000000;
资金流入:=ZJLR[-1]/1000000;
当日:=资金流出+资金流入;
STICKLINE(当日>0,0,当日,8,0),Color0000FF;
STICKLINE(当日<0,0,当日,8,0),Color00DF00;
D3:EMA(EMA(当日,30),3)*30,color00ffff;
D5:EMA(EMA(D3,5),3),colorff00cc;
D10:EMA(EMA(D3,10),3),color22ee22;
DRAWICON(CROSS(D10,0 ) ,0,'10');
PARTLINE(D10,D10>REF(D10,1),colorred,D10<=REF(D10,1),color22DD22),Linethick1;
IF(ISNULL(资金流出) AND ISNULL(资金流入))
DRAWICON(CROSS(D5,D10),L,1);
AA:=(O+H+L+C)/4;
A1:=HHV(AA,15);
A2:=LLV(AA,15);
A3:=A1-A2;
A4:=EMA((AA-A2)/A3,2)*9;
RSV:= (HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*10;
空:=SMA(RSV,2,1)/5;
多:=A4;
吸筹:STICKLINE(空>1.3 AND 多<0.3 AND C*0.02<(EMA(C,5)-C),0,ABS(SMA(MAX(当日,0),5,1)-ABS(当日))*2,8,0),colorwhite;
//大单净量
r:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;
//相对强弱
LC := REF(CLOSE,1);//前一日收盘价;
RSI$1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
RSI$2:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI$3:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
相对强弱:=0.5*RSI$1+0.31*RSI$2+0.19*RSI$3;
wave$1:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),3,1);
wave$2:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),5,1);
wave$3:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),8,1);
短线波段:=0.5*wave$1+0.31*wave$2+0.19*wave$3;
机会区:20,POINTDOT,colorred;
风险区:80,POINTDOT,colorgreen;
风险系数:0.5*相对强弱+0.5*短线波段,colorcyan;
//买入条件;
CD1:=IF(风险系数<20 AND CLOSE>OPEN AND r>0,1,0);//波段小于20,股价翻红;
CD2:=IF(风险系数<20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND r>0,1,0);//波段小于20,股价未翻红,但未创新低;
CD3:=IF(REF(风险系数,1)<20 AND 风险系数>REF(风险系数,1),1,0);//前一日波段小于20,今日转向;
SIGNALBUY=(CD1=1 OR CD2=1 OR CD3=1);
X=(SIGNALBUY AND COUNT(SIGNALBUY,3)=1);
DRAWICON(X,机会区,"buy");

同花顺三线多头必涨指标公式

 

相关文章