在线检测未来函数

通达信突破在即指标公式

来源:Internet,编辑:股旁网,2017-05-26

A4:=MA(CLOSE,10);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
{AVX:(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)))/50;}
风向标:MA((((((IF(A5,100,0) + IF(A6,100,0)) + IF(A7,100,0)) + IF(A8,100,0)) + IF(A9,100,0)) + IF(A11,100,0))/6,3.5);
{VARR:=REF(CLOSE,1);
强弱方向:=SMA(MAX(CLOSE-VARR,0),5,1)/SMA(ABS(CLOSE-VARR),5,1)*100,COLORYELLOW;}
{80, POINTDOT,COLORBLUE,LINETHICK2;
70, POINTDOT,COLORWHITE,LINETHICK2;
20, POINTDOT,COLORGREEN,LINETHICK2;
{10, POINTDOT,COLORBLUE,LINETHICK2};
航向: MA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,3,1)-2*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,3,1),3),COLORMAGENTA,LINETHICK1;
{DRAWTEXT(CROSS(买卖力道,80) AND 强弱方向>50,80,'买'),COLORYELLOW;};
{突破在即}
A1:=BARSLAST(C=HHV(C,20));
A2:=REF(C,A1);
A3:=CROSS(C,REF(A2,1));
突破在即:((COUNT(A3,5)=1 AND A3) {AND C=H} AND V>=MA(V,5)*2.5)*30;
AA:=CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA<0.2;
BB:=LLV(ASR.ASR,21)>50;
CC:=MACD.DIF>-1;
调整结束:(AA AND BB AND CC AND V>REF(V,1)*1.2)*30,COLORYELLOW;
VAR1:=C-REF(C,1);
VAR2:=O-REF(O,1);
VAR3:=H-REF(H,1);
VAR4:=L-REF(L,1);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
海浪:MA(VAR5*VOL/CAPITAL*500,5),LINETHICK0;
STICKLINE(海浪>=0,MA(海浪,1.5),0,3,0), COLORRED;
STICKLINE(海浪<0,MA(海浪,1.5),0,3,0) ,COLORGREEN;

通达信突破在即指标公式

 

相关文章