在线检测未来函数

通达信至少不会深套主图指标公式

来源:Internet,编辑:股旁网,2017-06-06

散户:=EMA(CLOSE,5),COLORWHITE;
绿降:=(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,COLORMAGENTA,LINETHICK2;
VAR1:=VOL*(O+C)/2;
生命线:=SUM(VAR1,7)/SUM(VOL,7),COLORFF00FF,LINETHICK1;
MW:=13;FL:=MA(CLOSE,MW)+ABS(MA(CLOSE,MW)-REF(MA(CLOSE,MW),1)),COLORRED;
FS:=MA(CLOSE,MW)+MA(CLOSE,MW)-REF(MA(CLOSE,MW),1),COLORGREEN,LINETHICK2;
分水岭:=IF(MA(CLOSE,MW)<FS,FS,MA(CLOSE,MW)),COLORLIBLUE,LINETHICK1,;
操作线:=分水岭-(EMA(C,3)-分水岭),COLORLIBLUE,LINETHICK1;
筹码密集:=HHV(MA(H,13),13),COLORRED,LINETHICK1;
TLAMSENR:=MAX(MAX((HIGH-LOW),ABS((REF(CLOSE,1)-HIGH))),ABS((REF(CLOSE,1)-LOW)));
ATR:=MA(TLAMSENR,13);VAR11A:=(REF(CLOSE,1)-REF(ATR,1));
多空线:(HHV(VAR11A,12)),LINETHICK2,COLOR0099FF,;
N:=20;
MB:=MA(C,N);
R:=C-MB;
X1:=MA(R*R,N);
X:=SQRT(X1);
中轨:MB,COLORWHITE,;
VART1:=POW((C-MB),2);
VART2:=MA(VART1,20);
VART3:=SQRT(VART2);
UPPER:=MB+2*VART3,LINETHICK1;
LOWER:=MB-2*VART3,LINETHICK1;
UB:REF(UPPER,1)COLORLIBLUE,LINETHICK1;{COLORBBC611COLOR006600COLOR0099FF}
LB:REF(LOWER,1)COLORLIBLUE,LINETHICK1;
LC20:=REF(CLOSE,1);
RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100,NODRAW;
STICKLINE(CROSS("KDJ.J"(27,3,3),0.0001),O,C,2,0),COLOR00FFEE;
{RSI出击买点DRAWICON((AA1-BB1)/BB1>13/10,L,1),COLORYELLOW;}
AA1:="RSI.RSI1"(3,14,24),LINETHICK1,COLOR6295D6;
BB1:=REF("RSI.RSI1"(3,14,24),1),LINETHICK1,COLORFF9800;
VAR177:=(2*CLOSE+HIGH+LOW)/4;
VAR277:=LLV(LOW,5);
VAR377:=HHV(HIGH,5);
VAR477:=EMA((VAR177-VAR277)/(VAR377-VAR277)*100,5);
MA177:=MA(VAR477,2);
XXX:=STICKLINE(FILTER(VAR477>MA177 AND REF(VAR477,1)<30,5),O,C,3,1),COLORWHITE;
DRAWICON(FILTER(VAR477>MA177 AND REF(VAR477,1)<30,5),L,9);
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
回调买:=(AV + NEWVOL);
{DRAWICON(CROSS(回调买,0),下,11),COLORYELLOW;};
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH*1.011,4);
VAR1A:=(EMA(C,12)-EMA(C,26))*100+50;
VAR2A:=EMA(VAR1A,9);
VAR3A:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR4A:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5A:=SMA(VAR4A,13,8);
VAR6A:=SMA(VAR3A,21,8);
趋势44:=CEILING(SMA(VAR5A,13,8)),LINETHICK2,COLOR0000FF;
看44:=(趋势44-VAR6A>85 AND VAR6A>0)*40,COLOR00FF00;
STICKLINE(CROSS(看44,0.2),O,C,2,0),COLORBLUE;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); H1D:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); L1D:=FILTER(C2,10);
前期高位:=REF(C,BARSLAST(H1D)),COLORBLUE,;
STICKLINE(CURRBARSCOUNT<420,REF(C,SUMBARS(L1D,1)),REF(C,SUMBARS(L1D,1)),2,1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT<420,REF(C,BARSLAST(H1D)),REF(C,BARSLAST(H1D)),2,1),COLORWHITE;

通达信至少不会深套主图指标公式

 

相关文章