在线检测未来函数

通达信冠军一号改编主图及选股指标公式

来源:Internet,编辑:股旁网,2017-06-22

HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H:=EMA(HH,90),COLORRED,LINETHICK1;
D90L:=EMA(LL,90),COLORRED,LINETHICK1;
D90:(D90H+D90L)/2,COLORWHITE,LINETHICK1;
D1:=EMA(D90,10),COLORWHITE,LINETHICK1;
D2:=EMA(D1,10),COLORWHITE,LINETHICK1;
YM:EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48),COLORRED,LINETHICK1;
YM1:=EMA(YM,5),COLORRED,LINETHICK1;
YM2:=EMA(YM1,5),COLORRED,LINETHICK1;
YMUP:=YM>YM2;
IF(YMUP,YM,DRAWNULL),LINETHICK1,COLORRED;
IF(YMUP,YM1,DRAWNULL),LINETHICK1,COLORRED;
YMD:=YM<=YM2;
IF(YMD,YM,DRAWNULL),LINETHICK1,COLORGREEN;
IF(YMD,YM1,DRAWNULL),LINETHICK1,COLORGREEN;
D90D:=EMA((CLOSE+HIGH+LOW)/3,5)<=D90;
D90UP:=EMA((CLOSE+HIGH+LOW)/3,5)>D90;
D90A:IF(D90UP,D90,DRAWNULL),LINETHICK1,COLORRED;
D90B:IF(D90UP,D1,DRAWNULL),LINETHICK1,COLORLIRED;
XG:=D90UP AND REF(YMD,1) AND YMUP AND RANGE(YM/D90,1,1.1);
DRAWICON(XG,L*0.98,9);

{
选股公式:

HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210;
LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210;
D90H:=EMA(HH,90);
D90L:=EMA(LL,90);
D90:=(D90H+D90L)/2;
D1:=EMA(D90,10);
D2:=EMA(D1,10);
YM:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48);
YM1:=EMA(YM,5);
YM2:=EMA(YM1,5);
YMUP:=YM>YM2;
YMD:=YM<=YM2;
D90D:=EMA((CLOSE+HIGH+LOW)/3,5)<=D90;
D90UP:=EMA((CLOSE+HIGH+LOW)/3,5)>D90;
XG:D90UP AND REF(YMD,1) AND YMUP AND RANGE(YM/D90,1,1.1);
}

通达信冠军一号改编主图及选股指标公式

 

相关文章