在线检测未来函数

同花顺量能柱线指标公式

来源:Internet,编辑:股旁网,2017-06-23

V5: MA(VOL,5)*2;
V34: MA(VOL,34)*2;
V65: MA(V,65)*2;
VAR2:=CLOSE-REF(CLOSE,1);
VAR3:=IF(CLOSE-REF(CLOSE,1)>=0,VAR2,0);
VAR4:=REF(CLOSE,1)-CLOSE;
VAR5:=IF(CLOSE-REF(CLOSE,1)<=0,VAR4,0);
VAR6:=SUM(VAR3,16)/SUM(VAR5,16);
VAR7:=100-100/(1+VAR6);
VAR8:=EMA(VAR7,16);
VAR9:=EMA(VAR8,8);
VARA:=EMA(VAR8,45);
MO:=(VAR8-VARA);
ML:=(VAR9-VARA);
VAR1A:=EMA(CLOSE,32);
VAR2A:=MA(OPEN,32);
趋势:=(VAR1A-VAR2A);
STICKLINE(MO>ML AND 趋势<0 AND MO>REF(MO,3) AND 趋势>REF(趋势,3),VOL,0,3,0), colorred;
VOL,VOLSTICK;
低量柱:MIN(LLV( VOL,89),VOL)=VOL;
DRAWTEXT(低量柱,VOL*1.8,'低'),colorwhite;
倍量:(VOL/REF(VOL,1)>1.98 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.98);
DRAWTEXT(倍量,VOL*1.1,'倍'),colorgreen;
STICKLINE(V>REF(V*1.9,1),0,V,5,0),coloryellow;
倍缩量:VOL/REF(VOL,1)<0.5;
DRAWTEXT(倍缩量,VOL*1.3,'缩'),colorred;
筹码空间:=IF(WINNER(CLOSE),WINNER(CLOSE)*100,20);
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,6),colorred;
D: EMA(0.667*REF(K,1)+0.333*K,2),colorgreen;
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((CLOSE-VAR3)/(VAR4-VAR3)*100,3);
VAR6:=(K+VAR5)/2;
VAR7:=EMA(0.667*REF(VAR5,1)+0.333*K,2);
VAR8:=EMA(VAR6,5);
VAR9:EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
换手率:=VOL/CAPITAL*100;
主力吸筹:换手率>3 AND 换手率<=5,colorblue;
加快吸筹:换手率>5 AND 换手率<=7,coloryellow;
主力进攻:换手率>7 AND 换手率<=10,colorgreen;
主力猛攻:换手率>10,COLORFF00FF;
量:VOL,colorgreen,NODRAW;
均5:=MA(VOL,5);
均10:=MA(VOL,10);
均20:=MA(VOL,20),colorred;
STICKLINE(V>0,0,V,3,0),COLOR0000AA;
STICKLINE(V>0,0,V,2,0),COLOR0000CC;
STICKLINE(V>0,0,V,1.6,0),COLOR0000FF;
STICKLINE(主力吸筹,0,V,2,0),colorblue;
STICKLINE(主力吸筹,0,V,1,0),colorblue;
STICKLINE(主力吸筹,0,V,0.5,0),colorblue;
STICKLINE(加快吸筹,0,V,2,0),COLOR00AAAA;
STICKLINE(加快吸筹,0,V,1,0),COLOR00CCCC;
STICKLINE(加快吸筹,0,V,0.5,0),COLOR00FFFF;
STICKLINE(主力进攻,0,V,2,0),colorgreen;
STICKLINE(主力进攻,0,V,1,0),colorgreen;
STICKLINE(主力进攻,0,V,0.5,0),COLORFFFF00;
STICKLINE(主力猛攻,0,V,2,0),COLORAA00AA;
STICKLINE(主力猛攻,0,V,1,0),COLORCC00CC;
STICKLINE(主力猛攻,0,V,0.5,0),COLORFF00FF;
M135:=MA(VOL,135);
股价趋势:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底部警戒:=10,colorred,LINETHICK2;
底1:=CROSS(股价趋势,底部警戒);
A1:=(2*CLOSE+HIGH+LOW)/4;
A2:=LLV(LOW,27);
A3:=HHV(HIGH,27);
A4:=EMA((A1-A2)/(A3-A2)*100,13);
A5:=EMA(0.618*REF(A4,1)+0.382*A4,3);
底2:=CROSS(A4,A5) AND A4<16;
波底:=底1 AND 底2;
VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;
VAR4:=EMA(VAR3,5);
VAR5:=3*VAR3-2*VAR4;
牛:=CROSS(VAR5,VAR3) AND VAR3<2.1 AND C>O;
VARA2:=LLV(LOW,10);
VARA3:=HHV(HIGH,25);
动力线:= EMA((CLOSE-VARA2)/(VARA3-VARA2)*4,4);
N:=19;
VARB1:=HHV(HIGH,N);
VARB2:=LLV(LOW,N);
阻力线:=EMA((CLOSE-VARB2)/(VARB1-VARB2),21)-0.5;
操作线:=EMA((CLOSE-VARB2)/(VARB1-VARB2),5)-0.5;
突破:=CROSS(操作线,阻力线) AND 阻力线<0.1;
破位:=CROSS(阻力线,操作线) AND 阻力线>0.25;
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
T12:=V2>=1;
T0:=BARSLAST(T12);
L1:=REF(L,T0);
H1:=REF(H,T0);
L11:=MIN(REF(L,1),L);
L10:=MIN(L11,REF(L,2));
L21:=MAX(REF(L,1),L);
L20:=MAX(L21,REF(L,2));
T111:=(REF(V2>=1,3) OR REF(V2>=1,2) OR REF(V2>=1,1)) AND
((L10>L1 AND L20>H1) OR (L11>L1 AND L21>H1) OR (L>H1));
T11:=T111 AND REF(T111,1)=0;
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
背离:=CROSS(88,RSI);
底背离:=CROSS(FF,MA15);
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
T1:=FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10);
获利盘:=WINNER(C)*100;
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,5),colorwhite;
MAVOL2:MA(VOLUME,35),coloryellow;MAVOL3:MA(VOLUME,135),colorgreen;
{V2:IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1),NODRAW,colorred;}
STICKLINE(V2>=1,0,VOL*0.5,2,0),coloryellow;
STICKLINE(动力线>=3.2,0,VOL,1,0),COLOR238E23;
STICKLINE(波底,0,VOL,2,0),colormagenta;
DRAWTEXT(波底,VOL*0.8,'底'),colorwhite;
DRAWICON(波底,VOL*1.1,5);
STICKLINE(牛,0,VOL,2,0),colorred;
DRAWTEXT(牛,VOL*1.15,'牛'),colorwhite;
STICKLINE(突破,0,VOL,1,0),colorblue;
DRAWTEXT(突破,VOL*0.5,'突破'),colorwhite;
DRAWICON(突破,VOL*1.2,1);
STICKLINE(破位,0,VOL,0.5,0),colorbrown;
DRAWTEXT(破位,VOL*0.5,'破位'),colorwhite;
DRAWICON(破位,VOL*1.05,2);
STICKLINE(T11,O,VOL,2,0),COLORFF00FF;
STICKLINE(涨停,VOL*0.5,VOL,2.5,0),colorlired;
STICKLINE(涨停,VOL*0.5,VOL,0,0),colorred;
STICKLINE(跌停,VOL*0.5,VOL,2.5,0),COLOR2F4F2F;
STICKLINE(跌停,VOL*0.5,VOL,0,0),colorblack;
STICKLINE(顶背离,VOL*0.8,VOL,2.5,0),colorgreen;
STICKLINE(底背离,0,VOL*0.2,3,0),COLOR7F017F;
DRAWTEXT(T1,VOL*1.1,'∠'),COLOR007575;
DRAWTEXT(获利盘>=75 AND 动力线>=3.2,VOL*1.1,'●'),colorred;
DRAWTEXT(获利盘<75 AND 动力线>=3.2,VOL*1.1,'●'),colorgreen;

同花顺量能柱线指标公式

 

相关文章