在线检测未来函数

通达信风火轮主图指标公式

来源:Internet,编辑:股旁网,2017-06-28

长期趋势:DRAWLINE(C=HHV(C,2000),HHV(H,3),C=HHV(C,24) AND C<HHV(C,72),HHV(HIGH,3),1),COLORWHITE;
AB:=DRAWLINE(HIGH>=HHV(HIGH,24),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORYELLOW;
短线:MA(C,5),LINETHICK2,COLORE6E8FA;
操盘线:MA(C,24),LINETHICK2,COLORD9D919;
生命线:MA(C,72),LINETHICK2,COLORRED;
庄线:MA(C,200)COLOR9F5F9F;
压力:DRAWLINE(H=HHV(H,2000),H,HIGH>=HHV(HIGH,100),HHV(HIGH,3),1),COLORMAGENTA;
拐点:DRAWLINE(HIGH>=HHV(HIGH,72),HIGH,LOW<=LLV(LOW,24),HHV(HIGH,3),1),LINETHICK2,COLORYELLOW;
FFXG:=CROSS(MA(CLOSE,24),拐点);
DRAWICON(CROSS(短线,MA(CLOSE,72)),MA(CLOSE,72)*1.01,1);
DRAWICON(CROSS(生命线,MA(CLOSE,5)),MA(CLOSE,72)*1.01,2);
AA1:DRAWTEXT(CROSS(短线,长期趋势),长期趋势,'加速'),COLORRED;
DRAWICON(短线>拐点 AND CROSS(短线,生命线),生命线,18);
DRAWICON(CROSS(拐点,MA(CLOSE,24)),拐点*1.01,6);
MA24回:=CROSS(MA(CLOSE,24),L) AND C>O AND C>拐点;
MA72回:=CROSS(MA(CLOSE,72),L) AND C>O AND C>拐点;
MA200回:=CROSS(MA(CLOSE,200),L) AND C>O AND C>拐点;
MA24回调:=REF(CROSS(MA(CLOSE,24),L),1) AND REF(C<O,1) AND C>O AND REF(C>拐点,1);
MA72回调:=REF(CROSS(MA(CLOSE,72),L),1) AND REF(C<O,1) AND C>O AND REF(C>拐点,1);
MA200回调:=REF(CROSS(MA(CLOSE,200),L),1) AND REF(C<O,1) AND C>O AND REF(C>拐点,1);
{DRAWTEXT(MA24回,L*0.93,'3'),COLORYELLOW;
DRAWTEXT(MA72回,L*0.95,'2'),COLORYELLOW;
DRAWTEXT(MA200回,L*0.97,'1'),COLORYELLOW;}
DRAWICON(MA24回,L*0.98,17);
DRAWICON(MA72回,L*0.98,13);
DRAWICON(MA200回,L*0.98,5);
{DRAWTEXT(MA24回调,L*0.93,'3'),COLORYELLOW;
DRAWTEXT(MA72回调,L*0.95,'2'),COLORYELLOW;
DRAWTEXT(MA200回调,L*0.97,'1'),COLORYELLOW;}
DRAWICON(MA24回调,L*0.98,17);
DRAWICON(MA72回调,L*0.98,13);
DRAWICON(MA200回调,L*0.98,5);
DRAWLINE(LOW<=LLV(LOW,120),LOW,HHV(H,6)<=HHV(H,10),LLV(LOW,6),1),COLORWHITE;
月1:=YEAR=2010 AND MONTH=1 AND (DAY=4 OR DAY=5);
月2:=YEAR=2010 AND MONTH=6 AND (DAY=7 OR DAY=20 OR DAY=25);
月4:=YEAR=2010 AND MONTH=4 AND (DAY=16);
月5:=YEAR=2010 AND MONTH=5 AND (DAY=12 OR DAY=22);
月6:=YEAR=2010 AND MONTH=6 AND (DAY=6);
月10:=YEAR=2010 AND MONTH=10 AND (DAY=16);
月11:=YEAR=2010 AND MONTH=11 AND (DAY=13 OR DAY=23);
月12:=YEAR=2010 AND MONTH=12 AND (DAY=19 OR DAY=31);
时间窗:=月1 OR 月2 OR 月4 OR 月5 OR 月6 OR 月10
OR 月11 OR 月12;
STICKLINE(时间窗 AND PERIOD=5,H,L,1,0),COLORWHITE;{K线做记号};

通达信风火轮主图指标公式

 

相关文章