在线检测未来函数

通达信涨跌停统计及次日表现指标公式

来源:Internet,编辑:股旁网,2017-07-11

P:=1000;
DRAWTEXT_FIX(CLOSE>0,0.00,0.00,0,' 股性 最高连板 涨停数 开板数 跌停数 封板率 ')COLORGREEN;
DRAWTEXT_FIX(CLOSE>0,0.00,0.10,0,' 涨停次日平均: 开 低 高 收 ')COLORGREEN;
DRAWTEXT_FIX(CLOSE>0,0.00,0.15,0,' 开板次日平均: 开 低 高 收 ')COLORGREEN;
DRAWTEXT_FIX(CLOSE>0,0.00,0.20,0,' 统计周期: 交易日')COLORYELLOW;
DRAWNUMBER_FIX(C>0,0.040,0.20,0,P),COLORRED;{显示统计周期}
DRAWTEXT_FIX(C>0,0.170,0.05,0,'%'),COLORRED;
涨停价:=ZTPRICE(REF(CLOSE,1),0.1);
跌停价:=DTPRICE(REF(CLOSE,1),0.1);
开板:=((HIGH>=涨停价) AND (CLOSE<涨停价));
涨停数:=COUNT((C>=涨停价) AND L!=C,P) NODRAW;
开板数:=COUNT(开板,P) NODRAW;
跌停数:=COUNT(C<=跌停价,P) NODRAW;
封板率:=ROUND((1-(开板数/(涨停数+开板数)))*100);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.065,0.05,0,涨停数),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.095,0.05,0,开板数),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.125,0.05,0,跌停数),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.155,0.05,0,封板率),COLORRED;
涨停次日收:=IF(REF(C>=涨停价 AND L!=C,1), C/REF(C,1)-1,0);
TTJ:=IF(涨停次日收,1,0);
TTJ1:=SUM(涨停次日收,P);
TTJ2:=SUM(TTJ,P);
次日平均涨幅收:=(TTJ1/TTJ2*100), NODRAW;
DRAWNUMBER_FIX(次日平均涨幅收>0 AND CURRBARSCOUNT=1,0.175,0.10,0,次日平均涨幅收),COLORRED;
DRAWNUMBER_FIX(次日平均涨幅收<=0 AND CURRBARSCOUNT=1,0.175,0.10,0,次日平均涨幅收),COLORGREEN;
涨停次日开:=IF(REF(C>=涨停价 AND L!=C,1), O/REF(C,1)-1,0);
TTJ3:=IF(涨停次日开,1,0);
TTJ4:=SUM(涨停次日开,P);
TTJ5:=SUM(TTJ3,P);
次日平均涨幅开:=TTJ4/TTJ5*100 NODRAW;
DRAWNUMBER_FIX(次日平均涨幅开>0 AND CURRBARSCOUNT=1,0.068,0.10,0,次日平均涨幅开),COLORRED;
DRAWNUMBER_FIX(次日平均涨幅开<=0 AND CURRBARSCOUNT=1,0.068,0.10,0,次日平均涨幅开),COLORGREEN;
涨停次日低:=IF(REF(C>=涨停价 AND L!=C,1), L/REF(C,1)-1,0);
TTJ6:=IF(涨停次日低,1,0);
TTJ7:=SUM(涨停次日低,P);
TTJ8:=SUM(TTJ6,P);
次日平均涨幅低:=TTJ7/TTJ8*100 NODRAW;
DRAWNUMBER_FIX(次日平均涨幅低>0 AND CURRBARSCOUNT=1,0.105,0.10,0,次日平均涨幅低),COLORRED;
DRAWNUMBER_FIX(次日平均涨幅低<=0 AND CURRBARSCOUNT=1,0.105,0.10,0,次日平均涨幅低),COLORGREEN;
涨停次日高:=IF(REF(C>=涨停价 AND L!=C,1), H/REF(C,1)-1,0);
TTJ9:=IF(涨停次日高,1,0);
TTJ10:=SUM(涨停次日高,P);
TTJ11:=SUM(TTJ9,P);
次日平均涨幅高:=TTJ10/TTJ11*100 NODRAW;
DRAWNUMBER_FIX(次日平均涨幅高>0 AND CURRBARSCOUNT=1,0.142,0.10,0,次日平均涨幅高),COLORRED;
DRAWNUMBER_FIX(次日平均涨幅高<=0 AND CURRBARSCOUNT=1,0.142,0.10,0,次日平均涨幅高),COLORGREEN;
开板次日开:=IF(REF(开板,1) AND L!=C, O/REF(C,1)-1,0);
TTTJ:=IF(开板次日开,1,0);
TTTJ1:=SUM(开板次日开,P);
TTTJ2:=SUM(TTTJ,P);
开板次日平均开:=TTTJ1/TTTJ2*100 NODRAW;
DRAWNUMBER_FIX(开板次日平均开>0 AND CURRBARSCOUNT=1,0.068,0.15,0,开板次日平均开),COLORRED;
DRAWNUMBER_FIX(开板次日平均开<=0 AND CURRBARSCOUNT=1,0.068,0.15,0,开板次日平均开),COLORGREEN;
开板次日低:=IF(REF(开板,1) AND L!=C, L/REF(C,1)-1,0);
TTTJ3:=IF(开板次日低,1,0);
TTTJ4:=SUM(开板次日低,P);
TTTJ5:=SUM(TTTJ3,P);
开板次日平均低:=TTTJ4/TTTJ5*100 NODRAW;
DRAWNUMBER_FIX(开板次日平均低>0 AND CURRBARSCOUNT=1,0.105,0.15,0,开板次日平均低),COLORRED;
DRAWNUMBER_FIX(开板次日平均低<=0 AND CURRBARSCOUNT=1,0.105,0.15,0,开板次日平均低),COLORGREEN;
开板次日高:=IF(REF(开板,1) AND L!=C, H/REF(C,1)-1,0);
TTTJ6:=IF(开板次日高,1,0);
TTTJ7:=SUM(开板次日高,P);
TTTJ8:=SUM(TTTJ6,P);
开板次日平均高:=TTTJ7/TTTJ8*100 NODRAW;
DRAWNUMBER_FIX(开板次日平均高>0 AND CURRBARSCOUNT=1,0.142,0.15,0,开板次日平均高),COLORRED;
DRAWNUMBER_FIX(开板次日平均高<=0 AND CURRBARSCOUNT=1,0.142,0.15,0,开板次日平均高),COLORGREEN;
开板次日收:=IF(REF(开板,1) AND L!=C, C/REF(C,1)-1,0);
TTTJ9:=IF(开板次日收,1,0);
TTTJ10:=SUM(开板次日收,P);
TTTJ11:=SUM(TTTJ9,P);
开板次日平均收:=TTTJ10/TTTJ11*100 NODRAW;
DRAWNUMBER_FIX(开板次日平均收>0 AND CURRBARSCOUNT=1,0.175,0.15,0,开板次日平均收),COLORRED;
DRAWNUMBER_FIX(开板次日平均收<=0 AND CURRBARSCOUNT=1,0.175,0.15,0,开板次日平均收),COLORGREEN;
涨停:=C>=涨停价 AND L!=C;
最高连板:=HHV(BARSLAST(NOT(涨停)),P);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.035,0.05,0,最高连板),COLORRED;
股性分数:=ROUND(最高连板*3+涨停数*2+开板数-跌停数+封板率);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.005,0.05,0,股性分数),COLORRED;

通达信涨跌停统计及次日表现指标公式

 

相关文章