在线检测未来函数

同花顺神奇数字主图指标公式

来源:Internet,编辑:股旁网,2017-07-13

HJ1:=60;
HJ:=1;
A:=DRAWTEXT(C<REF(L,4),LOW,'*');
LS0:=BARSLAST(A);
LS11:=IF(1,LS0=1,A);
LS21:=IF(1,LLV(L,1)>REF(L,1),1);
A1:=LS11 AND LS21;
LS12:=IF(2,LS0=2,A);
LS22:=IF(2,LLV(L,2)>REF(L,2),1);
A2:=LS12 AND LS22;
LS13:=IF(3,LS0=3,A);
LS23:=IF(3,LLV(L,3)>REF(L,3),1);
A3:=LS13 AND LS23;
LS14:=IF(4,LS0=4,A);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
A4:=LS14 AND LS24;
LS15:=IF(5,LS0=5,A);
LS25:=IF(5,LLV(L,5)>REF(L,5),1);
A5:=LS15 AND LS25;
LS16:=IF(6,LS0=6,A);
LS26:=IF(6,LLV(L,6)>REF(L,6),1);
A6:=LS16 AND LS26;
LS17:=IF(7,LS0=7,A);
LS27:=IF(7,LLV(L,7)>REF(L,7),1);
A7:=LS17 AND LS27;
LS18:=IF(8,LS0=8,A);
LS28:=IF(8,LLV(L,8)>REF(L,8),1);
A8:=LS18 AND LS28;
LS19:=IF(9,LS0=9,A);
LS29:=IF(9,LLV(L,9)>REF(L,9),1);
A9:=LS19 AND LS29;
DRAWTEXT(A1,L-0.5,'1'),colorgreen;
DRAWTEXT(A2,L-0.5,'2'),colorgreen;
DRAWTEXT(A3,L-0.5,'3'),colorgreen;
DRAWTEXT(A4,L-0.5,'4'),colorgreen;
DRAWTEXT(A5,L-0.5,'5'),colorgreen;
DRAWTEXT(A6,L-0.5,'6'),colorgreen;
DRAWTEXT(A7,L-0.5,'7'),colorgreen;
DRAWTEXT(A8,L-0.5,'8'),colorgreen;
DRAWTEXT(A9,L-0.5,'9'),colorgreen;
DRAWTEXT(CURRBARSCOUNT=7,HIGH*1.025,'7'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=11,HIGH*1.025,'11'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=18,HIGH*1.025,'18'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=29,HIGH*1.025,'29'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=47,HIGH*1.025,'47'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=76,HIGH*1.025,'76'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=123,HIGH*1.025,'123'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=199,HIGH*1.025,'199'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=322,HIGH*1.025,'322'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=521,HIGH*1.025,'521'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=843,HIGH*1.025,'843'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=1364,HIGH*1.025,'1364'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=2207,HIGH*1.025,'2207'), colorwhite;
DRAWTEXT(CURRBARSCOUNT=3571,HIGH*1.025,'3571'), colorwhite;
DRAWTEXT_FIX(1,0.01,0.9,0,'绿色数字为狄马克TD准备,白色卢卡斯螺旋周期'),colorbrown;
半分位:=(O+C)/2;
昨半分位:=REF(半分位,1);
STICKLINE(ISLASTBAR,昨半分位,昨半分位,10,0),colorwhite;
DRAWNUMBER(ISLASTBAR,昨半分位,昨半分位);
DRAWTEXT(ISLASTBAR,昨半分位,' 昨半分位'),colorgray;
NB:=HJ1;
MB:=HJ;
MA5X:=MA(C,5);
MA13X:=MA(C,13);
高:=REF(HHV(H,NB),MB);
低:=REF(LLV(L,NB),MB);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
一:REFDATE(高,DATE),POINTDOT,colorwhite;
二:REFDATE(H19,DATE),POINTDOT,coloryellow;
三:REFDATE(H38,DATE),POINTDOT,colormagenta;
四:REFDATE(H中,DATE),POINTDOT,colorred;
五:REFDATE(H61,DATE),POINTDOT,colormagenta;
六:REFDATE(H80,DATE),POINTDOT,coloryellow;
七:REFDATE(低,DATE),POINTDOT,colorwhite;
DRAWTEXT(ISLASTBAR,一,' 高'),colorwhite;
DRAWTEXT(ISLASTBAR,二,' 809'),coloryellow;
DRAWTEXT(ISLASTBAR,三,' 618'),colormagenta;
DRAWTEXT(ISLASTBAR,四,' 中'),colorred;
DRAWTEXT(ISLASTBAR,五,' 382'),colormagenta;
DRAWTEXT(ISLASTBAR,六,' 191'),coloryellow;
DRAWTEXT(ISLASTBAR,七,' 低'),colorwhite;

同花顺神奇数字主图指标公式

 

相关文章