在线检测未来函数

通达信小白顶底指标公式

来源:Internet,编辑:股旁网,2017-07-18

N:=30;
M:=13;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
RSIF:=90-RSI1,COLOR33DD33;
A4:=((C-LLV(L,33))/(HHV(H,33)-LLV(L,33)))*67;
K22:=LLV(LOW,10);
K33:=HHV(HIGH,25);
动力线:=EMA((CLOSE-K22)/(K33-K22)*4,4);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
W1:=SMA(RSV,3,1);
W2:=SMA(W1,3,1);
W3:=3*W1-2*W2;
STICKLINE(动力线>0 AND ISLASTBAR AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),20,80,0,1),COLORGRAY;
STICKLINE(动力线>=0.2 AND 动力线<0.5 AND ISLASTBAR AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),15,35,2,0),COLORGRAY;
STICKLINE(动力线>=0.5 AND 动力线<1.75 AND ISLASTBAR AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),35,55,2,0),COLORYELLOW;
STICKLINE(动力线>=1.75 AND 动力线<3.2 AND ISLASTBAR AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),55,75,2,0),COLORRED;
STICKLINE(动力线>=3.2 AND 动力线<3.45 AND ISLASTBAR AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),75,95,2,0),COLORMAGENTA;
STICKLINE(动力线>=3.45 AND ISLASTBAR,72,80,2,0) AND W3<W1,COLORCYAN;
STICKLINE(W3<W1 AND ISLASTBAR,30,70,1,0),COLORGREEN;
STICKLINE(动力线>0 AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),96,93,1,0),COLORGRAY;
STICKLINE(动力线>=0.2 AND 动力线<0.5 AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),98,91,1.6,0),COLORGRAY;
STICKLINE(动力线>=0.5 AND 动力线<1.75 AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),97,93,1,0),COLORYELLOW;
STICKLINE(动力线>=1.75 AND 动力线<3.2 AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),97,93,1,0),COLORRED;
STICKLINE(动力线>=3.2 AND 动力线<3.45 AND ((W3>W1 AND W3<REF(W3,1)) OR W3>W1),98,92,1.6,0),COLORMAGENTA;
STICKLINE(动力线>=3.45,97,92,2,0) AND W3<W1,COLORCYAN;
STICKLINE(W3<W1,95,94,1,0),COLORGREEN;
K1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
K2:=SMA(K1,9,1)+100;
K3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K4:=SMA(K3,3,1);
K5:=SMA(K4,3,1)+100;
K6:=K5-K2;
趋势:IF(K6>45,K6-45,0),COLORLIGRAY,DOTLINE;
STICKLINE(REF(趋势,1)<趋势,趋势,REF(趋势,1),0.2,0),COLORLIRED;
STICKLINE(REF(趋势,1)>趋势,趋势,REF(趋势,1),0.2,0),COLORLIBLUE;
NOTEXT保险:9.5,COLORLIGREEN,DOTLINE;
NOTEXT分界:49,COLORGRAY,DOTLINE;
NOTEXT底部:0,COLORLICYAN,DOTLINE;
NOTEXT安全:18,COLORLICYAN,DOTLINE;
NOTEXT预警:81,COLORLIBLUE,DOTLINE;
NOTEXT顶部:99,COLORLIRED,DOTLINE;
V1:=LLV(LOW,10);
V2:=HHV(H,25);
价位线:=EMA((C-V1)/(V2-V1)*4,4);
DRAWTEXT(CROSS(价位线,0.3),20,' ● 买'),COLORRED;
DRAWTEXT(CROSS(3.5,价位线),101,' ● 卖'),COLORCYAN;
K2Q:=REF(LOW,1);
K3Q:=SMA(ABS(LOW-K2Q),3,1)/SMA(MAX(LOW-K2Q,0),3,1)*100;
K4Q:=EMA(IF(CLOSE*1.3,K3Q*10,K3Q/10),3);
K5Q:=LLV(LOW,30);
K6Q:=HHV(K4Q,30);
K7Q:=IF(MA(CLOSE,58),1,0);
K8Q:=EMA(IF(LOW<=K5Q,(K4Q+K6Q*2)/2,0),3)/618*K7Q;
K9Q:=IF(K8Q>100,100,K8Q);
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
卖临界:STICKLINE(走势-AA6>85,103,100,10,-1),COLORCYAN;
主力线:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),COLORYELLOW,NODRAW;
超短线:=(((主力线-LLV(主力线,21))/(HHV(主力线,21)-LLV(主力线,21)))*(4))* (25),LINETHICK2,COLORBLUE;
K11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
K21:=SMA(ABS(LOW-K11),13,1)/SMA(MAX(LOW-K11,0),10,1);
K31:=EMA(K21,10);
K41:=LLV(LOW,33);
K51:=EMA(IF(LOW<=K41,K31,0),3);
主力进场:IF(K51>REF(K51,1),K51*0.36,0),COLORRED,NODRAW;
STICKLINE(K51>REF(K51,1),0,K51*0.36,2.8,0 ),COLOR000055;
STICKLINE(K51>REF(K51,1),0,K51*0.36,2.4,0 ),COLOR000077;
STICKLINE(K51>REF(K51,1),0,K51*0.36,2.0,0 ),COLOR000099;
STICKLINE(K51>REF(K51,1),0,K51*0.36,1.6,0 ),COLOR0000BB;
STICKLINE(K51>REF(K51,1),0,K51*0.36,0.8,0 ),COLOR0000DD;
STICKLINE(K51>REF(K51,1),0,K51*0.36,0.2,0 ),COLOR0000FF;
震荡洗盘:IF(K51<REF(K51,1),K51*0.36,0),COLORGREEN,NODRAW;
STICKLINE(K51<REF(K51,1),0,K51*0.36,2.8,0),COLOR005500;
STICKLINE(K51<REF(K51,1),0,K51*0.36,2.4,0),COLOR007700;
STICKLINE(K51<REF(K51,1),0,K51*0.36,2.0,0),COLOR009900;
STICKLINE(K51<REF(K51,1),0,K51*0.36,1.6,0),COLOR00BB00;
STICKLINE(K51<REF(K51,1),0,K51*0.36,0.8,0),COLOR00DD00;
STICKLINE(K51<REF(K51,1),0,K51*0.36,0.2,0),COLOR00FF00;
K12:=3;
K28:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
股价准备启动:=IF(CROSS(K28,K11),100,0),COLORRED,LINETHICK2,STICK;
SS1:=(LOW+HIGH+CLOSE*2)/4;
SS2:=MA(SS1,4);
SS3:=HHV(SS2,10);
SS4:=MA(SS3,3);
SS5:=1.25*SS4-0.25*SS3;
XKKJ:=IF(SS5>SS3,SS3,SS5);
FF1:=LLV(SS2,10);
FF2:=MA(FF1,3);
FF3:=1.25*FF2-0.25*FF1;
DKKJ:=IF(FF3<FF1,FF1,FF3);
MA13:=MA(C,13);
ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);
ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);
黑马大牛:IF(ZDHM OR ZHM,66,0),COLORMAGENTA,LINETHICK2,STICK;
动态底部:=EMA(IF(L<=LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),99,1),0)*5,3);
RSV11:=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;
K:=SMA(RSV11,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
短线:=EMA(J,6);
浮筹:=MA(短线,28)*1;
空方:=MA(100*(HHV(HIGH,35)-CLOSE)/(HHV(HIGH,35)-LLV(LOW,35)),3);
DRAWTEXT(CROSS(浮筹,空方),30,' 追'),COLORYELLOW;
DRAWICON(CROSS(浮筹,空方),30,38);
NOTEXTQW:主力线,DOTLINE,COLORYELLOW;
QA:=主力线;
QB:=趋势;
QAA:=(CROSS(QA,8) OR CROSS(QA,8.4) OR CROSS(QA,8.8) OR CROSS(QA,9.2) OR CROSS(QA,9.6) OR CROSS(QA,10) OR CROSS(QA,10.2) OR CROSS(QA,10.6) OR CROSS(QA,11)) AND QA>REF(QA,1);
QBB:=(CROSS(QB,2) OR CROSS(QB,3) OR CROSS(QB,4) OR CROSS(QB,5) OR CROSS(QB,6) OR CROSS(QB,7) OR CROSS(QB,8) OR CROSS(QB,9) OR CROSS(QB,10) OR CROSS(QB,11)) AND QB>REF(QB,1);
DRAWICON(FILTER(QAA OR QBB,3) AND C>REF(C,1) AND C>MA(C,3),-3,11);

通达信小白顶底指标公式

 

相关文章