在线检测未来函数

通达信天地波段指标公式

来源:Internet,编辑:股旁网,2017-07-24

VAR1:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR16:=EMA(VAR15,13);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR1E:=AMOUNT/VOL/100;
VAR20:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR21:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR22:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR23:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR24:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR25:=EMA(VAR24,24);
VAR26:=STD(VAR24,24);
VAR27:=(VAR24-VAR25)/VAR26*100;
VAR28:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR29:=EMA(VAR27,5);
VAR2A:=(VAR1E-MA(VAR1E,21))/(0.015*AVEDEV(VAR1E,21));
VAR2B:=SUMBARS(VOL,CAPITAL);
VAR2C:=(VAR20-MA(VAR20,90))/(0.015*AVEDEV(VAR20,90));
VAR2D:=((VAR2C+VAR2A+VAR29+VAR28+VAR21)/5+165)/4;
VAR2E:=(EMA(EMA(EMA(VAR2D,15),10),5)-25)*2+VAR23;
VAR2F:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR30:=EMA(VAR2F,13);
VAR31:=(VAR2D+VAR2F)/2/1.1;
VAR32:=HHV(VAR22,VAR2B);
VAR33:=LLV(VAR22,VAR2B);
VAR34:=(VAR22-VAR33)/(VAR32-VAR33);
人: IF(VAR22>=VAR32,(2*VAR22-VAR33-REF(VAR32,1))/(VAR32-VAR33),VAR34),COLORRED;
IF(VAR22<=VAR33,(2*VAR22-VAR33-REF(VAR33,1))/(VAR32-VAR33),VAR34),COLORGREEN;
AAA:=IF(VAR22>=VAR32,(2*VAR22-VAR33-REF(VAR32,1))/(VAR32-VAR33),VAR34);
DRAWICON(AAA<=0,0,4);
DRAWICON(AAA>=1,1.1,5);
地: 0;

通达信天地波段指标公式

 

相关文章