在线检测未来函数

通达信中长线波段指标公式

来源:Internet,编辑:股旁网,2017-09-11

AAX:=MA((2*CLOSE+HIGH+LOW)/4,5);
BB:=AAX*(200-102)/100;
XGG:=CROSS(C,BB);
RSV:=(C-LLV(L,60))/(HHV(H,9)-LLV(L,60))*100;
K:=SMA(RSV,9,1);
D:=SMA(K,9,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
CDL:=(CROSS(J,REF(J+0.01,1)) AND X AND (J<12)) AND ((CROSS(C,MA(C,3)))
AND (CROSS(J,REF(J+0.01,1)) AND X AND (J<12)) AND ((CROSS(J,REF(J+0.01,1))) AND X)
AND XGG);
DRAWICON(CDL,L,15);
DBXC:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
QSX:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
TJ2:=CROSS(DBXC,-24);
DRAWICON(TJ2,QSX,11);
DRAWICON(CROSS(QSX,10),QSX,13);
VARCQ3:=REF(CLOSE,1);
VARDQ3:=SMA(MAX(CLOSE-VARCQ3,0),7,1)/SMA(ABS(CLOSE-VARCQ3),7,1)*100;
VAREQ3:=SMA(MAX(CLOSE-VARCQ3,0),13,1)/SMA(ABS(CLOSE-VARCQ3),13,1)*100;
VARFQ3:=BARSLAST(VAREQ3<43)<=3 AND CROSS(VARDQ3,VAREQ3);
VAR10Q3:=(CLOSE-MA(CLOSE,43))/MA(CLOSE,20)*100<-12.5;
VAR11Q3:=LLV(LOW,5);
VAR12Q3:=HHV(HIGH,10);
VAR13Q3:=EMA((CLOSE-VAR11Q3)/(VAR12Q3-VAR11Q3)*100,4);
VAR14Q3:=EMA(0.667*REF(VAR13Q3,1)+0.333*VAR13Q3,2);
VAR15Q3:=1011131;
VAR16Q3:=IF(DATE<=VAR15Q3,VAR10Q3,0) OR IF(DATE<=VAR15Q3,80,0);
VARXG:=0-(-1)*VARFQ3 AND VAR10Q3 AND CROSS(VAR13Q3,VAR14Q3) AND
VAR13Q3<=25,COLORFFFF00,COLOR8000FF;
DRAWICON(VARXG,QSX,38);
DRAWTEXT(VARXG,QSX+2,'长线波段显现')COLORYELLOW;

通达信中长线波段指标公式

 

相关文章