在线检测未来函数

通达信五浪画线主图指标公式

来源:Internet,编辑:股旁网,2017-09-27

X:=5;
D:=10;
M5:MA(C,X);
M10:MA(C,D);
T:=BARSLAST(CROSS(M5,M10));
ST:=BARSLAST(CROSS(M10,M5));
T1:=SUMBARS(T=0,2);
T2:=SUMBARS(T=0,3);
ST1:=SUMBARS(ST=0,2);
ST2:=SUMBARS(ST=0,3);
H1:=IF(CONST(M5)>CONST(M10),HHV(H,T+1),REF(HHV(H,T+1),ST));
L1:=IF(CONST(M5)<CONST(M10),LLV(L,ST+1),REF(LLV(L,ST+1),T));
H2:=IF(CONST(M5)>CONST(M10),REF(HHV(H,T+1),ST),REF(HHV(H,T+1),ST1-1));
L2:=IF(CONST(M5)<CONST(M10),REF(LLV(L,ST+1),T),REF(LLV(L,ST+1),T1-1));
H3:=IF(CONST(M5)>CONST(M10),REF(HHV(H,T+1),ST1-1),REF(HHV(H,T+1),ST2-1));
L3:=IF(CONST(M5)<CONST(M10),REF(LLV(L,ST+1),T1-1),REF(LLV(L,ST+1),T2-1));
TJ1:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(T2) AND CURRBARSCOUNT<=CONST(ST2) AND L=CONST(L3);
TJ2:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(ST1) AND CURRBARSCOUNT<=CONST(T2) AND H=CONST(H3);
TJ3:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(T1) AND CURRBARSCOUNT<=CONST(ST1) AND L=CONST(L2);
TJ4:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(ST) AND CURRBARSCOUNT<=CONST(T1) AND H=CONST(H2);
TJ5:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(T)+1 AND CURRBARSCOUNT<=CONST(ST)+1 AND L=CONST(L1);
TJ6:=CONST(M5)>CONST(M10) AND H=CONST(H1) AND CURRBARSCOUNT<=CONST(ST2);
TJ7:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(ST2) AND CURRBARSCOUNT<=CONST(T2) AND H=CONST(H3);
TJ8:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(T1) AND CURRBARSCOUNT<=CONST(ST2) AND L=CONST(L3);
TJ9:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(ST1) AND CURRBARSCOUNT<=CONST(T1) AND H=CONST(H2);
TJ10:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(T) AND CURRBARSCOUNT<=CONST(ST1) AND L=CONST(L2);
TJ11:=CONST(M5)<CONST(M10) AND CURRBARSCOUNT>=CONST(ST)+1 AND CURRBARSCOUNT<=CONST(T)+1 AND H=CONST(H1);
TJ12:=CONST(M5)<CONST(M10) AND L=CONST(L1)AND CURRBARSCOUNT<=CONST(T2);
DRAWLINE(TJ1,L,TJ2,H,0),COLORMAGENTA;
DRAWLINE(TJ2,H,TJ3,L,0),COLORMAGENTA;
DRAWLINE(TJ3,L,TJ4,H,0),COLORMAGENTA;
DRAWLINE(TJ4,H,TJ5,L,0),COLORMAGENTA;
DRAWLINE(TJ5,L,TJ6,H,0),COLORMAGENTA;
DRAWLINE(TJ7,H,TJ8,L,0),COLORGREEN;
DRAWLINE(TJ8,L,TJ9,H,0),COLORGREEN;
DRAWLINE(TJ9,H,TJ10,L,0),COLORGREEN;
DRAWLINE(TJ10,L,TJ11,H,0),COLORGREEN;
DRAWLINE(TJ11,H,TJ12,L,0),COLORGREEN;
HH:=CONST(MAX(MAX(H1,H2),H3));
LL:=CONST(MIN(MIN(L1,L2),L3));
Z:=(HH-LL)/2+LL;
DRAWLINE(TJ7,Z,ISLASTBAR,Z,0),COLORGREEN,DOTLINE;
DRAWTEXT(TJ7,CONST(Z)*1.01,VARCAT(VARCAT('中区价位:',VAR2STR(CONST(Z),2)),'元')),COLORGREEN;
HH1:=CONST(MAX(H1,MAX(H2,H3)));
LL1:=CONST(MIN(MIN(L1,L2),L3));
Z1:=(HH1-LL1)/2+LL1;
DRAWLINE(TJ1,Z1,ISLASTBAR,Z1,0),COLORMAGENTA,DOTLINE;
DRAWTEXT(TJ1,CONST(Z)*1.01,VARCAT(VARCAT('中区价位:',VAR2STR(CONST(Z1),2)),'元')),COLORMAGENTA;
近高:H1,COLORMAGENTA,NODRAW;
近低:L1,COLORGREEN,NODRAW;
中高:H2,COLORMAGENTA,NODRAW;
中底:L2,COLORGREEN,NODRAW;
远高:H3,COLORMAGENTA,NODRAW;
远底:L3,COLORGREEN,NODRAW;

通达信五浪画线主图指标公式

 

相关文章