在线检测未来函数

通达信简明的黄金柱主图指标公式

来源:Internet,编辑:股旁网,2017-09-07

JJ:=(3*C+H+L+O)/6;
VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1;
LJL:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(LJL)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(LJL)=3 AND CLOSE>REF(HIGH,3),1,0)));
TP:=TJ2=1;
STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),6,0),COLORYELLOW;
TJ3:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(LJL)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(LJL)=3 AND CLOSE>REF(LOW,3),1,0)));
STFZ:=TJ3=1;
CL:=STFZ AND TP;
TJCL:=FILTER(CL,3);
DRAWTEXT(LJL,L*0.99,'黄'),COLORYELLOW;
DRAWTEXT(LJL,L*0.95,'金'),COLORYELLOW;
DRAWTEXT(LJL,L*0.90,'柱'),COLORYELLOW;

通达信简明的黄金柱主图指标公式

 

相关文章