在线检测未来函数

通达信能捉妖主图指标公式

来源:Internet,编辑:股旁网,2017-10-16

DRAWBAND(COST(70),RGB(80,0,80),COST(90),RGB(88,8,240));
DRAWBAND(COST(50),RGB(80,60,80),COST(70),RGB(88,68,240));
DRAWBAND(COST(30),RGB(80,120,80),COST(50),RGB(88,128,240));
DRAWBAND(COST(10),RGB(80,190,80),COST(30),RGB(88,188,240));
{彩色K线}
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
{空心红}
STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED;
{深绿}
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
{蓝}
STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44;
{黄}
STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF;
STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF;
STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;
{粉红}
STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF;
{亮灰}
STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
{深红}
STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;
{涨跌停K线}
STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORWHITE;
{突破}
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
A1:=CLOSE*VOL;
A2:=EMA((EMA(A1,3)/EMA(VOL,3)+EMA(A1,6)/EMA(VOL,6)+EMA(A1,12)/EMA(VOL,12)+EMA(A1,24)/EMA(VOL,24))/4,13);
A3:=1.06*A2;
A4:=EMA(A3-(EMA(CLOSE,3)-A3),5);
AAK:IF(A4<=A3,A4,A3),COLORYELLOW,LINETHICK2;
A5:=2*A3-AAK;
AAA:IF(A5>=A3,A5,A3),COLORYELLOW,LINETHICK2;
观望:IF(AAK=AAA,AAK,DRAWNULL),COLORGREEN,LINETHICK2;
趋势:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
ZZ:=趋势>REF(趋势,1);
K1:=VOL/1000000;
K2:=CLOSE;
V1:=EMA(K1,5);
V2:=EMA(K2,5);
价异动:=K2>REF(V2,1)*1.06;
量异动:=K1>REF(V1,1)*1.6&&ZZ;
停牌:=DYNAINFO(17)>0;
MK1:=SUM(价异动,2)>0 AND 停牌;
MK2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;
共鸣:=( C>REF(C,1) AND FILTER(MK1 AND MK2,3))*6,COLORRED;
XGP:=AAK=AAA AND 共鸣;
DRAWICON(XGP,O*1.01,10);
DRAWTEXT(XGP,O*1.01,' ←突破顶,'),COLORYELLOW;

通达信能捉妖主图指标公式

 

相关文章