在线检测未来函数

通达信涨停敢死队选股指标公式

来源:Internet,编辑:股旁网,2017-12-27

X_1:=MA(CLOSE,5);
X_2:=MA(CLOSE,10);
X_3:=MA(CLOSE,20);
X_4:=MA(CLOSE,60);
X_5:=MA(CLOSE,120);
X_6:=3;
X_7:=5;
X_8:=8;
X_9:=13;
X_10:=21;
X_11:=34;
X_12:=14;
X_13:=EMA(CLOSE,X_8)-EMA(CLOSE,X_9);
X_14:=EMA(X_13,X_7);
X_15:=X_13>X_14;
X_16:=X_13<X_14;
X_17:=IF(X_13>X_14,1,0);
X_18:=(CLOSE-LLV(LOW,X_8))/(HHV(HIGH,X_8)-LLV(LOW,X_8))*100;
X_19:=SMA(X_18,X_6,1);
X_20:=SMA(X_19,X_6,1);
X_21:=X_19>X_20;
X_22:=X_19<X_20;
X_23:=IF(X_19>X_20,1,0);
X_24:=REF(CLOSE,1);
X_25:=SMA(MAX(CLOSE-X_24,0),X_7,1)/SMA(ABS(CLOSE-X_24),X_7,1)*100;
X_26:=SMA(MAX(CLOSE-X_24,0),X_9,1)/SMA(ABS(CLOSE-X_24),X_9,1)*100;
X_27:=X_25>X_26;
X_28:=X_25<X_26;
X_29:=IF(X_25>X_26,1,0);
X_30:=(-HHV(HIGH,X_9)-CLOSE)/(HHV(HIGH,X_9)-LLV(LOW,X_9))*100;
X_31:=SMA(X_30,X_6,1);
X_32:=SMA(X_31,X_6,1);
X_33:=X_31>X_32;
X_34:=X_31<X_32;
X_35:=IF(X_31>X_32,1,0);
X_36:=(MA(CLOSE,X_6)+MA(CLOSE,X_7)+MA(CLOSE,X_8)+MA(CLOSE,X_9))/4;
X_37:=CLOSE>X_36;
X_38:=CLOSE<X_36;
X_39:=IF(CLOSE>X_36,1,0);
X_40:=CLOSE-REF(CLOSE,1);
X_41:=100*EMA(EMA(X_40,X_7),X_6)/EMA(EMA(ABS(X_40),X_7),X_6);
X_42:=100*EMA(EMA(X_40,X_9),X_8)/EMA(EMA(ABS(X_40),X_9),X_8);
X_43:=X_41>X_42;
X_44:=X_41<X_42;
X_45:=IF(X_41>X_42,1,0);
X_46:=(HIGH+LOW+CLOSE)/3;
X_47:=(X_46-MA(X_46,X_12))/(0.015*AVEDEV(X_46,X_12));
X_48:=X_47>REF(X_47,1) AND X_47>(-60);
X_49:=X_47<REF(X_47,1) AND X_47<103;
X_50:=IF(X_47>REF(X_47,1),1,0);
X_51:=(CLOSE-MA(CLOSE,X_7))/MA(CLOSE,X_7);
X_52:=X_51-REF(X_51,16);
X_53:=SMA(X_52,76,1);
X_54:=MA(X_53,5);
X_55:=X_53>X_54;
X_56:=X_53<X_54;
X_57:=IF(X_53>X_54,1,0);
X_58:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
X_59:=LLV(X_58,3);
X_60:=MA(X_58,12);
X_61:=CROSS(X_58,X_60);
X_62:=MA(X_58,5);
X_63:=CROSS(X_62,X_58) AND X_62>80;
X_64:=X_58>X_60;
X_65:=X_58<X_60;
X_66:=IF(X_58>X_60,1,0);
X_67:=CLOSE-REF(CLOSE,1);
X_68:=100*EMA(EMA(X_67,X_8),X_8)/EMA(EMA(ABS(X_67),X_8),X_8);
X_69:=MA(X_68,5);
X_70:=X_68>X_69;
X_71:=X_68<X_69;
X_72:=IF(X_68>X_69,1,0);
X_73:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
X_74:=REF(EMA(X_73,3),1);
X_75:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
X_76:=IF(CLOSE>OPEN,X_75*(HIGH-LOW),IF(CLOSE<OPEN,X_75*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-X_75*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-X_75*(HIGH-LOW),0-VOL/2));
X_77:=X_76/20/1.15;
X_78:=X_77*0.55+REF(X_77,1)*0.33+REF(X_77,2)*0.22;
X_79:=EMA(X_78,8);
X_80:=EMA(X_78,3);
X_81:=X_80;
X_82:=X_81>0;
X_83:=X_81<0;
X_84:=IF(X_81>0,1,0);
X_85:=IF(CLOSE>SAR(4,2,20),1,0);
X_86:=LLV(LOW,9);
X_87:=HHV(HIGH,9);
X_88:=EMA((CLOSE-X_86)/(X_87-X_86)*100,3);
X_89:=EMA(X_88,3);
X_90:=MA(X_19,3);
X_91:=IF(X_89>X_90,1,0);
X_92:=(CLOSE+HIGH+LOW+OPEN)/4;
X_93:=SUMBARS(VOL,CAPITAL);
X_94:=HHV(X_92,X_93);
X_95:=LLV(X_92,X_93);
X_96:=(2*X_92-X_95-REF(X_95,1))/(X_94-X_95);
X_97:=(X_92-X_95)/(X_94-X_95);
X_98:=IF(X_92<=X_95,X_96*60,X_97*60);
X_99:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
X_100:=EMA(X_99,7);
X_101:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
X_102:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
X_103:=HHV(HIGH,9)-LLV(LOW,9);
X_104:=HHV(HIGH,9)-CLOSE;
X_105:=CLOSE-LLV(LOW,9);
X_106:=X_104/X_103*100-70;
X_107:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
X_108:=(2*CLOSE+HIGH+LOW)/4;
X_109:=SMA(X_105/X_103*100,3,1);
X_110:=LLV(LOW,34);
X_111:=SMA(X_109,3,1)-SMA(X_106,9,1);
X_112:=IF(X_111>100,X_111-100,0);
X_113:=HHV(HIGH,34);
X_114:=EMA((X_108-X_110)/(X_113-X_110)*100,8);
X_115:=EMA(X_114,5);
X_116:=IF(X_114-X_115>0,1,0);
X_117:=SMA(AMOUNT,10,1)/10000000*2;
X_118:=REF(X_117,1);
X_119:=IF(X_117>X_118,1,0);
X_120:=18;
X_121:=10;
X_122:=(2*CLOSE+HIGH+LOW+OPEN)/5;
X_123:=LLV(LOW,X_121);
X_124:=HHV(HIGH,X_121);
X_125:=EMA((X_122-X_123)/(X_124-X_123)*100,13);
X_126:=EMA(X_125,3);
X_127:=IF(X_125>REF(X_125,1),1,0);
X_128:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*200*10;
X_129:=SMA(X_128,5,1);
X_130:=IF(X_129>REF(X_129,1),1,0);
X_131:=X_17+X_23+X_29+X_35+X_39+X_45+X_50+X_57+X_66+X_72+X_84+X_85+X_91+X_116+X_119+X_127+X_130;
X_132:=IF(X_131>7,1,0);
X_133:=(CLOSE/REF(CLOSE,1)-1)*100;
X_134:=(CLOSE/REF(CLOSE,1)-1)*100>=9.91;
X_135:=VOL/REF(MA(VOL,5),1);
X_136:=AMOUNT/100000000;
X_137:=IF(X_135>1,1,0);
X_138:=IF(VOL>REF(VOL,1)*1.2,1,0);
X_139:=EMA(CLOSE,2);
X_140:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
X_141:=CROSS(X_139,X_140);
X_142:=CROSS(X_140,X_139);
X_143:=IF(X_141>0,1,0);
X_144:=IF(CLOSE>MA(CLOSE,20) OR CLOSE>MA(CLOSE,60),1,0);
X_145:=IF(CLOSE<REF(CLOSE,40)*1.6 AND CLOSE>REF(CLOSE,40) AND CLOSE>REF(CLOSE,1),1,0);
X_146:=IF(VOL>MA(VOL,40),1,0);
X_147:=EMA(WINNER(CLOSE)*70,3);
X_148:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*65,3);
X_149:=X_148/(X_147+X_148)*100;
X_150:=X_147/(X_147+X_148)*100;
X_151:=EMA(X_150,89);
X_152:=INTPART(X_149);
X_153:=INTPART(X_150);
X_154:=IF(X_153>X_152,1,0);
X_155:=IF(VOL>REF(VOL,10)*0.5,1,0);
X_156:=IF(CLOSE>REF(CLOSE,1)*1.07,1,0);
X_157:=IF(CLOSE>REF(CLOSE,1)*1.05,1,0);
X_158:=IF(REF(X_133,1)<9.91,2,0);
X_159:=IF(REF(X_133,2)<9.91,2,0);
X_160:=IF(X_158=0 AND X_159=0,0,1);
X_161:=IF(COUNT(X_133>=9.91,25)>=4 OR (COUNT(X_133>=9.91,25)>=3 AND CLOSE<HHV(CLOSE,20)),0,1);
X_162:=VOL*CLOSE*100;
X_163:=SUM(X_162,1)/(SUM(VOL,1)*100);
X_164:=5;
X_165:=EMA(X_163,X_164);
X_166:=(X_163-X_165)*100/X_163;
X_167:=HHV(X_166,30);
X_168:=X_166>=HHV(REF(X_166,1),15);
X_169:=TFILTER(X_166>0 AND X_168>0,X_166<=0,1);
X_170:=IF(X_169>0,1,0);
X_171:=IF(X_166>0 AND (BARSLAST(X_170=1)>=0 AND BARSLAST(X_170=1)<=10),1,0);
X_172:=IF(X_137>0 AND X_138>0 AND X_144>0 AND X_145>0 AND X_146>0 AND X_154>0 AND X_155>0 AND X_132>0 AND X_157>0 AND X_160>0 AND X_161>0 AND X_171>0,1,0);
X_173:=IF(X_172>0 AND X_132>0,1,0);
X_174:=TFILTER(X_173>0,X_132=0,1);
X_175:=TFILTER(X_173>0,X_132=0,2);
X_176:=IF(NAMELIKE(1),0,1);
X_177:=IF(NAMELIKE(2),0,1);
X_178:=DYNAINFO(17)>0;
X_179:=X_176 AND X_177 AND X_178;
XG:X_179 AND X_174;

通达信涨停敢死队选股指标公式

 

相关文章