在线检测未来函数

通达信账户统计主图指标公式

来源:Internet,编辑:股旁网,2018-01-05

MA5:MA(C,5);MA10:MA(C,10);MA20:MA(C,20);MA60:MA(C,60);
DRAWRECTREL(IF(TOTALBARSCOUNT>80,0,455),280,IF(TOTALBARSCOUNT>80,330,790),590,RGB(40,70,50));
DRAWRECTREL(IF(TOTALBARSCOUNT>80,0,736),280,IF(TOTALBARSCOUNT>80,278,790),590,RGB(40,70,50));
{账户统计}
股一成本:=29.19 ; 股一数量:=500; 股一现价:="600516$C";
股二成本:=17.25 ; 股二数量:=500; 股二现价:="600903$C";
股三成本:=8.750; 股三数量:=1000 ; 股三现价:="000426$C";
股四成本:=5.81 ; 股四数量:=1000; 股四现价:="000725$C";
股五成本:=00000 ; 股五数量:=0000; 股五现价:="000$C";
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.005,0.46),0.34,0,'方大炭素'),COLORCYAN;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.005,0.46),0.39,0,'贵州燃气'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.005,0.46),0.44,0,'兴业矿业'),COLORCYAN;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.005,0.46),0.49,0,'京东方A'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.005,0.46),0.54,0,'空余'),COLORCYAN;
{--------------以上股票代码和名称应与自己持股做修改--------------}
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.015,0.47),0.29,0,'股名'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.063,0.518),0.29,0,'持仓'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.105,0.56),0.29,0,'成本'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.151,0.606),0.29,0,'涨跌'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.195,0.65),0.29,0,'盈比'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.241,0.696),0.29,0,'盈亏'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.284,0.742),0.39,0,'总盈比'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.284,0.742),0.49,0,'现总值'),COLORYELLOW;
股一盈亏:=INTPART((股一现价-股一成本)*股一数量);
股二盈亏:=INTPART((股二现价-股二成本)*股二数量);
股三盈亏:=INTPART((股三现价-股三成本)*股三数量);
股四盈亏:=INTPART((股四现价-股四成本)*股四数量);
股五盈亏:=INTPART((股五现价-股五成本)*股五数量);
股一盈亏比:=(股一现价-股一成本)/股一成本*100;
股二盈亏比:=(股二现价-股二成本)/股二成本*100;
股三盈亏比:=(股三现价-股三成本)/股三成本*100;
股四盈亏比:=(股四现价-股四成本)/股四成本*100;
股五盈亏比:=(股五现价-股五成本)/股五成本*100;
股一涨跌:=CONST(股一现价-股一成本);
股二涨跌:=CONST(股二现价-股二成本);
股三涨跌:=CONST(股三现价-股三成本);
股四涨跌:=CONST(股四现价-股四成本);
股五涨跌:=CONST(股五现价-股五成本);
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.06,0.515),0.34,0,股一数量),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.06,0.515),0.39,0,股二数量),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.06,0.515),0.44,0,股三数量),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.06,0.515),0.49,0,股四数量),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.06,0.515),0.54,0,股五数量),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.097,0.553),0.34,0,股一成本),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.097,0.553),0.39,0,股二成本),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.097,0.553),0.44,0,股三成本),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.097,0.553),0.49,0,股四成本),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.097,0.553),0.54,0,股五成本),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.146,0.601),0.34,0,股一涨跌),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.146,0.601),0.39,0,股二涨跌),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.146,0.601),0.44,0,股三涨跌),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.146,0.601),0.49,0,股四涨跌),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.146,0.601),0.54,0,股五涨跌),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.188,0.643),0.34,0,CONST(股一盈亏比)),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.188,0.643),0.39,0,CONST(股二盈亏比)),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.188,0.643),0.44,0,CONST(股三盈亏比)),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.188,0.643),0.49,0,CONST(股四盈亏比)),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.188,0.643),0.54,0,CONST(股五盈亏比)),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.237,0.693),0.34,0,CONST(股一盈亏)),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.237,0.693),0.39,0,CONST(股二盈亏)),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.237,0.693),0.44,0,CONST(股三盈亏)),COLORCYAN;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.237,0.693),0.49,0,CONST(股四盈亏)),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.237,0.693),0.54,0,CONST(股五盈亏)),COLORCYAN;
总盈:=CONST(股一盈亏)+CONST(股二盈亏)+CONST(股三盈亏)+CONST(股四盈亏)+CONST(股五盈亏);
DRAWTEXT_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.284,0.742),0.29,0,'总盈值'),COLORYELLOW;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.284,0.742),0.34,0,CONST(总盈)),COLORCYAN;
总成本:=CONST((股一成本*股一数量)+(股二成本*股二数量)+(股三成本*股三数量)+
(股四成本*股四数量)+(股五成本*股五数量));
总盈比:=总盈/总成本*100;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.284,0.742),0.44,0,CONST(总盈比)),COLORCYAN;
股一现值:=股一数量*股一现价;
股二现值:=股二数量*股二现价;
股三现值:=股三数量*股三现价;
股四现值:=股四数量*股四现价;
股五现值:=股五数量*股五现价;
总市值:=股一现值+股二现值+股三现值+股四现值+股五现值;
DRAWNUMBER_FIX(C!=0,IF(TOTALBARSCOUNT>80,0.284,0.742),0.54,0,CONST(总市值)),COLORCYAN;

通达信账户统计主图指标公式

 

相关文章