在线检测未来函数

通达信双均画线主图指标公式

来源:Internet,编辑:股旁网,2018-01-10

{使用说明:出现连续阳线一般是多方所为,在上一次连续阳线出现后我们在它的实体平均价格画一条黄色水平线,在它的成交额/成交量/100(均价)的平均价画一条洋红色水平线,看看多方在上次进攻中的成本在哪个位置。}

JJ:=AMOUNT/VOL/100;
VAR0:=BARSLASTCOUNT(C>O);
T:=BARSLAST(CROSS(VAR0=1 AND REFX(VAR0=2,1),0.5));
VAR2:=IF(ISLASTBAR,VAR0>1,VAR0>1 AND REFX(C<=O,1));
T2:=BARSLAST(VAR2);
中间价:CONST((REF(HHV(C,T+1),T2)+REF(LLV(O,T+1),T2))/2),NODRAW;
中间均价:CONST(REF(SUM(JJ,T+1)/(T+1),T2)),NODRAW;
IF(CURRBARSCOUNT<=CONST(T)+1,中间价,DRAWNULL),COLORYELLOW;
IF(CURRBARSCOUNT<=CONST(T)+1,中间均价,DRAWNULL),COLORMAGENTA;

通达信双均画线主图指标公式

 

相关文章