在线检测未来函数

通达信建洗增拉主图指标公式

来源:Internet,编辑:股旁网,2018-01-15

N:=25;
G1:=BARSLAST(DATE=1151223);
D1:=BARSLAST(DATE=1150826);
ZF1:=REF((C-REF(C,D1+1))/REF(C,D1+1)*100,G1);
V1:=REF(SUM(VOL,D1+1),G1);
L1:=REF(LLV(L,D1+1),G1);
D2:=BARSLAST(L=LLV(L,G1+1));
V2:=REF(SUM(VOL,G1+1),D2);
L2:=REF(LLV(L,G1+1),D2);
V3:=SUM(VOL,D2+1);
TJ1:=RANGE(ZF1,N,N*2);
TJ2:=L1<L2 AND V1>V2;
TJ3:=CROSS(V3>V1,0.5);
TJ4:=TJ1 AND TJ2 AND TJ3;
GG:=BARSLAST(TJ4);
ZF2:=(REF(C,GG)/REF(C,D2+1)-1)*100;
DD:IF(ZF2<ZF1,REF(H,GG),DRAWNULL)COLORRED LINETHICK2;
XG1:=CROSS(C,DD)||(COUNT(C>REF(H,GG),GG)=1 AND C>REF(H,GG));
DRAWICON(XG1 AND ZF2<ZF1,L,1);
DRAWTEXT(G1+1,H,VARCAT(VARCAT('涨:',VAR2STR(ZF1,2)),'%'))DRAWABOVE COLORYELLOW;
REF(H,G1)COLORRED DOTLINE;
REF(L,D1)COLORGREEN DOTLINE;

通达信建洗增拉主图指标公式

 

相关文章