在线检测未来函数

通达信量柱语言指标公式

来源:Internet,编辑:股旁网,2018-01-23

PERIOD5:=COUNT(DATE<>REF(DATE,1),2)=2;
FROMOPEN1:=IF(HOUR<12,60*(HOUR-9)-30+MINUTE,120+60*(HOUR-13)+MINUTE);
VVOL:IF(BARSCOUNT(CLOSE)=1 AND PERIOD5,VOL*240/FROMOPEN,0),LINETHICK0;
STICKLINE(BARSCOUNT(CLOSE)=1 AND PERIOD5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
AA:=VOL>REF(V,1)*1.9;
AA1:=VOL<REF(LLV(VOL,13),1);
AA2:=VOL<REF(LLV(VOL,55),1);
STICKLINE(AA,0,V,2,0),COLORYELLOW;
STICKLINE(AA1,0,V,4,0),COLORGREEN;
STICKLINE(AA2,0,V,2,0),COLORMAGENTA;
TJ1:=COUNT(V>REF(V,1)*1.9,4)=1;
TJ2:=COUNT(V<REF(V,1) AND L>MIN(L,4) AND L>REF(L,1),3)=3 ;
TJ3:=TJ1 AND TJ2;
STICKLINE(TJ3,0,V,4,0),COLORRED;
MV2:MA(V,2),COLORWHITE;
MV6:MA(V,6),COLORYELLOW;
MV20:MA(V,20),COLORMAGENTA;
量柱:V/CAPITAL*100,VOLSTICK;
倍量柱:=IF(V/REF(V,1)>1.9 AND C>REF(C,1),1,0);
高量柱:=IF(V=HHV(V,10),3,2);
低量柱:=IF(V=LLV(V,10),9,8);
并肩平量柱:=IF((V/REF(V,1)>0.95 AND V/REF(V,1)<1.05),7,6);
缩量柱:=IF(V<REF(V,1) AND REF(V,1)<REF(V,2) AND REF(V,2)<REF(V,3),25,35);
梯量柱:=IF(V>REF(V,1) AND REF(V,1)>REF(V,2) AND REF(V,2)>REF(V,3),11,10);
DRAWTEXT(倍量柱>0,VOLUME*1.4,'倍'),COLORWHITE;
DRAWTEXT(高量柱>2,VOLUME*0.8,'高'),COLORWHITE;
DRAWTEXT(并肩平量柱>6,VOLUME*0.7,'平'),COLORWHITE;
DRAWTEXT(梯量柱>10,VOLUME*0.55,'梯'),COLORWHITE;
DRAWTEXT(低量柱>8,VOLUME*1.3,'低'),COLORYELLOW;
DRAWTEXT(缩量柱<35,VOLUME*1.8,'缩'),COLORYELLOW;

通达信量柱语言指标公式

 

相关文章