在线检测未来函数

通达信横盘区主图指标公式

来源:Internet,编辑:股旁网,2018-01-26

XXX1:=(HHV(H,30)-LLV(L,30))/LLV(L,30)*100<15;
XXX2:=HHV(H,20)<=REF(HHV(H,20),9) AND LLV(L,20)>=REF(LLV(L,20),9);
XXX3:=HHV(H,20)<=REF(HHV(H,10),19) AND LLV(L,20)>=REF(LLV(L,10),19);
XXX:XXX1*XXX2*XXX3 AND REFX(C>REF(HHV(H,30),1),1),NODRAW;
FT:=BARSNEXT(XXX);
HH:=REFX(HHV(H,30),FT);
LL:=REFX(LLV(L,30),FT);
T:=MIN(BARSLAST(H>HH AND FT>29) ,BARSLAST(L<LL AND FT>29) );
FTT:=REFX(T,FT);
STICKLINE(FT<FTT AND FT>0 ,HH,LL,8,0),COLORAA0044;
STICKLINE(FT=FTT OR XXX,HH,LL,0,0),COLOR00FFFF;
STICKLINE(FT<FTT AND FT>0 ,HH,HH,8,0),COLOR00FFFF;
STICKLINE(FT<FTT AND FT>0 ,LL,LL,8,0),COLOR00FFFF;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

通达信横盘区主图指标公式

 

相关文章