在线检测未来函数

通达信金凤凰穿越主图指标公式

来源:Internet,编辑:股旁网,2018-03-08

M5:MA(CLOSE,5);
M10:MA(CLOSE,10);
M20:MA(CLOSE,20);
M60:MA(CLOSE,60);
M120:MA(CLOSE,120);
M240:MA(CLOSE,240);
STICKLINE(CLOSE/REF(C,1)>=1.09,O,C,2.7,0),COLORYELLOW;
工作线:=MA(CLOSE,14),COLORFF00FF,LINETHICK1;
二号线:=MA(CLOSE,25),COLORYELLOW;三号线:=MA(CLOSE,99),COLORGREEN;
四号线:=MA(CLOSE,144),COLORBLUE;生命线:=MA(CLOSE,453),COLORYELLOW,LINETHICK2;
VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
A81:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);
B8:=ZIG(3,5)*100;
G:=MA(B8,2);
D:=CROSS(B8,G);
W:=CROSS(G,B8);
E:=REF(INDEXC,1);
F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);
VAR10:=F AND F<8;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR13 AND VAR13<20;
DRAWTEXT(FILTER(D=1,5),(L+C)/2,'↖准'),COLORYELLOW;
DRAWTEXT(W=1,HIGH,'逃'),COLORGREEN;
STICKLINE(W=1,O,C,3,0),COLORBLUE;
STICKLINE(D=1,O,C,3,0),COLORYELLOW;
MID :=MA(CLOSE,20)DOTLINE;
布林上轨:MID+2*STD(CLOSE,20)DOTLINE;
布林下轨:MID-2*STD(CLOSE,20)DOTLINE;
P3:=(REF(C,1)-REF(C,4))/REF(C,4)*100<6;
P2:=REF(C,240)*1.4>REF(C,1);
P4:=(C-REF(C,1))/REF(C,1)*100>2;
P5:=(REF(C,1)-REF(C,2))/REF(C,2)*100<5;
P6:=(O-REF(C,1))/REF(C,1)*100<2;
P7:=REF(C,60)*1.12>REF(C,1);
P9:=(HHV(HIGH,60)-LLV(LOW,60))/LLV(LOW,60)*100<60;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:=EMA(RSV,3);
D11:=MA(K,3);
TYP:=(HIGH+LOW+CLOSE)/3;
C7:=45+(TYP-MA(TYP,14))/(0.09*AVEDEV(TYP,14));
AHCC1:=AMOUNT/100000000;
AHCC2:=AHCC1>2 AND REF(AHCC1,1)>2 AND REF(AHCC1,2)>2;
AHCC3:=AHCC1+REF(AHCC1,1)+REF(AHCC1,2)+REF(AHCC1,3)+REF(AHCC1,4);
AHCC4:=AHCC2 AND AHCC3>15 AND FINANCE(40)<90000000000 AND VOL/CAPITAL*100>1;
AHCC5:=REF(AHCC4,1);
XG:=P2 AND P3 AND P4 AND P5 AND P6 AND P7 AND P9 AND C7>70 AND OBV>REF(HHV(OBV,60),1) AND C>REF(HHV(C,80),1) ;
DRAWTEXT(XG=1,(L+H)/2,'↖金凤凰买'),COLORYELLOW;
A1:=(REF(H,1)-REF(C,1))/REF(C,1)*100>2.8;
A2:=(REF(H,2)-REF(C,2))/REF(C,2)*100>2.8;
A4:=A1 OR A2;
A3:=(REF(C,1)-REF(C,10))/REF(C,10)*100<10;
A6:=(REF(C,1)-REF(C,3))/REF(C,3)*100<8;
A5:=(C-REF(C,1))/REF(C,1)*100>1.5;
A7:=(REF(C,1)-REF(C,2))/REF(C,2)*100<8;
A8:=(REF(C,1)-REF(C,8))/REF(C,8)*100<28;
A9:=A8 AND REF(A8,1) AND REF(A8,2) AND REF(A8,3) AND REF(A8,4) AND REF(A8,5) AND REF(A8,6) AND REF(A8,7) AND REF(A8,8) AND REF(A8,9) AND REF(A8,10) AND REF(A8,11) AND REF(A8,12) AND REF(A8,13) AND REF(A8,14) AND REF(A8,15) AND REF(A8,16) AND REF(A8,17) AND REF(A8,18) AND REF(A8,19) AND REF(A8,20) ;
V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
V1:= COUNT(V00,3)>=1 AND LLVBARS(LOW,3) = 1 AND V03;
V2:= COUNT(V00,4)>=1 AND LLVBARS(LOW,4) = 2 AND V04;
V3:= COUNT(V00,4)>=1 AND COUNT(V01 OR V02,4)=1 AND LLVBARS(LOW,4) = 1 AND V03;
V4:= COUNT(V00,5)>=1 AND COUNT(V01 OR V02,5)=2 AND LLVBARS(LOW,5) = 2 AND V04;
V05:=REF(L,2) >REF(L,1) AND REF(LOW,1) > LOW AND REF(HIGH,2) > REF(HIGH,1) AND HIGH > REF(HIGH,1) AND REF(C,2) < C;
V06:=REF(L,2) >REF(L,1) AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,1) < LOW AND HIGH> REF(HIGH,1) AND L > REF(L,1) ;
V07:=REF(O,2) >REF(L,1) AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,1) < LOW AND HIGH> REF(HIGH,1) AND L > REF(L,1) ;
BB1:=H>REF(H,2) AND REF(H,2)<REF(H,3) AND L>REF(L,1) AND REF(L,1)<REF(L,3);
BB2:=H>REF(H,1) AND REF(H,1)<REF(H,3) AND L>REF(L,2) AND REF(L,2)<REF(L,3);
XG1:= V1 OR V2 OR V3 OR V4 OR V05 OR V06 OR BB1 OR BB2;
XG2:= C > REF(C,1);
M1:=MA(C,5);
M2:=MA(C,10);
M3:=MA(C,20);
M4:=MA(C,60);
M6:=REF(MA(C,60),1);
M8:=REF(MA(C,60),10);
M11:=(M6-M8)/M8>-0.001;
M12:=C>M4;
BBB1:=TOTALBARSCOUNT<80;
M13:=M11 OR BBB1 OR M12;
A10:=A9 OR BBB1;
B5:=XG1 AND XG2;
B6:=B5 OR REF(B5,1);
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
EE1:=REF(MACD,2)>REF(MACD,1) AND MACD>REF(MACD,1);
EE2:=REF(MACD,3)>REF(MACD,2) AND MACD>REF(MACD,2);
EE3:=EE1 OR EE2;
KK:=CROSS(K,D11);
DD:=CROSS(D11,K);
KK1:=KK OR REF(KK,1) OR REF(KK,2) OR REF(DD,3) OR REF(DD,4) OR REF(DD,5) OR REF(DD,6) OR REF(DD,7);
II1:=REF(CCI,2)>REF(CCI,1) AND CCI>REF(CCI,1);
II2:=REF(CCI,3)>REF(CCI,2) AND CCI>REF(CCI,2);
II3:=II1 OR II2;
SS:=MID+2*STD(CLOSE,20);
XX:=MID-2*STD(CLOSE,20);
SS3:=(SS-C)/C*100;
SS1:=SS-XX;
SS2:=(REF(SS1,1)-REF(SS1,2))/REF(SS,2)*100>-0.2;
SS4:=SS2 OR REF(SS3,1)>5 ;
XG11:=A4 AND A3 AND A5 AND A6 AND A7 AND A10 AND M13 AND B6 AND C>M1 AND C>M2 AND C>M3 AND REF(K,1)<56 AND SS4 AND EE3 AND II3 AND KK1 ;
XG21:=XG11=0;
XG31:=REF(XG21,1) AND REF(XG21,2) AND REF(XG21,3) ;
XG41:=XG11 AND XG31 ;
A:=CLOSE>OPEN;
B:=A&&CLOSE>MA(CLOSE,20)&&CLOSE>MA(CLOSE,40)&&CLOSE>MA(CLOSE,60);
CC:=B&&OPEN<MA(CLOSE,40)&&OPEN<MA(CLOSE,60);
CSFRO:=CC&&(CLOSE-OPEN)>0.0618*CLOSE;
MM1:=MA(C,20);
MM2:=MA(C,60);
MM3:=MA(C,120);
MM6:=REF(MA(C,60),1);
MM7:=REF(MA(C,120),1);
MM8:=REF(MA(C,60),2);
MM9:=REF(MA(C,120),2);
MM10:=(MM2-MM6)/MM6>-0.001;
MM11:=(MM6-MM8)/MM8>-0.001;
MM12:=(MM3-MM7)/MM7>-0.001;
MM13:=(MM7-MM9)/MM9>-0.001;
C11:=C>MM2 AND C>MM3 AND SS4 AND CSFRO ;
AAA:=CLOSE>OPEN;
BBB:=AAA AND CROSS(C,MA(CLOSE,5)) AND CROSS(C,MA(CLOSE,10)) AND CROSS(C,MA(CLOSE,20));
Y11:=BBB&&OPEN<MA(CLOSE,20) AND C>MM2 AND C>MM3 AND MM1>MM2 AND MM2>MM3 AND MM10 AND MM11 AND MM12 AND MM13 AND SS4 ;
DRAWTEXT(Y11=1,L,'↖穿越1'),COLORYELLOW;
DRAWTEXT(C11=1,L,'↖穿越..2'),COLORYELLOW;
DRAWTEXT(XG41=1,L,'↖穿越....3'),COLORYELLOW;

通达信金凤凰穿越主图指标公式

 

相关文章