在线检测未来函数

通达信二点短击指标公式

来源:Internet,编辑:股旁网,2018-04-04

VAR1:80,DOTLINE;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(VAR3*10,3);
VAR5:=LLV(LOW,13);
VAR6:=HHV(VAR4,13);
VAR7:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618;
VAR8:=IF(VAR7>500,500,VAR7);
RSVDS:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
AS:=SMA(RSVDS,3,1);
AC:=SMA(AS,3,1);
AF:=3*AS-2*AC;
AW:=LLV(AF,2)=LLV(AF,8);
AH:=IF(CROSS(AF,REF(AF+0.01,1)) AND AW AND AF<20,30,0);
SJ:=WMA(((2*C+H+L)/4-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
VAR3A:=3;
VAR2A:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
STICKLINE(VAR8>-120,0,VAR8,3,1),COLORGRAY;
STICKLINE(VAR8>1 AND "KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2),0,VAR8,3,0),COLORRED;
STICKLINE(VAR8>0.1 AND VAR8<1 AND "KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2),0,VAR8,3,0),COLOR00FFFF;
买点1:(CROSS(AF,REF(AF+0.01,1)) AND AW AND AF<20)*70,CIRCLEDOT,LINETHICK5;
买点2:(CROSS(SJ,ZJ) AND SJ<30)*45,CIRCLEDOT,LINETHICK5,COLORBROWN;
加仓:IF(FILTER(YXF=1,5),1,0)*38,STICK,COLORFFFFFF,LINETHICK3;
红柱:IF((VAR8>1 AND "KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2)),VAR8,DRAWNULL)>1,COLORRED;

通达信二点短击指标公式

 

相关文章