在线检测未来函数

通达信红黄二龙主图指标公式

来源:Internet,编辑:股旁网,2018-04-12

VAR1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR2:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR1>=4.945;
VAR3:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR1<=(-4.945);
涨停价:IF(VAR2,REF(CLOSE,1)*1.05,REF(CLOSE,1)*1.1),NODRAW,COLORRED;
跌停价:IF(VAR3,REF(CLOSE,1)*0.95,REF(CLOSE,1)*0.9),NODRAW,COLORGREEN;
VAR4:=REF(CLOSE,1);
VAR5:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1);
STICKLINE(VAR5,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(VAR5,OPEN,CLOSE,1,0),COLORMAGENTA;
VAR6:=CLOSE=DTPRICE(REF(CLOSE,1),0.1);
STICKLINE(VAR6,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(VAR6,HIGH,LOW,0,1),COLORGREEN;
VAR7:=AMOUNT/VOL/100;
VAR8:=CLOSE>OPEN AND REF(CLOSE,1)>VAR7 AND CLOSE>VAR7 AND CLOSE<300;
STICKLINE(VAR8,OPEN,CLOSE,1,0),COLORLICYAN;
VAR9:=OPEN>CLOSE AND CLOSE<VAR7 AND VAR7>REF(CLOSE,1);
STICKLINE(VAR9,OPEN,CLOSE,1,0),COLORRED;
VAR10:=VOL>REF(VOL,1)*0.95 AND VOL<REF(VOL,1)*1.05;
VAR11:=WINNER(CLOSE)-WINNER(OPEN)>=0.2 AND VAR10;
STICKLINE(VAR11,OPEN,CLOSE,1,0),COLORBLUE;
流通市值:FINANCE(40)/100000000,NODRAW;
MA5角度:ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.142,NODRAW,COLORRED;
循环年位置:(CLOSE-LLV(CLOSE,225))/(HHV(CLOSE,225)-LLV(CLOSE,225))*100,NODRAW,COLORGREEN;
VAR12:=HHV(VOL,10);
VAR13:=BARSLAST(VAR12=VOL);
VAR14:=CROSS(REF(MAX(CLOSE,OPEN),VAR13),CLOSE);
STICKLINE(VAR14,MAX(CLOSE,OPEN)*1.02,MIN(CLOSE,OPEN)*0.98,0,1),COLORRED;
STICKLINE(VAR14,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,10,0),COLORRED;
DRAWICON(OPEN>REF(MAX(CLOSE,OPEN),1) AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND CLOSE>MA(CLOSE,5),LOW*0.97,11);
VAR15:=CONST(HHV(REF(HIGH,1),240));
VAR16:=CONST(LLV(REF(LOW,1),240));
VAR17:=VAR15-VAR16;
VAR18:=LOW-VAR17*0.03;
VAR19:=HIGH+VAR17*0.03;
VAR20:=CLOSE>500;
VAR21:=MAX(CLOSE,OPEN);
VAR22:=MIN(CLOSE,OPEN);
VAR23:=0;
VAR24:=1;
VAR25:=IF(VAR20,HIGH,VAR21);
VAR26:=IF(VAR20,LOW,VAR22);
VAR27:=IF(CLOSE>OPEN,IF(VAR24=0,LOW,VAR26),IF(VAR24=0,HIGH,VAR25));
VAR28:=2/1000;
VAR29:=CURRBARSCOUNT;
VAR30:=120;
VAR31:=VAR29<=VAR30;
VAR32:=LOW;
VAR33:=IF(VAR23=0,VAR32,REF(VAR23,VAR23));
基准价:IF(VAR31,CONST(VAR33),DRAWNULL),DOTLINE,COLORRED;
VAR34:=基准价;
VAR35:=VAR34*VAR28;
VAR36:=ABS(LOW-VAR34)<=VAR35;
VAR37:=ABS(OPEN-VAR34)<=VAR35;
VAR38:=ABS(CLOSE-VAR34)<=VAR35;
VAR39:=ABS(HIGH-VAR34)<=VAR35;
VAR40:=VAR36 OR VAR37 OR VAR38 OR VAR39 AND VAR31 AND VAR29!=1;
VAR41:=COUNT(VAR40,VAR30);
精准点个数:IF(VAR41>0,VAR41+1,0),NODRAW,COLORMAGENTA;
STICKLINE(CLOSE<OPEN AND REF(CLOSE,1)>REF(OPEN,1),REF(CLOSE,1),REF(CLOSE,1),2,0),COLORWHITE;
VAR42:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VAR43:=SMA(VAR42,3,1);
VAR44:=SMA(VAR43,3,1);
VAR45:=3*VAR43-2*VAR44;
VAR46:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
VAR47:=SMA(VAR46,3,1);
VAR48:=SMA(VAR47,3,1);
VAR49:=3*VAR47-2*VAR48;
VAR50:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
VAR51:=SMA(VAR50,3,1);
VAR52:=SMA(VAR51,3,1);
VAR53:=3*VAR51-2*VAR52;
VAR54:=MA(CLOSE,10);
VAR55:=ATAN(VAR54-REF(VAR54,1))*180/3.1416;
STICKLINE(VAR55>1 AND VAR54>REF(VAR54,1),VAR54,REF(VAR54,1),8,0),COLORRED;
STICKLINE(VAR55<1 AND VAR54<REF(VAR54,1),VAR54,REF(VAR54,1),8,1),COLORGREEN;
VAR56:=MA(CLOSE,20);
VAR57:=ATAN(VAR56-REF(VAR56,1))*180/3.1416;
STICKLINE(VAR57>1,VAR56,REF(VAR56,1),8,0),COLORBROWN;

通达信红黄二龙主图指标公式

 

相关文章