在线检测未来函数

通达信长阴短柱主图指标公式

来源:Internet,编辑:股旁网,2018-04-12

VAR1:=CLOSE<REF(CLOSE,1) AND CLOSE<OPEN AND VOL<REF(VOL,1)*0.7;
VAR2:=BARSLAST(VAR1);
当前高量顶价:DRAWLINE(VAR2=0 AND VAR2<=10,MIN(CLOSE,OPEN),REF(VAR2=0,1),REF(MIN(CLOSE,OPEN),1),1),DOTLINE,COLORMAGENTA;
VAR3:=CONST(HHV(REF(HIGH,1),240));
VAR4:=CONST(LLV(REF(LOW,1),240));
VAR5:=VAR3-VAR4;
VAR6:=LOW-VAR5*0.03;
VAR7:=HIGH+VAR5*0.03;
VAR8:=CLOSE>500;
VAR9:=MAX(CLOSE,OPEN);
VAR10:=MIN(CLOSE,OPEN);
VAR11:=0;
VAR12:=1;
VAR13:=IF(VAR8,HIGH,VAR9);
VAR14:=IF(VAR8,LOW,VAR10);
VAR15:=IF(CLOSE>OPEN,IF(VAR12=0,LOW,VAR14),IF(VAR12=0,HIGH,VAR13));
VAR16:=2/1000;
VAR17:=CURRBARSCOUNT;
VAR18:=120;
VAR19:=VAR17<=VAR18;
VAR20:=LOW;
VAR21:=IF(VAR11=0,VAR20,REF(VAR11,VAR11));
基准价:IF(VAR19,CONST(VAR21),DRAWNULL),DOTLINE,COLORRED;
VAR22:=基准价;
VAR23:=VAR22*VAR16;
VAR24:=ABS(LOW-VAR22)<=VAR23;
VAR25:=ABS(OPEN-VAR22)<=VAR23;
VAR26:=ABS(CLOSE-VAR22)<=VAR23;
VAR27:=ABS(HIGH-VAR22)<=VAR23;
VAR28:=VAR24 OR VAR25 OR VAR26 OR VAR27 AND VAR19 AND VAR17!=1;
VAR29:=COUNT(VAR28,VAR18);
精准点个数:IF(VAR29>0,VAR29+1,0),NODRAW,COLORRED;
VAR30:=AMOUNT/VOL/100;
VAR31:=CLOSE>OPEN AND REF(CLOSE,1)>VAR30 AND CLOSE>VAR30 AND CLOSE<300;
STICKLINE(VAR31,OPEN,CLOSE,1,0),COLORLICYAN;
VAR32:=OPEN>CLOSE AND CLOSE<VAR30 AND VAR30>REF(CLOSE,1);
STICKLINE(VAR32,OPEN,CLOSE,1,0),COLORRED;
VAR33:=VOL>REF(VOL,1)*0.95 AND VOL<REF(VOL,1)*1.05;
VAR34:=WINNER(CLOSE)-WINNER(OPEN)>=0.2 AND VAR33;
STICKLINE(VAR34,OPEN,CLOSE,1,0),COLORBLUE;
VAR35:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR36:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR35>=4.945;
VAR37:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR35<=(-4.945);
涨停价:IF(VAR36,REF(CLOSE,1)*1.05,REF(CLOSE,1)*1.1),NODRAW,COLORRED;
跌停价:IF(VAR37,REF(CLOSE,1)*0.95,REF(CLOSE,1)*0.9),NODRAW,COLORGREEN;
VAR38:=REF(CLOSE,1);
VAR39:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1);
STICKLINE(VAR39,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(VAR39,OPEN,CLOSE,1,0),COLORMAGENTA;
VAR40:=CLOSE=DTPRICE(REF(CLOSE,1),0.1);
STICKLINE(VAR40,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(VAR40,HIGH,LOW,0,1),COLORGREEN;
流通市值:FINANCE(40)/100000000,NODRAW;
MA5角度:ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.142,NODRAW,COLORRED;
循环年位置:(CLOSE-LLV(CLOSE,225))/(HHV(CLOSE,225)-LLV(CLOSE,225))*100,NODRAW,COLORGREEN;
VAR41:=HHV(VOL,10);
VAR42:=BARSLAST(VAR41=VOL);
VAR43:=CROSS(REF(MAX(CLOSE,OPEN),VAR42),CLOSE);
STICKLINE(VAR43,MAX(CLOSE,OPEN)*1.02,MIN(CLOSE,OPEN)*0.98,0,1),COLORRED;
STICKLINE(VAR43,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,10,0),COLORRED;
DRAWICON(OPEN>REF(MAX(CLOSE,OPEN),1) AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND CLOSE>MA(CLOSE,5),LOW*0.97,11);
DRAWICON(OPEN>REF(MAX(CLOSE,OPEN),1) AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND CLOSE>MA(CLOSE,5),LOW*0.97,11);
VAR44:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5);
VAR45:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3) AND REFX(CLOSE,8)<REFX(CLOSE,4);
VAR46:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6);
VAR47:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3);
VAR48:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7);
VAR49:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2);
VAR50:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8);
VAR51:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1);
VAR52:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9);
VAR53:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE;
VAR54:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10);
VAR55:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1);
VAR56:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11);
VAR57:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2);
VAR58:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12);
VAR59:=REFX(CLOSE,1)<REF(CLOSE,3);
VAR60:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12) AND REF(CLOSE,9)>REF(CLOSE,13);
VAR61:=IF(PERIOD<4,LOW*(1-(PERIOD+1)/10*0.01),LOW*0.98);
VAR62:=IF(PERIOD<4,HIGH*(1+(PERIOD+1)/10*0.01),HIGH*1.05);
VAR63:=CURRBARSCOUNT-1;
DRAWNUMBER(VAR44 AND (VAR45 OR VAR63=0 OR (VAR63=1 AND VAR59) OR (VAR63=2 AND VAR57) OR (VAR63=3 AND VAR55) OR (VAR63=4 AND VAR53) OR (VAR63=5 AND VAR51) OR (VAR63=6 AND VAR49) OR (VAR63=7 AND VAR47)),VAR61,1),COLORMAGENTA;
DRAWNUMBER(VAR46 AND (VAR47 OR VAR63=0 OR (VAR63=1 AND VAR59) OR (VAR63=2 AND VAR57) OR (VAR63=3 AND VAR55) OR (VAR63=4 AND VAR53) OR (VAR63=5 AND VAR51) OR (VAR63=6 AND VAR49)),VAR61,2),COLORMAGENTA;
DRAWNUMBER(VAR48 AND (VAR49 OR VAR63=0 OR (VAR63=1 AND VAR59) OR (VAR63=2 AND VAR57) OR (VAR63=3 AND VAR55) OR (VAR63=4 AND VAR53) OR (VAR63=5 AND VAR51)),VAR61,3),COLORMAGENTA;
DRAWNUMBER(VAR50 AND (VAR51 OR VAR63=0 OR (VAR63=1 AND VAR59) OR (VAR63=2 AND VAR57) OR (VAR63=3 AND VAR55) OR (VAR63=4 AND VAR53)),VAR61,4),COLORMAGENTA;
DRAWNUMBER(VAR52 AND (VAR53 OR VAR63=0 OR (VAR63=1 AND VAR59) OR (VAR63=2 AND VAR57) OR (VAR63=3 AND VAR55)),VAR61,5),COLORMAGENTA;
DRAWNUMBER(VAR54 AND (VAR55 OR VAR63=0 OR (VAR63=1 AND VAR59) OR (VAR63=2 AND VAR57)),VAR61,6),COLORMAGENTA;
DRAWNUMBER(VAR56 AND (VAR57 OR VAR63=0 OR (VAR63=1 AND VAR59)),VAR61,7),COLORMAGENTA;
DRAWNUMBER(VAR58 AND (VAR59 OR VAR63<1),VAR61,8),COLORMAGENTA;
DRAWNUMBER(VAR60,VAR61,9),COLORGREEN;
VAR64:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5);
VAR65:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3) AND REFX(CLOSE,8)>REFX(CLOSE,4);
VAR66:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6);
VAR67:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3);
VAR68:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7);
VAR69:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2);
VAR70:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8);
VAR71:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1);
VAR72:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9);
VAR73:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE;
VAR74:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10);
VAR75:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1);
VAR76:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11);
VAR77:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2);
VAR78:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12);
VAR79:=REFX(CLOSE,1)>REF(CLOSE,3);
VAR80:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12) AND REF(CLOSE,9)<REF(CLOSE,13);
DRAWNUMBER(VAR64 AND (VAR65 OR VAR63=0 OR (VAR63=1 AND VAR79) OR (VAR63=2 AND VAR77) OR (VAR63=3 AND VAR75) OR (VAR63=4 AND VAR73) OR (VAR63=5 AND VAR71) OR (VAR63=6 AND VAR69) OR (VAR63=7 AND VAR67)),VAR62,1),COLORMAGENTA;
DRAWNUMBER(VAR66 AND (VAR67 OR VAR63=0 OR (VAR63=1 AND VAR79) OR (VAR63=2 AND VAR77) OR (VAR63=3 AND VAR75) OR (VAR63=4 AND VAR73) OR (VAR63=5 AND VAR71) OR (VAR63=6 AND VAR69)),VAR62,2),COLORMAGENTA;
DRAWNUMBER(VAR68 AND (VAR69 OR VAR63=0 OR (VAR63=1 AND VAR79) OR (VAR63=2 AND VAR77) OR (VAR63=3 AND VAR75) OR (VAR63=4 AND VAR73) OR (VAR63=5 AND VAR71)),VAR62,3),COLORMAGENTA;
DRAWNUMBER(VAR70 AND (VAR71 OR VAR63=0 OR (VAR63=1 AND VAR79) OR (VAR63=2 AND VAR77) OR (VAR63=3 AND VAR75) OR (VAR63=4 AND VAR73)),VAR62,4),COLORMAGENTA;
DRAWNUMBER(VAR72 AND (VAR73 OR VAR63=0 OR (VAR63=1 AND VAR79) OR (VAR63=2 AND VAR77) OR (VAR63=3 AND VAR75)),VAR62,5),COLORMAGENTA;
DRAWNUMBER(VAR74 AND (VAR75 OR VAR63=0 OR (VAR63=1 AND VAR79) OR (VAR63=2 AND VAR77)),VAR62,6),COLORMAGENTA;
DRAWNUMBER(VAR76 AND (VAR77 OR VAR63=0 OR (VAR63=1 AND VAR79)),VAR62,7),COLORMAGENTA;
DRAWNUMBER(VAR78 AND (VAR79 OR VAR63<1),VAR62,8),COLORMAGENTA;
DRAWNUMBER(VAR80,VAR62,9),COLORGREEN;

通达信长阴短柱主图指标公式

 

相关文章