在线检测未来函数

通达信黄金ENE轨道主图指标公式

来源:Internet,编辑:股旁网,2018-04-12

N:=11;
M1:=10;
M2:=9;
XA1:=DATE>901224 AND DATE<1260101;
¶¥:(1+M1/100)*MA(CLOSE,N);
µ×:(1-M2/100)*MA(CLOSE,N)*XA1;
ENE:(¶¥+µ×)/2;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
DRAWBMP(CROSS(LOW,µ×)*XA1,LOW*0.98,2);
XA_1:=EMA(CLOSE,13)-EMA(CLOSE,55);
XA_2:=EMA(0.618*REF(XA_1,1)+0.382*XA_1,3);
STICKLINE(XA_1>=XA_2,HIGH,LOW,0,0),COLORYELLOW;
STICKLINE(XA_1>=XA_2,OPEN,CLOSE,(-1),0),COLOR0099DD;
STICKLINE(XA_1>=XA_2,OPEN,CLOSE,2,0),COLOR00ABEE;
STICKLINE(XA_1>=XA_2,OPEN,CLOSE,1,0),COLOR00DDFF;
STICKLINE(XA_1>=XA_2,OPEN,CLOSE,0.1,0),COLORYELLOW;
STICKLINE(XA_1<XA_2,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(XA_1<XA_2,OPEN,CLOSE,(-1),0),COLOR009900;
STICKLINE(XA_1<XA_2,OPEN,CLOSE,2,0),COLOR00AB00;
STICKLINE(XA_1<XA_2,OPEN,CLOSE,1,0),COLOR00DD00;
STICKLINE(XA_1<XA_2,OPEN,CLOSE,0.1,0),COLORGREEN;
A_1:=REF(CLOSE,1);
A_2:=EMA(HHV(HIGH,1),8);
A_3:=EMA(CLOSE,8);
A_4:=A_3<REF(A_3,1) AND CLOSE<A_3;
A_5:=IF(A_2<REF(A_2,1) OR A_4,1,0);
A_6:=SMA(MAX(CLOSE-A_1,0),2,1)/SMA(ABS(CLOSE-A_1),2,1)*100;
A_7:=45;
A_8:=20;
A_9:=A_6<A_7 AND REF(A_6,1)>A_7;
A_10:=A_6<A_8 AND REF(A_6,1)>A_8;
XG:=(COUNT(A_5=1,4)=3 AND A_5=0 AND OPEN<CLOSE AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.065)*10>=10 OR ((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.065 AND (REF(A_10,1) OR REF(A_9,1))),COLORYELLOW;
DRAWICON(XG,L,29);
STICKLINE(XG,L,L+(H-L)/2,2.7,0),COLORLIRED;
STICKLINE(XG,L+(H-L)/2,H,2.7,0),COLORMAGENTA;

通达信黄金ENE轨道主图指标公式

 

相关文章