在线检测未来函数

通达信神龙精准KDJ指标公式

来源:Internet,编辑:股旁网,2018-04-19

DRAWGBK(CLOSE>0,RGB(0,0,0),RGB(20,58,120),0,61,0);
X_1:=MA(CLOSE,13);
X_2:=100-ABS((CLOSE-X_1)/X_1*100);
X_3:=LLV(LOW,75);
X_4:=HHV(HIGH,75);
X_5:=(X_4-X_3)/100;
X_6:=SMA((CLOSE-X_3)/X_5,20,1);
X_7:=SMA((OPEN-X_3)/X_5,20,1);
X_8:=3*X_6-2*SMA(X_6,15,1);
X_9:=3*X_7-2*SMA(X_7,15,1);
X_10:=100-X_9;
X_11:=100-X_8;
X_12:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
X_13:=EMA(X_12,5);
DRAWBAND(IF(X_13-X_11>=0,X_13-X_11,0),RGB(150,90,50),0,RGB(50,50,50));
X_14:=(2*CLOSE+HIGH+LOW)/4;
X_15:=LLV(LOW,34);
X_16:=HHV(HIGH,34);
X_17:=MAX((X_14-X_15)/(X_16-X_15)*100,8);
X_18:=SMA(X_17,8,1);
X_19:=SMA(X_18,5,1);
DRAWBAND(X_18,RGB(250,248,0),X_19,RGB(0,118,0));
J:3*X_18-2*X_19,COLORMAGENTA;
IF(EMA(((2*CLOSE+HIGH+LOW+OPEN)/5-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,60))/(HHV((2*CLOSE+HIGH+LOW+OPEN)/5,60)-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,60)),2)*100>90 OR EMA(((2*CLOSE+HIGH+LOW+OPEN)/5-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,15))/(HHV((2*CLOSE+HIGH+LOW+OPEN)/5,15)-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,15)),2)*100>95 AND J>80,J,DRAWNULL),COLORGREEN,LINETHICK2;
IF(EMA(((2*CLOSE+HIGH+LOW+OPEN)/5-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,60))/(HHV((2*CLOSE+HIGH+LOW+OPEN)/5,60)-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,60)),2)*100<10 OR EMA(((2*CLOSE+HIGH+LOW+OPEN)/5-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,15))/(HHV((2*CLOSE+HIGH+LOW+OPEN)/5,15)-LLV((2*CLOSE+HIGH+LOW+OPEN)/5,15)),2)*100<5 AND J<5,J,DRAWNULL),COLORYELLOW,LINETHICK2;
X_20:=SMA(CLOSE,2,1);
X_21:=SMA(MAX(CLOSE-X_20,0),6,1)/SMA(ABS(CLOSE-X_20),6,1)*100;
X_22:=SMA(HIGH,2,1);
X_23:=SMA(MAX(HIGH-X_22,0),6,1)/SMA(ABS(HIGH-X_22),6,1)*100;
X_24:=SMA(OPEN,2,1);
X_25:=SMA(MAX(OPEN-X_24,0),6,1)/SMA(ABS(OPEN-X_24),6,1)*100;
X_26:=SMA(LOW,2,1);
X_27:=SMA(MAX(LOW-X_26,0),6,1)/SMA(ABS(LOW-X_26),6,1)*100;
X_28:=SMA(10000*CLOSE/INDEXC,2,1);
X_29:=SMA(MAX(10000*CLOSE/INDEXC-X_28,0),6,1)/SMA(ABS(10000*CLOSE/INDEXC-X_28),6,1)*100;
X_30:=(X_21+X_25+X_23+X_27+X_29)/5;
X_31:=EMA(EMA(X_30,6),5);
底部【机会区】:IF(X_30<=15 AND X_31<=15,J,DRAWNULL),COLORRED,LINETHICK3;
顶部【风险区】:IF(X_30>=85 AND X_31>=80,J,DRAWNULL),COLORWHITE,LINETHICK3;
控仓(险):EMA(WINNER(CLOSE)*100,5)>85 AND X_18>85 OR (EMA(WINNER(CLOSE)*100,5)>90 OR X_18>90),NODRAW,COLORCYAN;
STICKLINE(控仓(险),J,85,0,1),COLORCYAN,LINETHICK3;
X_32:=REF(LOW,1)*0.9;
X_33:=EMA(X_32,30);
X_34:=CLOSE-REF(CLOSE,1);
X_35:=MAX(X_34,0);
X_36:=ABS(X_34);
X_37:=SMA(X_35,7,1)/SMA(X_36,7,1)*100;
X_38:=SMA(X_35,13,1)/SMA(X_36,13,1)*100;
X_39:=BARSCOUNT(CLOSE);
X_40:=SMA(MAX(X_34,0),6,1)/SMA(ABS(X_34),6,1)*100;
X_41:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
X_42:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
X_43:=SMA((SMA(X_42,4,1)-50)*2,3,1);
X_44:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
X_45:=SMA(X_44,4,1);
X_46:=SMA(X_45,3,1);
X_47:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
神龙大底:(X_40<=25 AND X_41<(-95) AND X_47>20 AND X_43<(-30) AND X_46<30 AND X_33-CLOSE>=(-0.25) AND X_37<22 AND X_38<28 AND X_39>50)*50,COLORYELLOW;
X_48:=VOL/REF(VOL,1)>=1.91 AND CLOSE>REF(CLOSE,1) AND CLOSE>OPEN;
X_49:=VOL>=HHV(VOL,21);
X_50:=X_48 AND X_49;
倍量反弹:(X_30<=15 AND X_31<=15 AND X_50)*70,COLORGREEN;
X_51:=BARSLAST(MONTH!=REF(MONTH,1))+1;
月±%:(CLOSE/REF(CLOSE,X_51)-1)*100,NODRAW,COLORRED;

通达信神龙精准KDJ指标公式

 

相关文章