在线检测未来函数

通达信飞天小妖主图及选股指标公式

来源:Internet,编辑:股旁网,2018-04-17

V5:=EMA(CLOSE,1);主线:=EMA(V5,5) ;
本:=EMA(HHV(主线,5),1);
急进:=EMA(HHV(本,17),1);
稳健:=EMA(HHV(急进,17),2);
飞天:EMA(HHV(稳健,17),3),LINETHICK2, COLORRED;
BF:=L<MA(C,15) AND L<REF(HHV(C,20),1)*0.9 AND MA(C,15)<REF(HHV(C,20),1)*0.9;
小妖线:EMA(CLOSE,20),COLORCYAN,DOTLINE;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
起步线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
小妖:=CROSS(C,小妖线) AND CROSS(C,起步线) AND 起步线<小妖线 AND BF;
STICKLINE(小妖,C,O,2.1,0)COLORYELLOW;
STICKLINE(小妖,C,O,2.8,0)COLORYELLOW;
STICKLINE(小妖,C,O,1.5,0)COLORFF00FF;
DRAWTEXT(小妖,L*0.98,'★小妖'),COLOR00FF00;

{
选股公式:

BF:=L<MA(C,15) AND L<REF(HHV(C,20),1)*0.9 AND MA(C,15)<REF(HHV(C,20),1)*0.9;
小妖线:=EMA(CLOSE,20);
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
起步线:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
小妖:=CROSS(C,小妖线) AND CROSS(C,起步线) AND 起步线<小妖线 AND BF;
AHC1:=CLOSE*VOL;
AHC11:=EMA((EXPMA(AHC1,1)/EXPMA(VOL,1)+EXPMA(AHC1,2)/EXPMA(VOL,2)+EXPMA(AHC1,4)/EXPMA(VOL,4)+EXPMA(AHC1,6)/EXPMA(VOL,6))/4,7);
AHC2:=EMA((EXPMA(AHC1,3)/EXPMA(VOL,3)+EXPMA(AHC1,6)/EXPMA(VOL,6)+EXPMA(AHC1,12)/EXPMA(VOL,12)+EXPMA(AHC1,24)/EXPMA(VOL,24))/4,13);
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,13);
内上:=1.06*AHC2;
内下:=AHC2*0.94;
ZT:=REF(C,1)*1.1-C<0.02 AND H=C;
启爆1:=CROSS(C,内上) OR CROSS(C,内下) AND ZT;
小妖 AND 启爆1;
}

通达信飞天小妖主图及选股指标公式

 

相关文章