在线检测未来函数

通达信天涯爱胜主图指标公式

来源:Internet,编辑:股旁网,2018-05-03

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
NOTEXT1:=HHV(EMA(C,17),2);
NOTEXT2:EMA(C,17),COLORRED,LINETHICK2;
NOTEXT3:IF(NOTEXT1=NOTEXT2 AND UPNDAY(NOTEXT1,3),NOTEXT1,DRAWNULL),COLORRED,LINETHICK2;
NOTEXT4:IF(REF(NOTEXT1,2)>NOTEXT2,NOTEXT2,DRAWNULL),COLORGREEN,LINETHICK2;
趋势线:EMA(SLOPE(CLOSE,21)*20+CLOSE,55)*1,LINETHICK;
股价线:EMA(CLOSE,0),POINTDOT,LINETHICK;
STICKLINE(股价线>趋势线 AND C<O,H,L,0,0),COLORRED;
STICKLINE(股价线>趋势线 AND C<O,O,C,3,1),COLORRED;
STICKLINE(股价线>趋势线 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(股价线>趋势线 AND C>=O ,O,C,3,0),COLORRED;
STICKLINE(股价线<=趋势线 AND C>O,H,L,0,0),COLORGREEN;
STICKLINE(股价线<=趋势线 AND C>O,O,C,3,1),COLORGREEN;
STICKLINE(股价线<=趋势线 AND C<=O ,H,L,0,0),COLORGREEN;
STICKLINE(股价线<=趋势线 AND C<=O,O,C,3,0),COLORGREEN;
X_2:=BACKSET(REF(HIGH,1)=HHV(HIGH,3),2);
X_3:=CROSS(X_2,0.9);
X_4:=BACKSET(REF(LOW,1)=LLV(LOW,3),2);
X_5:=CROSS(X_4,0.9);
STICKLINE(CLOSE,REF(HIGH,BARSLAST(X_3)),REF(HIGH,BARSLAST(X_3)),2,0),COLORRED;
STICKLINE(CLOSE,REF(LOW,BARSLAST(X_5)),REF(LOW,BARSLAST(X_5)),2,0),COLORGREEN;

通达信天涯爱胜主图指标公式

 

相关文章