在线检测未来函数

通达信线上主升选股指标公式

来源:Internet,编辑:股旁网,2018-05-14

VAR0 := MA(REF(HHV(C,26),1),2);
VAR1 := MA(C,26);
VAR2 := POW(C - VAR1,2);
VAR3 := MA(VAR2,13);
VAR4 := SQRT(VAR3);
VAR5 := VAR1 + (2 * VAR4);
VAR6 := REF(VAR5,1);
VAR7 := ((CROSS(C,VAR0) AND (HIGH > REF(VAR5,1))) OR ((C > VAR0) AND CROSS(C,REF(VAR5,1)))) AND ((C / OPEN) > 0.998);
VAR8 := MACD.MACD;
VAR9 := KD.K;
VAR10 := KD.D;
VAR11 := RSI.RSI1;
VAR12 := RSI.RSI3;
VAR13 := C - REF(C,1);
VAR14 := IF(VAR13 >= 0,VAR13,0);
VAR15 := IF(VAR13 < 0,-1 * VAR13,0);
VAR16 := MEMA(VAR14,10);
VAR17 := MEMA(VAR15,10);
VAR18 := MEMA(VAR14,6);
VAR19 := MEMA(VAR15,6);
VAR20 := MA((100 * VAR16) / (VAR16 + VAR17),10);
VAR21 := MA((100 * VAR18) / (VAR18 + VAR19),6);
VAR22 := (((((MA(C,5) / MA(C,10)) > 0.999) AND ((MA(C,10) / MA(C,20)) > 0.9847)) AND (MA(C,20) > MA(C,60))) AND (REF((COUNT(((MA(C,10) / MA(C,20)) < 1.017) OR ((MA(C,5) / MA(C,10)) < 1.017),8)) >= 1,1))) AND ((MA(C,20) / MA(C,60)) < 1.121);
VAR23 := ((C - MA(C,60)) / MA(C,60)) * 100;
VAR24 := (COUNT(VAR23 < 35,100)) >= 95;
T1:=VAR7 AND VAR22>0 AND VAR24 AND REF(COUNT(MA(C,20)>MA(C,30),4)=4 AND COUNT(C>MA(C,5),3)>=2,1) AND V>REF(V,1) AND (REF(COUNT(C>O,10)>=6 OR COUNT(C>O,5)>=4,1) OR C=H);
T2:=CROSS(VAR21,VAR20) OR CROSS(VAR8,0) OR REF(COUNT(CROSS(VAR8,0),3)=1 AND VAR8<0.15 AND C/O>0.989 AND C/REF(C,1)<1.03,1) OR CROSS(VAR9,VAR10) OR CROSS(VAR11,VAR12);
T3:=REF(C/O>0.988 AND (C>O OR (C<=O AND H/L<1.049)),1) AND H/C<1.013 AND C/O>1.05;
线上主升:T1 AND T2 AND T3;

通达信线上主升选股指标公式

 

相关文章