在线检测未来函数

通达信多空通道主图指标公式

来源:Internet,编辑:股旁网,2018-09-24

短上轨:EMA(H,26),COLORRED;
短下轨:EMA(L,26),COLORGREEN;
NOTEXT短下轨0:IF(C>短下轨,短下轨,DRAWNULL),COLORRED;
NOTEXT短下轨1:IF(C<短下轨,短下轨,DRAWNULL),COLORGREEN;
NOTEXT短上轨0:IF(C>短上轨,短上轨,DRAWNULL),COLORRED;
NOTEXT短上轨1:IF(C<短上轨,短上轨,DRAWNULL),COLORGREEN;
STICKLINE(C>短上轨,短上轨,短下轨,0,0),COLORRED;
STICKLINE(C<短下轨,短上轨,短下轨,0,0),COLORGREEN;
长上轨:EMA(H,89),COLORMAGENTA;
长下轨:EMA(L,89),COLORBLUE;
NOTEXT长下轨0:IF(C>长下轨,长下轨,DRAWNULL),COLORMAGENTA;
NOTEXT长下轨1:IF(C<长下轨,长下轨,DRAWNULL),COLORBLUE;
NOTEXT长上轨0:IF(C>长上轨,长上轨,DRAWNULL),COLORMAGENTA;
NOTEXT长上轨1:IF(C<长上轨,长上轨,DRAWNULL),COLORBLUE;
STICKLINE(C>长上轨,长上轨,长下轨,0,0),COLORMAGENTA;
STICKLINE(C<长下轨,长上轨,长下轨,0,0),COLORBLUE;
DRAWTEXT((REF(C,3)<REF(短下轨,3) OR REF(C,3)<REF(短上轨,3)) AND (REF(C,2)<REF(短下轨,2) OR REF(C,2)<REF(短上轨,2)) AND (REF(C,1)<REF(短下轨,1) OR REF(C,1)<REF(短上轨,1)) AND C>短上轨 AND 短上轨<长下轨 AND COUNT(C<短下轨,6)>0,L*0.96,'4'),COLORMAGENTA;
DRAWTEXT((REF(C,3)<REF(短下轨,3) OR REF(C,3)<REF(短上轨,3)) AND (REF(C,2)<REF(短下轨,2) OR REF(C,2)<REF(短上轨,2)) AND (REF(C,1)<REF(短下轨,1) OR REF(C,1)<REF(短上轨,1)) AND C>短上轨 AND C>长上轨 AND COUNT(C<短下轨,6)>0,L*0.98,'10'),COLORMAGENTA;
DRAWTEXT((REF(C,3)<REF(长下轨,3) OR REF(C,3)<REF(长上轨,3)) AND (REF(C,2)<REF(长下轨,2) OR REF(C,2)<REF(长上轨,2)) AND (REF(C,1)<REF(长下轨,1) OR REF(C,1)<REF(长上轨,1)) AND C>长上轨 AND C>短上轨 AND COUNT(C<长下轨,6)>0,L*0.98,'10'),COLORMAGENTA;
DRAWTEXT((REF(C,3)>REF(短上轨,3) OR REF(C,3)>REF(短下轨,3)) AND (REF(C,2)>REF(短上轨,2) OR REF(C,2)>REF(短下轨,2)) AND (REF(C,1)>REF(短上轨,1) OR REF(C,1)>REF(短下轨,1)) AND C<短下轨 AND 短上轨>长上轨 AND C>长下轨 AND COUNT(C>短上轨,6)>0,H*1.04,'6'),COLORMAGENTA;
DRAWTEXT((REF(C,3)>REF(短上轨,3) OR REF(C,3)>REF(短下轨,3)) AND (REF(C,2)>REF(短上轨,2) OR REF(C,2)>REF(短下轨,2)) AND (REF(C,1)>REF(短上轨,1) OR REF(C,1)>REF(短下轨,1)) AND C<短下轨 AND 短下轨<长下轨 AND COUNT(C>短上轨,6)>0,H*1.04,'0'),COLORMAGENTA;
DRAWTEXT((REF(C,3)>REF(长上轨,3) OR REF(C,3)>REF(长下轨,3)) AND (REF(C,2)>REF(长上轨,2) OR REF(C,2)>REF(长下轨,2)) AND (REF(C,1)>REF(长上轨,1) OR REF(C,1)>REF(长下轨,1)) AND C<长下轨 AND C<短下轨 AND COUNT(C>长上轨,6)>0,H*1.04,'0'),COLORMAGENTA;

通达信多空通道主图指标公式

 

相关文章