在线检测未来函数

通达信OBV和ASI叠加指标公式

来源:Internet,编辑:股旁网,2018-12-13

M:=30 ;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100000;
OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:MA(OBV,M);
LC:=REF(CLOSE,1);
AA:=ABS(HIGH-LC);
BB:=ABS(LOW-LC);
CC:=ABS(HIGH-REF(LOW,1));
DD:=ABS(LC-REF(OPEN,1));
R:=IF(AA>BB AND AA>CC,AA+BB/2+DD/4,IF(BB>CC AND BB>AA,BB+AA/2+DD/4,CC+DD/4));
X:=(CLOSE-LC+(CLOSE-OPEN)/2+LC-REF(OPEN,1));
SI:=8*X/R*MAX(AA,BB);
ASI:SUM(SI,0);
MASI:MA(ASI,6);

通达信OBV和ASI叠加指标公式

 

相关文章