在线检测未来函数

通达信好牛指标公式

来源:Internet,编辑:股旁网,2019-01-28

VURH9:=WINNER(C)>0.95 AND HHV(C,13)=C AND 100*(C-MA(C,12))/MA(C,12)>10 ;
STICKLINE(VURH9>0,5,9.2,1,0),COLORFF00FF;
DRAWTEXT(VURH9,9.18,'追'),COLORYELLOW;
日K:="KDJ.K#DAY"(9,3,3);
日D:="KDJ.D#DAY"(9,3,3);
日YDIF:="MACD.DIF#DAY"(12,26,9);
日YDEA:="MACD.DEA#DAY"(12,26,9);
RSI:="RSI.RSI1#DAY"(9);
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
周YDIF:="MACD.DIF#WEEK"(12,26,9);
周YDEA:="MACD.DEA#WEEK"(12,26,9);
周RSI:="RSI.RSI1#WEEK"(9);
月K:="KDJ.K#MONTH"(9,3,3);
月D:="KDJ.D#MONTH"(9,3,3);
月YDIF:="MACD.DIF#MONTH"(12,26,9);
月YDEA:="MACD.DEA#MONTH"(12,26,9);
月RSI:="RSI.RSI1#MONTH"(9);
XY1:=日K>日D;
XY2:=日YDIF>日YDEA;
XY3:=日RSI>5;
XY4:=周K>周D;
XY5:=周YDIF>周YDEA;
XY6:=周RSI>5;
XY7:=月K>月D;
XY8:=月YDIF>月YDEA;
XY9:=月RSI>5;
黑码初显:=XY1 AND XY2 AND XY3 AND XY4 AND XY5 AND XY6 AND XY7 AND XY8 AND XY9;
STICKLINE(黑码初显,0.05,5,1,0),COLORBLUE;
STICKLINE(黑码初显 AND C/REF(C,1)>1.05,0.05,5,2,0)COLORYELLOW;
STICKLINE(黑码初显 AND C/REF(C,1)>1.05,0.05,5,1,0),COLORRED;
DRAWTEXT(黑码初显,5,'黑'),COLORWHITE;
DIFX:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEAX:=EMA(DIFX,9);
AAAT:=(DIFX-DEAX)*2*60;
启动:=CROSS(AAAT-REF(AAAT,1),15),COLORRED,LINETHICK2;
DRAWTEXT(启动,2,'↖金牛启动'),COLORYELLOW,LINETHICK2;
DIFK:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEAK:=EMA(DIFK,9);
STICKLINE(DIFK>=DEAK,-10,-13,5,0),COLOR0000BB;
STICKLINE(DIFK<DEAK,-10,-13,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,-12,'★MACD日线★'),COLOR00FFFF;
周MD:=MACD.DIF#WEEK;
周MA:=MACD.DEA#WEEK;
STICKLINE(周MD>=周MA,-13.5,-16.5,5,0),COLOR0000BB;
STICKLINE(周MD<周MA,-13.5,-16.5,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,-15,'★MACD周线★'),COLOR00FFFF;
月MD:=MACD.DIF#MONTH;
月MA:=MACD.DEA#MONTH;
STICKLINE(月MD>=月MA,-16.5,-19.5,5,0),COLOR0000BB;
STICKLINE(月MD<月MA,-16.5,-19.5,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,-18,'★MACD月线★'),COLOR00FFFF;
RSVX:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
KX:=SMA(RSVX,3,1);
DHX:=SMA(KX,3,1);
JX:=3*KX-2*DHX;
STICKLINE(KX>=DHX,-20.5,-23.5,5,0),COLOR0000FF;
STICKLINE(KX<DHX,-20.5,-23.5,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,-22,'★KDJ日线★'),COLORFFFFFF;
周XK:="KDJ.K#WEEK" ;
周XD:="KDJ.D#WEEK" ;
STICKLINE(周XK>=周XD,-24.5,-27.5,5,0),COLOR0000FF;
STICKLINE(周XK<周XD,-24.5,-27.5,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,-26,'★KDJ周线★'),COLORWHITE;
月XK:="KDJ.K#MONTH" ;
月XD:="KDJ.D#MONTH" ;
STICKLINE(月XK>=月XD,-28.5,-31.5,5,0),COLOR0000FF;
STICKLINE(月XK<月XD,-28.5,-31.5,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,-30,'★KDJ月线★'),COLORWHITE;
VUR1:=VOL/CAPITAL;
VUR2:=1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1);
VUR3:=2.5*MAX(VUR1,VUR2);
VUR4:=DMA(CLOSE,VUR3);
VUR5:=20*(VUR4/REF(VUR4,1)-1)*38;
VUR6:=EMA(VUR5,2);
VUR7:=EMA(VUR5,2);
VUR8:=EMA(VUR7,3);
VURS:=EMA(VUR7,8);
VUR9:=1.1*(MAX(INDEXH,REF(INDEXC,1))/MIN(INDEXL,REF(INDEXC,1))-1);
VURA:=2.5*MAX(VUR1,VUR9);
VURB:=DMA(INDEXC,VURA);
VURC:=EMA(20*(VURB/REF(VURB,1)-1),1)*38;
VURD:=EMA(VURC,2);
VURE:=EMA(VURC,2);
D强:STICKLINE(VURD>0,0,VURD,3.3,1),COLORMAGENTA;
D弱:STICKLINE(VURD<0,0,VURD,3.3,1),COLORCYAN;
极强:STICKLINE(VUR5>0,0,VUR5,3.3,0),COLORYELLOW;
STICKLINE(VUR5>0,0,VUR5,2.5,0),COLOR00BBBB;
STICKLINE(VUR5>0,0,VUR5,1.5,0),COLOR00FFFF;
强势:STICKLINE(VUR6>0,0,VUR6,3.3,0),COLOR0000AA;
STICKLINE(VUR6>0,0,VUR6,2.5,0),COLOR0000BB;
STICKLINE(VUR6>0,0,VUR6,1.5,0),COLOR0000FF;
极弱:STICKLINE(VUR5<0,0,VUR5,3.3,0),COLOR00AA00;
STICKLINE(VUR5<0,0,VUR5,2.5,0),COLOR00BB00;
STICKLINE(VUR5<0,0,VUR5,1.5,0),COLOR00FF00;
弱势:STICKLINE(VUR6<0,0,VUR6,3.3,0),COLOR005AAA;
STICKLINE(VUR6<0,0,VUR6,2.5,0),COLOR007BBB;
STICKLINE(VUR6<0,0,VUR6,1.5,0),COLOR009FFF;
DX:=VURE,LINETHICK2,COLOR1088FF;
界:=VURS,LINETHICK2,COLOR6CBC10;
控:=VUR8,LINETHICK2,COLORFF10FF;
零:0,COLORCCCCCC;
额:AMOUNT/100000000,NODRAW;
VAR1:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
流入亿:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/100000000,COLORRED,NODRAW;
流出亿:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN- LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-AMOUNT/2))/100000000,COLOR00FF00,NODRAW;
差:(流入亿+流出亿),NODRAW;
强:=EMA((CLOSE-REF(CLOSE,1))/CLOSE*10,2);
主力:=EMA(差,1),COLORFF00FF,LINETHICK5;
差A:3*EMA(EMA(EMA(EMA(强,2),2),2),2),NODRAW;
净流:3*EMA(EMA(EMA(EMA(差A,1),2),2),2), COLORRED,NODRAW;
MID:= MA(CLOSE,26);
AB:= EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA(CLOSE,8)+EMA(CLOSE,13))/4,2)LINETHICK2;
UPPER:= IF(DATE<1090501,MID+2*STD(CLOSE,26),0);
AUPPER:= IF(DATE<1090501,MID+1.7*2*STD(CLOSE,26),0);
LOWER:= IF(DATE<1090501,MID-2*STD(CLOSE,26),0);
ALOWER:= IF(DATE<1090501,MID-1.7*2*STD(CLOSE,26),0);
DRAWTEXT(CROSS(AB,MID),0,'追击');
K30:=SMA(((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100),3,1);
MD1:=K30-REF(K30,1)>9 ;
MD2:=V/REF(V,1)>2.4 OR REF(COUNT(ABS((C-REF(C,1))/REF(C,1))*100<2,6)=6,1) OR REF(V/REF(V,1)>2.4,1) ;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
暴张:IF(MD1 AND MD2 AND DIFF>DEA,6,0),COLORYELLOW;
DRAWTEXT(暴张,5,暴张),COLORYELLOW;
STICKLINE(MD1 AND MD2,0,5,2.5,0),COLORFF00FF,LINETHICK2;
DRAWTEXT(MD1 AND MD2 ,暴张,'暴张'),COLORWHITE;

通达信好牛指标公式

 

相关文章