在线检测未来函数

通达信分钟MACD分时指标公式

来源:Internet,编辑:股旁网,2019-02-26

SHORT:=12;
LONG:=26;
MID:=9;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,60);
MA30:=EMA(CLOSE,30);
强弱:=EMA(CLOSE,900);
{STICKLINE((MA30>强弱),MA30,强弱,0,-1),COLORLIGRAY;
STICKLINE((MA30<强弱),MA30,强弱,0,-1),COLORLICYAN;}
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
DIF1:=EMA(CLOSE,8)-EMA(CLOSE,18),COLORYELLOW;
DEA1:=EMA(DIF1,8),COLORWHITE;
五大:=IF (MA(C,5)>MA(C,10) AND MA(C,5)>REF(MA(C,5),1) AND C>MA(C,5),MA(C,5),DRAWNULL),COLORWHITE,LINETHICK2;
十大:=IF (EVERY(MA(C,10)>MA(C,20),2),MA(C,10),DRAWNULL),COLORYELLOW,LINETHICK2;
二十大:=IF (EVERY(MA(C,20)>MA(C,60),2),MA(C,20),DRAWNULL),COLORRED,LINETHICK2;
六十大:=IF (EVERY(MA(C,60)>REF(MA(C,60),1),6),MA(C,60),DRAWNULL),COLORGREEN,LINETHICK2;
分钟板底:IF(EVERY(DEA>0 AND DEA>REF(DEA,1) AND DIF>DEA,5),DEA,DRAWNULL),COLORRED,LINETHICK2;
中期行情:DRAWTEXT(COUNT(CROSS(DIF,0),3) AND CROSS(DEA,0) AND MACD>REF(MACD,1),-0.01,'中期'),COLOR888888;
稳板:DRAWTEXT((({COUNT(中期行情,10) AND }REF(MACD<0,1) AND MACD>0) OR (REF(EVERY(DEA<REF(DEA,1) AND DEA>DIF AND MACD<0,10),1))
AND CROSS(DIF,DEA)) AND MACD>REF(MACD,1) AND 五大,-0.01,'WB'),COLORWHITE;
{第一涨停}
ZT:=C/REF(C,1)>1.096;
前次涨停:=BARSLAST(REF(ZT,1));
DRAWTEXT(REF(COUNT(ZT,20)=0,1) AND C/REF(C,1)>1.076{ AND V=HHV(V,250) AND C<=HHV(C,50)} AND HSL>3
AND C>=MA(O,前次涨停) AND DEA<0 AND C/O>1.056,DEA,'↖NO1'), COLORLIRED;
均线启动:=DRAWTEXT((REF((COUNT(CROSS(MA(C,60),MA(C,5)),15)) OR (EVERY(MA(C,60)<REF(MA(C,60),1),20)
AND MA(C,5)<MA(C,60)),1) AND CROSS(MA(C,5),MA(C,60)) AND C>REF(HHV(H,10),1))
OR BARSLASTCOUNT(((EVERY(C,20)),MA(C>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60),20)
AND C>REF(HHV(H,20),1)) AND COUNT((C>O OR C>REF(C,1)),10)>7{ AND EVERY(V>REF(V,1),3)})=1,MA(C,20),'均启'),COLORLIBLUE;
{金叉启动:DRAWTEXT(CROSS(DIF,DEA),DEA,'金叉'),COLORLIRED;}
{123 金叉数字}
DONCROSS:=IF(CROSS(DIF,DEA) AND DEA>0,1,0); {0上金叉}
DUNDERCROSS:=IF(CROSS(DIF,DEA) AND DIF<0,1,0); {0下金叉}
KONCROSS:=IF(CROSS(DEA,DIF) AND DIF>0,1,0); {0上死叉}
KUNDERCROSS:=IF(CROSS(DEA,DIF) AND DEA<0,1,0); {0下死叉}
A7X:=VAR2STR(COUNT(DUNDERCROSS,BARSLAST(DIF>0)+1),0),NODRAW;
DRAWTEXT(DONCROSS,DEA,VAR2STR(COUNT(DONCROSS,BARSLAST(DIF<0)+1),0)),COLORRED;
DRAWTEXT(DUNDERCROSS,DEA,A7X),COLORYELLOW;
DRAWTEXT(KONCROSS,DIF,VAR2STR(COUNT(KONCROSS,BARSLAST(DIF<0)+1),0)),COLORCYAN;
DRAWTEXT(KUNDERCROSS,DIF,VAR2STR(COUNT(KUNDERCROSS,BARSLAST(DIF>0)+1),0)),COLORGREEN;
分时板底:IF(EVERY(DEA>0 AND DIF>0,8) AND EVERY(NOT(KONCROSS),10),0,DRAWNULL),COLORRED,LINETHICK3;
分时启动:DRAWTEXT(((EVERY(DIF>DEA AND DEA>REF(DEA,1),10))
OR (REF(EVERY(DIF>DEA AND DEA>REF(DEA,1),10),5) AND (CROSS(DIF,DEA)
OR (REF(MACD<REF(MACD,1),1) AND MACD>REF(MACD,1)))))
AND ((REF(DIF<=REF(DIF,1),1)
AND DIF>REF(DIF,1)) OR (REF(MACD<REF(MACD,1),1) AND MACD>REF(MACD,1)))
AND DIF>REF(HHV(DIF,6),1),DEA,'启动'), COLORLIRED;

通达信分钟MACD分时指标公式

 

相关文章