载入中...
在线检测未来函数
载入中...

通达信潜伏黄金坑指标公式

来源:Internet,编辑:股旁网,2019-09-24

N:=14;
M:=6;
NC:=14;
MTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=SUM(IF(HD>0&&HD>LD,HD,0),N);
DMM:=SUM(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/MTR;
MDI: DMM*100/MTR;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:(ADX+REF(ADX,M))/2;
看多线:20,DOTLINE,COLORRED;
MA5:=MA(C,5);MA10:=MA(C,10);MA20:=MA(C,20);MA30:=MA(C,30);MA60:=MA(C,60);
MAX1:=MAX(MA5,MA10);
MAX2:=MAX(MAX1,MA20);
MAX3:=MAX(MAX2,MA30);
MAXH:=MAX(MAX3,MA60);
MIN1B:=MIN(MA5,MA10);
MIN2:=MIN(MIN1B,MA20);
MIN3:=MIN(MIN2,MA30);
MINL:=MIN(MIN3,MA60);
粘合度:=(MAXH-MINL)/MINL*100;
多头发散:=MA5>REF(MA5,1) AND MA5>MA10 AND MA10>=REF(MA10,1) AND MA10>MA20 AND MA20>=REF(MA20,1) AND MA20>MA30 AND MA30>=REF(MA30,1) AND MA30>MA60 AND MA60>=REF(MA60,1);
选股:BARSLASTCOUNT(粘合度<=5)=2 AND 多头发散;
DRAWTEXT(CROSS(PDI,MDI) AND EXIST(粘合度<=8,5) AND MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2)
AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1),38,'多'),COLORRED;
DRAWTEXT(CROSS(PDI,MDI) AND EXIST(粘合度<=8,5) AND MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2)
AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1),48,'看'),COLORRED;
DRAWTEXT(CROSS(MDI,PDI),38,'看'),COLORGREEN;
DRAWTEXT(CROSS(MDI,PDI),26,'空'),COLORGREEN;
DRAWTEXT(CROSS(PDI,MDI) AND ADX>20 AND ADXR>20 AND MA(C,10)>REF(MA(C,10),1)
,28,'主'),COLORRED;
DRAWTEXT(CROSS(PDI,MDI) AND ADX>20 AND ADXR>20 AND MA(C,10)>REF(MA(C,10),1)
,18,'升'),COLORRED;
DRAWTEXT(CROSS(PDI,ADX) AND CROSS(PDI,ADXR) AND MDI<REF(MDI,1) AND ADX>REF(ADX,1) AND ADXR>REF(ADXR,1)
AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND
ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45,58,'走'),COLORRED;
DRAWTEXT(CROSS(PDI,ADX) AND CROSS(PDI,ADXR) AND MDI<REF(MDI,1) AND ADX>REF(ADX,1) AND ADXR>REF(ADXR,1)
AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND
ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45,48,'牛'),COLORRED;
升1:=CROSS(ADXR,20) AND ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60;
升2:=CROSS(ADX,20) AND ATAN((ADX/REF(ADX,1)-1)*100)*180/3.1416>60;
升3:=CROSS(PDI,20) AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60;
升4:=CROSS(20,MDI) AND ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45;
反降:=MDI<REF(MDI,1) AND ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45;
升:=升1 OR 升2 OR 升3 OR 升4;
DRAWTEXT(升 AND 反降 AND ADX>20 AND ADXR>20 AND PDI>20 AND ADX>REF(ADX,1) AND PDI>=REF(PDI,1) AND MA(C,5)>REF(MA(C,5),1),46,'升'),COLORRED;
DRAWTEXT(升 AND 反降 AND ADX>20 AND ADXR>20 AND PDI>20 AND ADX>REF(ADX,1) AND PDI>=REF(PDI,1) AND MA(C,5)>REF(MA(C,5),1),36,'势'),COLORRED;
DRAWTEXT(ADX<REF(ADX,1) AND ADXR<REF(ADXR,1) AND PDI<REF(PDI,1) AND MDI>REF(MDI,1)
AND MA(C,5)<REF(MA(C,5),1),44,'降'),COLORGREEN;
DRAWICON(CROSS(PDI,MDI),PDI,1);
DRAWICON(CROSS(MDI,PDI),MDI,2);
DRAWTEXT(CROSS(PDI,ADXR) AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND MDI<=REF(MDI,1) AND MA(C,5)>REF(MA(C,5),1) AND PDI>MDI,22,'短'),COLORRED;
DRAWTEXT(CROSS(PDI,ADXR) AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND MDI<=REF(MDI,1) AND MA(C,5)>REF(MA(C,5),1) AND PDI>MDI,18,'升'),COLORRED;
{黄金坑}
RR1:=MA(CLOSE,27);
RR2:=(CLOSE-RR1)/RR1*100;
RRA:=MA(RR2,2);
RRB:=BARSLAST(CROSS(-10,RRA)=1);
RRD:=RRA<-10 AND RRB>3;
黄金坑:=IF(RRD,-120,0);
{CCI}
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,NC))/(0.015*AVEDEV(TYP,NC));
DRAWTEXT(CROSS(CCI,0),66,'上'),COLORRED;
DRAWTEXT(CROSS(0,CCI),66,'下'),COLORGREEN;
DRAWTEXT(CROSS(CCI,100),56,'突'),COLORRED;
DRAWTEXT(CROSS(100,CCI),56,'落'),COLORGREEN;
DRAWTEXT(CROSS(100,CCI) AND MA(C,20)>REF(MA(C,20),1),60,'暂'),COLORGREEN;
叉1:=CROSS(ADX,0) AND ATAN((ADX/REF(ADX,1)-1)*100)*180/3.1416>60;
叉2:=CROSS(ADXR,0) AND ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60;
叉3:=CROSS(20,PDI) AND ATAN(((2*REF(PDI,1)-PDI)/REF(PDI,1)-1)*100)*180/3.1416>45;
叉4:=CROSS(MDI,20) AND ATAN((MDI/REF(MDI,1)-1)*100)*180/3.1416>45;
叉:=叉1 OR 叉2 OR 叉3 OR 叉4;
逆势:=MDI>REF(MDI,1) AND ATAN((MDI/REF(MDI,1)-1)*100)*180/3.1416>45 AND MDI>20;
DRAWTEXT(叉 AND 逆势 AND PDI<20 AND MDI>20 AND ADX>20 AND ADXR>20,54,'跌'),COLORGREEN;
DRAWTEXT(叉 AND 逆势 AND PDI<20 AND MDI>20 AND ADX>20 AND ADXR>20,50,'势'),COLORGREEN;
跌角1:=ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60 AND ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60
AND ATAN((MDI/REF(MDI,1)-1)*100)*180/3.1416>60 AND ADXR>20 AND ADX>20 AND MDI>20 AND MDI>REF(MDI,1);
DRAWTEXT(跌角1 AND ATAN(((2*REF(PDI,1)-PDI)/REF(PDI,1)-1)*100)*180/3.1416>45 AND MA(C,10)<REF(MA(C,10),1),34,'大'),COLORGREEN;
DRAWTEXT(跌角1 AND ATAN(((2*REF(PDI,1)-PDI)/REF(PDI,1)-1)*100)*180/3.1416>45 AND MA(C,10)<REF(MA(C,10),1),30,'跌'),COLORGREEN;
潜伏:=CROSS(PDI,MDI) AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND
MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2) AND EXIST(粘合度<=8,5);
潜伏2:=CROSS(PDI,MDI) AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND
MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2) AND EXIST(粘合度<=8,5) AND EXIST(黄金坑,10);
DRAWTEXT(潜伏,14,'潜'),COLORYELLOW;
DRAWTEXT(潜伏,10,'伏'),COLORYELLOW;
DRAWTEXT(潜伏2,6,'潜'),COLORRED;
DRAWTEXT(潜伏2,2,'伏'),COLORRED;

通达信潜伏黄金坑指标公式

 

通达信潜伏黄金坑指标公式的选股公式如下:

http://www.gupang.com/201909/48255.html

http://www.gupang.com/201909/48256.html

http://www.gupang.com/201909/48257.html

http://www.gupang.com/201909/48258.html

http://www.gupang.com/201909/48259.html

相关文章