载入中...
在线检测未来函数
载入中...

通达信射日箭指标公式

来源:Internet,编辑:股旁网,2019-11-01

MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA90:=MA(C,90);
MA120:=MA(C,120);
MA250:=MA(C,250);
VAR1:=EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3);
ABV:=MA(SUM(IF(C>REF(C,1),V,IF(C<REF(C,1),-V,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=C-REF(C,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MMA:=C-REF(C,1);
MMB:=100*EMA(EMA(MMA,9),9)/EMA(EMA(ABS(MMA),9),9);
MMC:=MA(MMB,5);
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
V1:=(H+O+L+(2)*(C))/(5);
V2:=REF(V1,1);
V3:=MAX(V1-V2,0);
V4:=ABS(V1-V2);
V5:=SMA(V3,10,1);
V6:=SMA(V4,10,1);
V8:=COUNT(((V5)/(V6)<0.2),5);
V9:=COUNT((LLV(V1,10)=V1),10);
主力进出:=(MMS>REF(MMS,1) AND MMB>REF(MMB,1) AND CROSS(ABV,M2) AND ABV>REF(ABV,1) AND M1>REF(M1,1) AND M2>REF(M2,1));
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(MMB,MMC);
TJ:=REF(C,1)>REF(O,1) AND V>REF(V,1);
精准买卖:=V8>=1 AND V9>=1 AND C>O AND TJ AND MMS>MML AND CROSS(ABV,M2);
短线买点:=V8>=1 AND V9>=1 AND C>O AND TJ AND CROSS(MMS,MML) AND ABV>REF(ABV,1);
中线买点:=V8>=1 AND V9>=1 AND C>O AND TJ AND ABV>REF(ABV,1) AND MMS>MML AND CROSS(MMM,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
主进主买:=ABV>M2 AND MMB>MMC AND CROSS(MMS,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
主力买卖:=精准买卖 OR 短线买点 OR 中线买点 OR 主进主买;
射日:=S<X AND Y<X AND MMS>MML AND ABV>M1 AND CROSS(S,Y);
主力轨迹:=ABV>M2 AND MMS>MML AND CROSS(MMB,MMC) AND MMB>REF(MMB,1) AND MMC>REF(MMC,1);
SR:=射日>0;
SR11:=EXIST(主力买卖,10);
SR12:=EXIST(主力进出,10);
SR13:=EXIST(主力轨迹,10);
YGQFSRJ:=SR11 OR SR12 OR SR13 ;
YGQFXS:=MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND C>MA10 AND C>MA20 AND C>MA120;
DT1:=MA5>MA10 AND MA10>MA20 AND MA20>MA30;
射日箭:=SR AND YGQFSRJ AND YGQFXS AND DT1;
STICKLINE(射日箭,0,1,1,0),COLORYELLOW;
DRAWICON(射日箭,0.9,1);
DRAWICON(射日箭,0.1,34);
DRAWTEXT(射日箭,0.8,' 射'),COLORRED;
DRAWTEXT(射日箭,0.6,' 日'),COLORRED;
DRAWTEXT(射日箭,0.4,' 箭'),COLORRED;

通达信射日箭指标公式

 

通达信射日箭指标公式的选股公式如下:

http://www.gupang.com/201911/48638.html

相关文章