在线检测未来函数

通达信节节升高指标公式

来源:Internet,编辑:股旁网,2019-11-22

本文指标含有选股公式如下:

http://www.gupang.com/201911/48933.html

VAR1:=IF(NAMELIKE(7),0,1);
VAR2:=DYNAINFO(8)>0;
VAR3:=IF(NAMELIKE(8),0,1);
VAR4:=VAR1 AND VAR2 AND VAR3;
VAR5:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR6:=SMA(VAR5,9,1);
VAR7:=SMA(VAR5,30,1);
VAR8:=CROSS(VAR6,VAR7);
VAR9:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
VAR10:=COUNT(VAR8,21)>=2;
VAR11:=VAR6<20;
VAR12:=MA(CLOSE,10)>REF(MA(CLOSE,10),1);
VAR13:=COUNT(VAR9<(-8),20)>=1 AND VAR9<=0 AND COUNT(VAR9<=0,4)>=2;
VAR14:=VAR10 AND VAR11 AND VAR12 AND VAR13;
VAR15:=VAR14 AND COUNT(VAR14,10)=1;
VAR16:=REF(CLOSE,1);
VAR17:=SMA(MAX(CLOSE-VAR16,0),7,1)/SMA(ABS(CLOSE-VAR16),7,1)*100;
VAR18:=SMA(MAX(CLOSE-VAR16,0),13,1)/SMA(ABS(CLOSE-VAR16),13,1)*100;
VAR19:=BARSLAST(VAR18<20)<=3 AND CROSS(VAR17,VAR18);
VAR20:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100<(-12.5);
VAR21:=LLV(LOW,5);
VAR22:=HHV(HIGH,5);
VAR23:=EMA((CLOSE-VAR21)/(VAR22-VAR21)*100,4);
VAR24:=EMA(0.667*REF(VAR23,1)+0.333*VAR23,2);
VAR25:=VAR19 AND VAR20 AND CROSS(VAR23,VAR24) AND VAR23<=25;
VAR26:=DMA(EMA(CLOSE,14),SUM(VOL,5)/3/CAPITAL);
VAR27:=(CLOSE-VAR26)/VAR26*100;
VAR28:=VAR27<(-38);
VAR29:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR30:=(CLOSE-VAR29)/VAR29*100;
VAR31:=REF(VAR30,1)<(-37) AND VAR30>REF(VAR30,1) AND REF(VAR30,1)<REF(VAR30,2) AND REF(VAR30,2)-REF(VAR30,1)>1;
VAR32:=VAR28 OR VAR31 AND VOL/CAPITAL*100<6;
VAR33:=VAR32 AND COUNT(VAR32,10)=1;
VAR34:=(HIGH-LOW)/HIGH*100+(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR35:=EMA(MA(VAR34,50),5);
VAR36:=VAR35>LLV(VAR35,5)*1.01 AND REF(VAR35,1)<REF(LLV(VAR35,5),1)*1.01 AND LLV(VAR35,50)=LLV(VAR35,5);
VAR37:=LLV(LOW,5)=LLV(LOW,50) AND LLV(LOW,5)<HHV(LOW,70)*0.5;
VAR38:=VAR36 AND VAR37;
VAR39:=VAR15 OR VAR25 OR VAR33 OR VAR38 AND VAR4;
STICKLINE(VAR39,0,90,1,0),COLORBROWN;
STICKLINE(VAR39,0,90,0.1,0),COLORRED;
VAR40:=CLOSE/REF(CLOSE,1)>1.05 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
VAR41:=FILTER(VAR40,28)*100;
VAR42:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND CLOSE>REF(CLOSE,1),91,0);
VAR43:=FILTER(VAR42>90,45) AND FILTER(VAR42>90,35) AND VAR41>0;
VAR44:=VAR43 AND COUNT(VAR43,60)=1;
STICKLINE(VAR44,75,66,1,0),COLORRED;
STICKLINE(VAR44,66,57,1,0),COLORMAGENTA;
STICKLINE(VAR44,57,48,2,0),COLORGREEN;
STICKLINE(VAR44,48,39,2,0),COLORBLUE;
STICKLINE(VAR44,30,21,3,0),COLORBROWN;
STICKLINE(VAR44,39,30,3,0),COLORCYAN;
STICKLINE(VAR44,21,12,4,0),COLORYELLOW;
STICKLINE(VAR44,12,3,4,0),COLORWHITE;
DRAWICON(VAR44,70,13);

通达信节节升高指标公式

 

相关文章