在线检测未来函数

通达信牛股启动主图及选股指标公式

来源:Internet,编辑:股旁网,2020-01-14

代码1:=CODELIKE('603596');{分别在年、月、日及买入价位、买入股数等处填入实际数据}
买入时间1:=YEAR{年}=2019 AND MONTH{月}=8 AND DAY{日}=15;
买入价位1:=13.45;
买入股数1:=8000;
天数1:=BARSLAST(买入时间1);
{第二只个股,填入代码、买入时间、价位及股数}
代码2:=CODELIKE('300356');{在[0]位置处填写个股代码}
买入时间2:=YEAR{年}=2019 AND MONTH {月}=12 AND DAY{日}=30;
买入价位2:=7.78;
买入股数2:=9000;
天数2:=BARSLAST(买入时间2);
{第三只个股,填入代码、买入时间、价位及股数}
代码3:=CODELIKE('0');
买入时间3:=YEAR{年}=0 AND MONTH{月}=0 AND DAY{日}=0;
买入价位3:=0;
买入股数3:=0;
天数3:=BARSLAST(买入时间3);
{1}
买入个股时间1:=IF(代码1,买入时间1,0);
买入价格1:=IF(买入个股时间1,买入价位1,0);
买入价1:=REF(买入价位1,BARSLAST(买入个股时间1));
现价1:=IF(BARSLAST(买入个股时间1)+1>=1,CONST(C),0);
最高价条件1:=IF(BARSLAST(买入个股时间1)+1>=1,H=HHV(H,BARSLAST(买入个股时间1)+1),0);
最高价横线1:=IF(BARSLAST(最高价条件1)>=0 AND BARSLAST(买入个股时间1)+1>=1,CONST(REF(H,BARSLAST(最高价条件1))),0);
最低价条件1:=IF(BARSLAST(买入个股时间1)+1>=1,L=LLV(L,BARSLAST(买入个股时间1)+1),0);
最低价横线1:=IF(BARSLAST(最低价条件1)+1>=1 AND BARSLAST(买入个股时间1)+1>=1,
CONST(REF(L,BARSLAST(最低价条件1))),0);
{2}
买入个股时间2:=IF(代码2,买入时间2,0);
买入价格2:=IF(买入个股时间2,买入价位2,0);
买入价2:=REF(买入价位2,BARSLAST(买入个股时间2));
现价2:=IF(BARSLAST(买入个股时间2)+1>=1,CONST(C),0);
最高价条件2:=IF(BARSLAST(买入个股时间2)+1>=1,H=HHV(H,BARSLAST(买入个股时间2)+1),0);
最高价横线2:=IF(BARSLAST(最高价条件2)+1>=1 AND BARSLAST(买入个股时间2)+1>=1,
CONST(REF(H,BARSLAST(最高价条件2))),0);
最低价条件2:=IF(BARSLAST(买入个股时间2)+1>=1,L=LLV(L,BARSLAST(买入个股时间2)+1),0);
最低价横线2:=IF(BARSLAST(最低价条件2)+1>=1 AND BARSLAST(买入个股时间2)+1>=1,
CONST(REF(L,BARSLAST(最低价条件2))),0);
{3}
买入个股时间3:=IF(代码3,买入时间3,0);
买入价格3:=IF(买入个股时间3,买入价位3,0);
买入价3:=REF(买入价位3,BARSLAST(买入个股时间3));
现价3:=IF(BARSLAST(买入个股时间3)+1>=1,CONST(C),0);
最高价条件3:=IF(BARSLAST(买入个股时间3)+1>=1,H=HHV(H,BARSLAST(买入个股时间3)+1),0);
最高价横线3:=IF(BARSLAST(最高价条件3)+1>=1 AND BARSLAST(买入个股时间3)>=0,
CONST(REF(H,BARSLAST(最高价条件3))),0);
最低价条件3:=IF(BARSLAST(买入个股时间3)+1>=1,L=LLV(L,BARSLAST(买入个股时间3)+1),0);
最低价横线3:=IF(BARSLAST(最低价条件3)+1>=1 AND BARSLAST(买入个股时间3)+1>=1,
CONST(REF(L,BARSLAST(最低价条件3))),0);
持股数量【股】:IF(代码1,买入股数1,IF(代码2,买入股数2,IF(代码3,买入股数3,DRAWNULL))),NODRAW;
持股天数:IF(代码1,天数1,IF(代码2,天数2,IF(代码3,天数3,DRAWNULL))),NODRAW;
最高价:=IF(代码1,最高价横线1,IF(代码2,最高价横线2,IF(代码3,最高价横线3,DRAWNULL))),COLOR00FFFF,LINETHICK2;
最低价:=IF(代码1,最低价横线1,IF(代码2,最低价横线2,IF(代码3,最低价横线3,DRAWNULL))),COLORFF0000,LINETHICK2;
买入价:IF(代码1,买入价1,IF(代码2,买入价2,IF(代码3,买入价3,DRAWNULL))),COLORFF00FF,LINETHICK4;
现价:IF(代码1,现价1,IF(代码2,现价2,IF(代码3,现价3,DRAWNULL))),COLORFFFF00,LINETHICK2;
买入时间:=IF(代码1,买入时间1,IF(代码2,买入时间2,IF(代码3,买入时间3,DRAWNULL)));
股数:=IF(代码1,买入股数1,IF(代码2,买入股数2,IF(代码3,买入股数3,DRAWNULL)));
DRAWBAND(现价,RGB(150,0,0),买入价,RGB(0,180,180));
DRAWBAND(买入价,RGB(0,180,180),买入价,RGB(0,180,180));
DRAWBAND(现价,RGB(180,0,180),现价,RGB(180,0,180));
DRAWKLINE(H,O,L,C);
D1:=YEAR AND MONTH AND DAY;
AA1:=STRCAT(CON2STR(YEAR,0),'年');
AA2:=STRCAT(CON2STR(MONTH,0),'月');
AA3:=STRCAT(CON2STR(DAY,0),'日');
AA4:=STRCAT('【',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三','日'))));
AA5:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),'】');
DRAWTEXT_FIX(D1,0.78,0,0,AA5),COLORFFFF00;
现赢利:=(现价-买入价)/买入价*100;
金额:=买入价*现赢利*股数/100;
WW3:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT('【','现赢利'),'】'),':'),CON2STR(现赢利,2)),'﹪');
WW4:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT('【','现亏损'),'】'),':'),CON2STR(现赢利,2)),'﹪');
WW5:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT('【','利润'),'】'),':'),CON2STR(金额,0)),'元');
WW6:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT('【','亏损'),'】'),':'),CON2STR(金额,0)),'元');
DRAWTEXT_FIX(HHV(H,80)=最高价 AND 现价>=买入价,0.64,1,0,WW3),COLORRED;
DRAWTEXT_FIX(ISLASTBAR AND (HHV(H,80)>最高价 OR HHV(H,80)<最高价) AND 最高价>0 AND
现价>=买入价,0.67,1,0,WW3),COLORRED;
DRAWTEXT_FIX(HHV(H,80)=最高价 AND 现价<买入价,0.64,1,0,WW4),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR AND (HHV(H,80)>最高价 OR HHV(H,80)<最高价) AND 最高价>0 AND
现价<买入价,0.67,1,0,WW4),COLORGREEN;
DRAWTEXT_FIX(HHV(H,80)=最高价 AND 现价>=买入价,0.8,1,0,WW5),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND (HHV(H,80)>最高价 OR HHV(H,80)<最高价) AND 最高价>0 AND
现价>=买入价,0.83,1,0,WW5),COLORYELLOW;
DRAWTEXT_FIX(HHV(H,80)=最高价 AND 现价<买入价,0.8,1,0,WW6),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND (HHV(H,80)>最高价 OR HHV(H,80)<最高价) AND 最高价>0 AND
现价<买入价,0.83,1,0,WW6),COLORWHITE;
YDD:=L=REFX(L,1) OR L=REFX(L,2) OR L=REFX(L,3) OR L=REFX(L,4) OR L=REFX(L,5) OR L=REFX(L,6) OR L=REFX(L,7) OR L=REFX(L,8) OR L=REFX(L,9) OR L=REFX(L,10) OR L=REFX(L,11) OR L=REFX(L,12) OR L=REFX(L,13) OR
L=REFX(L,14) OR L=REFX(L,15) OR L=REFX(L,16) OR L=REFX(L,17) OR L=REFX(L,18) OR L=REFX(L,19) OR L=REFX(L,20);
EDD:=BARSLAST(YDD)>0 AND L=REF(L,BARSLAST(YDD));
DRAWLINE(YDD AND CURRBARSCOUNT<20,L,EDD AND CURRBARSCOUNT<20,L,1)COLORYELLOW;
{======================================================}
高点位:=REFDATE(HHV(H,350),DATE);
低点位:=REFDATE(LLV(L,350),DATE);
低位价:=REF(L,BARSLAST(低点位=L)),COLORGREEN,NODRAW;
高位价:=REF(H,BARSLAST(高点位=H)),COLORRED,NODRAW;
曾最大涨幅:=(高位价-低位价)/低位价*100;
当前涨幅:=(C-低位价)/低位价*100;
ZFA:=CON2STR(CONST(曾最大涨幅),2);
ZFB:=CON2STR(CONST(当前涨幅),2);
ZFC:=STRCAT('【曾最大涨幅】:',ZFA);
ZFD:=STRCAT(ZFC,'﹪');
ZFE:=STRCAT(ZFD,'【当前总涨幅】:');
ZFF:=STRCAT(ZFE,ZFB);
ZFG:=STRCAT(ZFF,'﹪');
DRAWTEXT_FIX(ISLASTBAR,0,1,0,'▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0,1,0,ZFG),COLORYELLOW;
{========================额外==========================}
Z11:=STRCAT(DYBLOCK,' ');
Z22:=STRCAT(Z11,HYBLOCK);
Z33:=STRCAT(Z22,' ');
Z44:=STRCAT(Z33,GNBLOCK);
Z55:=STRCAT(Z44,' ');
Z66:=STRCAT(Z55,FGBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.1350,0.01,0,STRCAT(Z66,ZHBLOCK)),COLORCYAN;
DRAWTEXT_FIX(1,0.45,0.065,0,STRCAT('【自定板块】:',ZDBLOCK)),COLORYELLOW;
MA89:MA(C,89)COLORGREEN;
牛股启动线D:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,LINETHICK2,;
牛股启动线L:(MA(CLOSE,6)+MA(CLOSE,18)+MA(CLOSE,54)+MA(CLOSE,162))/4,COLORCYAN,LINETHICK2;
DRAWICON(CROSS(牛股启动线D,牛股启动线L),L*0.985,7);
{九转序列}
A1:=C>REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,H*1.002,VAR2STR(AY,0)),COLORRED;
DRAWTEXT(NT=9,H*1.002,'9'),COLORLIGREEN;
B1:=C<REF(C,4);
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,L*0.998,VAR2STR(AY1,0))COLORLIGREEN;
DRAWTEXT(NT0=9,L*0.998,'9'),COLORLIMAGENTA;

{
选股公式:

牛股启动线D:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,LINETHICK2,;
牛股启动线L:=(MA(CLOSE,6)+MA(CLOSE,18)+MA(CLOSE,54)+MA(CLOSE,162))/4,COLORCYAN,LINETHICK2;
CROSS(牛股启动线D,牛股启动线L);
}

通达信牛股启动主图及选股指标公式

 

通达信牛股启动主图及选股指标公式的选股公式如下

相关文章