载入中...
在线检测未来函数
载入中...

通达信突破牛主图指标公式

来源:Internet,编辑:股旁网,2020-02-21

短:MA(CLOSE,13),LINETHICK2,COLORYELLOW;
中:MA(CLOSE,55),COLORMAGENTA;
界:MA(CLOSE,144),COLORGREEN;
长:MA(CLOSE,377),COLORLIMAGENTA;
超:MA(CLOSE,453),COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,短,' 短13'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,中,' 中55'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,界,' 界144'),COLORGREEN;
DRAWTEXT(ISLASTBAR,长,' 长377'),COLORLIMAGENTA;
DRAWTEXT(ISLASTBAR,超,' 超453'),COLORRED,LINETHICK2;
{牛线等突破}
LT:=LLVBARS(L,60);
LTT:=BARSLAST(CURRBARSCOUNT=CONST(LT)+1);
HT:=FINDHIGHBARS(H,LT+1,60,1);
AA1:DRAWLINE(CURRBARSCOUNT=CONST(HT)+1,H,ISLASTBAR,REF(H,HT),0),COLORYELLOW,LINETHICK2;
TT:=BARSLAST(CURRBARSCOUNT=CONST(HT)+1);
AA:=CROSS(C,CONST(AA1));
TJAA:=COUNT(AA,TT+1)=1 AND AA;
TJ1AA:=COUNT(V<MA(V,277),TT+1) ;
BL:=TJ1AA/(TT+1)*100;
XG:=TJAA AND TT>40 AND BL>70;
XGT:=BARSLAST(CURRBARSCOUNT=CONST(BARSLAST(XG))+1);
ZH:=REF(H,TT);
YL:=REF(L,LTT);
XC:=REF(C,XGT);
YZ:=(XC-YL)/YL*100;
ZBL:=YZ/REF(LTT,XGT);
XGA:=XG AND ZBL<2.95;
DRAWICON(XGA,L*0.95,9);
DRAWTEXT(CURRBARSCOUNT=1,AA1*0.999,STRCAT('------------牛线',CON2STR(AA1,2))),COLORYELLOW;
DRAWTEXT(TT=0,REF(H,TT)*1.0007,VARCAT(VARCAT('牛线等突破 : ',VAR2STR(REF(H,TT),2)),'元'))COLORWHITE;
XG11:=COUNT(CROSS(C>=AA1,0.5),TT+1)=1 AND CROSS(C>=AA1,0.5) AND LT>1.5;
DRAWICON(CROSS(C,AA1) AND CURRBARSCOUNT<CONST(TT)+1,L,23);
DRAWTEXT(XG11,(H* 0.999),'过牛线'),COLORYELLOW;
STICKLINE( XG11,C,O,5,1)COLOR8080FF;
STICKLINE( XG11,C,O,0.7,1)COLORYELLOW;
ZNOTEXT1:IF(C>=AA1,AA1,DRAWNULL),LINETHICK5,COLOR8000FF;
IF(C>=AA1,AA1,DRAWNULL),DOTLINE,COLORFFFFFF;
ZNOTEXT2:IF(C<AA1,AA1,DRAWNULL),LINETHICK2,COLORGREEN;
IF(C<AA1,AA1,DRAWNULL),DOTLINE,COLORRED;
{小牛}
T:=FINDHIGHBARS(H,60,30,1);
A:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,H,ISLASTBAR,REF(H,T),0),COLORMAGENTA;
TT1:=BARSLAST(C>A*1.014 AND L<A);
TA:=BARSLAST(CROSS(A!=DRAWNULL,0.5));
TJ:=VOL=HHV(VOL,T+1) AND TA>28;
TJ1:=COUNT(EXPMA(C,2)>=A,TA+1)=1 AND EXPMA(C,2)>=A*1.01;
E13:=EXPMA(C,TA+1);
CJ:=(A/E13-1) *100 ;
HH:=HHV(CJ,10);
JXG:=COUNT(TT=0,T+1)=1 AND TT1=0 AND TJ AND TJ1 AND HH<20;
STICKLINE(JXG,H,L,0,0),COLORFF00FF;
STICKLINE(JXG,C,O,3,0),COLOR990099;
STICKLINE(JXG,C,O,2,0),COLORBB00BB;
STICKLINE(JXG,C,O,1,0),COLORDD00DD;
STICKLINE(JXG,C,O,0.3,0),COLORFF00FF;
DRAWICON(JXG,L*0.99,25);
DRAWTEXT(TA=0,A*1.01,STRCAT(STRCAT('小牛等突破:',VAR2STR(REF(A,TA),2)),'元')),COLORMAGENTA;
X_1:=MA(CLOSE,5);
X_2:=MA(CLOSE,10);
X_3:=EMA(CLOSE,14);
X_4:=EXPMA(EXPMA(CLOSE,50),1);
X_5:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_6:=OPEN/REF(CLOSE,1)<1.098;
X_7:=X_1>X_2 AND X_3>X_4;
X_8:=CROSS(MA(CLOSE,5),MA(CLOSE,30)) AND X_5>1.8;
X_9:=IF(CLOSE>REF(CLOSE,1),88,0);
X_10:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_9>0,91,0);
X_11:=FILTER(X_10>1,5);
X_12:=CLOSE=HHV(CLOSE,20);
X_13:=BARSLAST(X_12);
X_14:=IF(X_13>0,REF(CLOSE,X_13),REF(CLOSE,X_13));
X_15:=CROSS(CLOSE,REF(X_14,1));
X_16:=X_15 AND COUNT(X_15,5)=1;
强龙介入选股:X_16 AND X_11 AND X_7 AND X_8 AND X_6;
{涨跌停K线}
STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORRED;
STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORGREEN;

通达信突破牛主图指标公式

 

通达信突破牛主图指标公式的选股公式如下:

http://www.gupang.com/202002/50192.html

相关文章