载入中...
在线检测未来函数
载入中...

通达信短绝底强升追涨指标公式

来源:Internet,编辑:股旁网,2020-02-21

MA5:=MA(VOL,5);
MA8:=MA(VOL,13);
MA144:=MA(VOL,144);
AA:=(O+H+L+C)/4;
BB:=MA(AA,3);
CC:=SUM(IF(AA>REF(AA,1),AA*VOL,0),4)/SUM(IF(AA<REF(AA,1),AA*VOL,0),4);
DD:=REF(100-(100/(1+CC)),1);
LA:=REF(CLOSE,1);
LB:=((SMA(MAX((CLOSE - LA),0),5,1) / SMA(ABS((CLOSE - LA)),5,1)) * 100);
LC:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
LE:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
LF:=SUM(IF(((LC > 0) AND (LC > LD)),LC,0),10);
LG:=SUM(IF(((LD > 0) AND (LD > LC)),LD,0),10);
LH:=((LF * 100) / LE);
LI:=((LG * 100) / LE);
LJ:=MA(((ABS((LI - LH)) / (LI + LH)) * 100),5);
AV:=(LB + LJ);
LK:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
LL:=(LB - LK);
LM:=(AV + LL);
向导线:=LLV(LM,1);
T:=IF((BARSCOUNT(C) > 7),(100)*((MA(C,7))/(LLV(MA(C,7),7)) - 1),1);
N:=IF((T > 0.35),6,65);
W:=((-((100)*(HHV(H,21) - C))/(HHV(HIGH,21) - LLV(L,21)))),LINETHICK2;
RV2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG2:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J01:=(HIGH+LOW)/2;
QJ1:=EMA(J01,3);
A1:=HHV(AA,15);
A2:=LLV(AA,15);
A3:=A1-A2;
A4:=EMA((AA-A2)/A3,2)*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
J11:=IF(CLOSE>QJ1,VOL,0);
J21:=IF(CLOSE<QJ1,VOL,0);
BB1:=MA(SUM(J11-J21,22),3);
VAR03:=(BB-CC);
股市黑客:=SMA(RV,3,1);
普通投资者:=SMA(股市黑客,5,1);
KK1:=EMA(SMA(RG,3,1),2),COLORFFFFFF;
DD2:=SMA(KK1,3,1),COLOR00FFFF;
RSV3:=(((CLOSE - LLV(LOW,8)) / (HHV(HIGH,8) - LLV(LOW,8))) * 100);
K11:=SMA(RSV3,3,1);
D11:=SMA(K11,3,1);
KK5:=INTPART(SMA(RSV3,3,1));
DD5:=INTPART(SMA(K11,3,1));
JJ5:=INTPART(((3 * K11) - (2 * D11)));
N1:=(KK5 + DD5);
KX:=(N1 < 25);
KX1:=REF(KX,29);
XX:=(N1 < 18);
XX1:=REF(XX,31);
XXX:=(N1 < 23);
XXX1:=REF(XXX,198);
KP:=((KX1 OR XX1) OR XXX1);
B1:=HHV(AA,60);
B2:=LLV(AA,60);
B3:=B1-B2;
B4:=EMA((AA-B2)/B3,2)*100;
KA1:=(((REF(CLOSE,2) / REF(OPEN,2)) < 0.95) AND (REF(CLOSE,2) < REF(CLOSE,3)));
KA2:=(((REF(OPEN,1) < REF(CLOSE,2)) AND (REF(CLOSE,
1) > REF(CLOSE,2))) AND (REF(CLOSE,1) > ((REF(CLOSE,2) + REF(OPEN,2)) / 2)));
KA3:=(CLOSE > REF(CLOSE,1));
KA4:=(LLV(LOW,13) = REF(LOW,1));
KP2:=(COUNT((((KA1 AND KA2) AND KA3) AND KA4),3) > 0);
KP3:=CROSS((-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))),80);
KD3:=(N1 < 45);
KD1:=(((((REF(KD3,180) OR REF(KD3,179)) OR REF(KD3,
31)) OR REF(KD3,29)) OR REF(KD3,13)) OR REF(KD3,11));
KP4:=((KP2 AND KP3) AND KD1);
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
KP5:=2*(DIFF-DEA);
KD2:=((((REF(KD3,180) OR REF(KD3,261)) OR REF(KD3,98)) OR REF(KD3,77)) OR REF(KD3,1));
KP6:=((KP2 AND KP5) AND KD2);
KP7:=(N1 < 34);
KP8:=REF(KP7,11);
KP9:=(N1 < 45);
KP10:=((REF(KP9,83) AND KP8) AND KP2);
KP11:=(N1 < 38);
KP12:=((REF(KP11,19) AND REF(KP11,32)) AND KP2);
KP13:=((REF(KP9,28) AND REF(KP11,101)) AND KP2);
KP14:=(N1 < 43);
KP15:=((REF(KP14,28) AND REF(KP14,189)) AND KP2);
I:=((((((REF(CLOSE,2) / REF(OPEN,2)) < 0.95) AND (REF(OPEN,1) < REF(CLOSE,
2))) AND ((ABS((REF(OPEN,1) - REF(CLOSE,1))) / REF(CLOSE,
1)) < 0.03)) AND ((CLOSE / OPEN) > 1.05)) AND (CLOSE > REF(CLOSE,2)));
I1:=2*(DIFF-DEA);
T3:=(N1 < 40);
T4:=((REF(T3,34) OR REF(T3,28)) OR REF(T3,57));
C1:=HHV(AA,240);
C2:=LLV(AA,240);
C3:=C1-C2;
C4:=EMA((AA-C2)/C3,2)*100;
KP16:=((I AND I1) AND T4);
P1:=13;P2:=5;
短期:A4,COLORGREEN;
中期:B4,COLORYELLOW;
长期:C4,COLORFF00FF;
SSRCJL:=EMA(VOL,13);
SSRCJE:=EMA(AMOUNT,13);
SSRCBJX:=((SSRCJE / SSRCJL) / 100);
SSRGL:=(((CLOSE - SSRCBJX) / SSRCBJX) * 100);
趋:=SSRGL<(0-18);
势:=SSRGL<(0-14);
而:=SSRGL<(0-10);
为:=SSRGL<(0-6);
STICKLINE(短期>90 AND 中期>70,86,94,1,0),COLOR00FF00;
STICKLINE(短期<5 AND 中期<30,0,8,1,0);
IF(FILTER(中期<REF(中期,1)AND 中期>90 AND BB<REF(BB,1),5),80,100),COLORBLUE,LINETHICK2;
IF(FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5),20,0),COLORRED,LINETHICK2;
D1:=中期>REF(中期,1) AND 短期>REF(短期,1)AND 长期>REF(长期,1)AND 长期<8 AND 中期<10 AND 短期<15;
D2:=CROSS(短期,中期) AND 中期<8;
D3:=CROSS(短期,长期) AND 长期<8 AND 中期<20;
绝对底④:IF((SSRGL < (0 - 18)),23,0),LINETHICK3,COLORBLUE;
DRAWTEXT((FILTER((SSRGL < (0 - 18)),7)),25,'④'),COLORCYAN;
大底③:IF((SSRGL < (0 - 14)),84,0),LINETHICK3,COLORRED;
DRAWTEXT((FILTER((SSRGL < (0 - 14)),7)),86.5,'③'),COLORMAGENTA;
中底②:IF((SSRGL < (0 - 10)),60,0),LINETHICK3,COLORMAGENTA;
DRAWTEXT((FILTER((SSRGL < (0 - 10)),7)),64.5,'②'),COLORCYAN;
短底①:IF((SSRGL < (0 - 6)),44,0),LINETHICK3,COLORBROWN;
DRAWTEXT((FILTER((SSRGL < (0 - 6)),7)),44,'①'),COLORLIGRAY;
WWWGUPANGCOM:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
DRAWICON(FILTER((D1 OR D2 OR D3) AND DD<15 AND C>REF(C,1),5),5,1);
DRAWICON(FILTER((中期<REF(中期,1)AND 短期<REF(短期,1)AND 长期<REF(长期,
1)AND 中期>95 AND 短期>85)OR (长期>100 AND 中期>100 AND 短期>100),5),95,2);
¥①:IF(KP AND KP2 OR KP4 OR KP6 OR KP10 OR KP12 OR KP13 OR KP15 OR KP16,60,0),LINETHICK3,COLORLIGRAY;
¥②:IF(CROSS(向导线,(0-3)),21,0),LINETHICK3,COLORLIGREEN;
¥③:IF(CROSS(W,-2) AND CROSS(股市黑客,普通投资者) AND CROSS(KK1,DD2),60,0),LINETHICK3,COLORLICYAN;
DRAWTEXT(KP AND KP2 OR KP4 OR KP6 OR KP10 OR KP12 OR KP13 OR KP15 OR KP16,60,'★★★'),COLORYELLOW;
DRAWTEXT(CROSS(W,-2) AND CROSS(股市黑客,普通投资者) AND CROSS(KK1,DD2),60,'强势追涨'),COLORYELLOW;
强弱分界:50,POINTDOT,COLORWHITE;
警戒区:90,LINETHICK1,COLORWHITE;
安全区:20,COLORFFFF00;
DRAWICON(CROSS(向导线,(0-3)),13,5);
DRAWICON(CROSS(235,向导线),80,6);

通达信短绝底强升追涨指标公式

 

通达信短绝底强升追涨指标公式的选股公式如下:

http://www.gupang.com/202002/50193.html

http://www.gupang.com/202002/50194.html

http://www.gupang.com/202002/50195.html

http://www.gupang.com/202002/50196.html

http://www.gupang.com/202002/50197.html

相关文章